aboutsummaryrefslogtreecommitdiff
path: root/src/pt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/pt/Makefile.am')
-rw-r--r--src/pt/Makefile.am114
1 files changed, 0 insertions, 114 deletions
diff --git a/src/pt/Makefile.am b/src/pt/Makefile.am
deleted file mode 100644
index 10ae04931..000000000
--- a/src/pt/Makefile.am
+++ /dev/null
@@ -1,114 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12plugindir = $(libdir)/gnunet
13
14dist_pkgcfg_DATA = \
15 pt.conf
16
17libexec_PROGRAMS = \
18 gnunet-daemon-pt
19
20gnunet_daemon_pt_SOURCES = \
21 gnunet-daemon-pt.c
22gnunet_daemon_pt_LDADD = \
23 $(top_builddir)/src/vpn/libgnunetvpn.la \
24 $(top_builddir)/src/cadet/libgnunetcadet.la \
25 $(top_builddir)/src/dht/libgnunetdht.la \
26 $(top_builddir)/src/dns/libgnunetdns.la \
27 $(top_builddir)/src/statistics/libgnunetstatistics.la \
28 $(top_builddir)/src/util/libgnunetutil.la \
29 $(GN_LIBINTL)
30
31if HAVE_TESTING
32
33if HAVE_LIBGNURL
34LIB_GNURL=@LIBGNURL@
35CPP_GNURL=@LIBGNURL_CPPFLAGS@
36if LINUX
37 VPN_TEST = \
38 test_gnunet_vpn-4_to_6 \
39 test_gnunet_vpn-6_to_4 \
40 test_gnunet_vpn-6_over \
41 test_gnunet_vpn-4_over \
42 test_gns_vpn
43endif
44else
45if HAVE_LIBCURL
46LIB_GNURL=@LIBCURL@
47CPP_GNURL=@LIBCURL_CPPFLAGS@
48if LINUX
49 VPN_TEST = \
50 test_gnunet_vpn-4_to_6 \
51 test_gnunet_vpn-6_to_4 \
52 test_gnunet_vpn-6_over \
53 test_gnunet_vpn-4_over \
54 test_gns_vpn
55endif
56endif
57endif
58
59endif
60
61check_PROGRAMS = $(VPN_TEST)
62
63if ENABLE_TEST_RUN
64AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
65TESTS = $(check_PROGRAMS)
66endif
67
68EXTRA_DIST = \
69 test_gnunet_vpn.conf \
70 test_gns_vpn.conf
71
72
73
74test_gns_vpn_SOURCES = \
75 test_gns_vpn.c
76test_gns_vpn_LDADD = $(MHD_LIBS) $(LIB_GNURL) \
77 $(top_builddir)/src/namestore/libgnunetnamestore.la \
78 $(top_builddir)/src/identity/libgnunetidentity.la \
79 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
80 $(top_builddir)/src/testing/libgnunettesting.la \
81 $(top_builddir)/src/util/libgnunetutil.la
82test_gns_vpn_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
83
84test_gnunet_vpn_4_over_SOURCES = \
85 test_gnunet_vpn.c
86test_gnunet_vpn_4_over_LDADD = $(MHD_LIBS) $(LIB_GNURL) \
87 $(top_builddir)/src/vpn/libgnunetvpn.la \
88 $(top_builddir)/src/testing/libgnunettesting.la \
89 $(top_builddir)/src/util/libgnunetutil.la
90test_gnunet_vpn_4_over_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
91
92test_gnunet_vpn_6_over_SOURCES = \
93 test_gnunet_vpn.c
94test_gnunet_vpn_6_over_LDADD = $(MHD_LIBS) $(LIB_GNURL) \
95 $(top_builddir)/src/vpn/libgnunetvpn.la \
96 $(top_builddir)/src/testing/libgnunettesting.la \
97 $(top_builddir)/src/util/libgnunetutil.la
98test_gnunet_vpn_6_over_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
99
100test_gnunet_vpn_4_to_6_SOURCES = \
101 test_gnunet_vpn.c
102test_gnunet_vpn_4_to_6_LDADD = $(MHD_LIBS) $(LIB_GNURL) \
103 $(top_builddir)/src/vpn/libgnunetvpn.la \
104 $(top_builddir)/src/testing/libgnunettesting.la \
105 $(top_builddir)/src/util/libgnunetutil.la
106test_gnunet_vpn_4_to_6_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
107
108test_gnunet_vpn_6_to_4_SOURCES = \
109 test_gnunet_vpn.c
110test_gnunet_vpn_6_to_4_LDADD = $(MHD_LIBS) $(LIB_GNURL) \
111 $(top_builddir)/src/vpn/libgnunetvpn.la \
112 $(top_builddir)/src/testing/libgnunettesting.la \
113 $(top_builddir)/src/util/libgnunetutil.la
114test_gnunet_vpn_6_to_4_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)