aboutsummaryrefslogtreecommitdiff
path: root/src/pt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/pt/Makefile.am')
-rw-r--r--src/pt/Makefile.am110
1 files changed, 0 insertions, 110 deletions
diff --git a/src/pt/Makefile.am b/src/pt/Makefile.am
deleted file mode 100644
index fc2cb592c..000000000
--- a/src/pt/Makefile.am
+++ /dev/null
@@ -1,110 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12plugindir = $(libdir)/gnunet
13
14dist_pkgcfg_DATA = \
15 pt.conf
16
17libexec_PROGRAMS = \
18 gnunet-daemon-pt
19
20gnunet_daemon_pt_SOURCES = \
21 gnunet-daemon-pt.c
22gnunet_daemon_pt_LDADD = \
23 $(top_builddir)/src/vpn/libgnunetvpn.la \
24 $(top_builddir)/src/cadet/libgnunetcadet.la \
25 $(top_builddir)/src/dht/libgnunetdht.la \
26 $(top_builddir)/src/dns/libgnunetdns.la \
27 $(top_builddir)/src/statistics/libgnunetstatistics.la \
28 $(top_builddir)/src/util/libgnunetutil.la \
29 $(GN_LIBINTL)
30
31if HAVE_LIBGNURL
32LIB_GNURL=@LIBGNURL@
33CPP_GNURL=@LIBGNURL_CPPFLAGS@
34if LINUX
35 VPN_TEST = \
36 test_gnunet_vpn-4_to_6 \
37 test_gnunet_vpn-6_to_4 \
38 test_gnunet_vpn-6_over \
39 test_gnunet_vpn-4_over \
40 test_gns_vpn
41endif
42else
43if HAVE_LIBCURL
44LIB_GNURL=@LIBCURL@
45CPP_GNURL=@LIBCURL_CPPFLAGS@
46if LINUX
47 VPN_TEST = \
48 test_gnunet_vpn-4_to_6 \
49 test_gnunet_vpn-6_to_4 \
50 test_gnunet_vpn-6_over \
51 test_gnunet_vpn-4_over \
52 test_gns_vpn
53endif
54endif
55endif
56
57check_PROGRAMS = $(VPN_TEST)
58
59if ENABLE_TEST_RUN
60AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
61TESTS = $(check_PROGRAMS)
62endif
63
64EXTRA_DIST = \
65 test_gnunet_vpn.conf \
66 test_gns_vpn.conf
67
68
69
70test_gns_vpn_SOURCES = \
71 test_gns_vpn.c
72test_gns_vpn_LDADD = $(MHD_LIBS) $(LIB_GNURL) \
73 $(top_builddir)/src/namestore/libgnunetnamestore.la \
74 $(top_builddir)/src/identity/libgnunetidentity.la \
75 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
76 $(top_builddir)/src/testing/libgnunettesting.la \
77 $(top_builddir)/src/util/libgnunetutil.la
78test_gns_vpn_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
79
80test_gnunet_vpn_4_over_SOURCES = \
81 test_gnunet_vpn.c
82test_gnunet_vpn_4_over_LDADD = $(MHD_LIBS) $(LIB_GNURL) \
83 $(top_builddir)/src/vpn/libgnunetvpn.la \
84 $(top_builddir)/src/testing/libgnunettesting.la \
85 $(top_builddir)/src/util/libgnunetutil.la
86test_gnunet_vpn_4_over_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
87
88test_gnunet_vpn_6_over_SOURCES = \
89 test_gnunet_vpn.c
90test_gnunet_vpn_6_over_LDADD = $(MHD_LIBS) $(LIB_GNURL) \
91 $(top_builddir)/src/vpn/libgnunetvpn.la \
92 $(top_builddir)/src/testing/libgnunettesting.la \
93 $(top_builddir)/src/util/libgnunetutil.la
94test_gnunet_vpn_6_over_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
95
96test_gnunet_vpn_4_to_6_SOURCES = \
97 test_gnunet_vpn.c
98test_gnunet_vpn_4_to_6_LDADD = $(MHD_LIBS) $(LIB_GNURL) \
99 $(top_builddir)/src/vpn/libgnunetvpn.la \
100 $(top_builddir)/src/testing/libgnunettesting.la \
101 $(top_builddir)/src/util/libgnunetutil.la
102test_gnunet_vpn_4_to_6_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)
103
104test_gnunet_vpn_6_to_4_SOURCES = \
105 test_gnunet_vpn.c
106test_gnunet_vpn_6_to_4_LDADD = $(MHD_LIBS) $(LIB_GNURL) \
107 $(top_builddir)/src/vpn/libgnunetvpn.la \
108 $(top_builddir)/src/testing/libgnunettesting.la \
109 $(top_builddir)/src/util/libgnunetutil.la
110test_gnunet_vpn_6_to_4_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS)