aboutsummaryrefslogtreecommitdiff
path: root/src/pt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/pt/Makefile.am')
-rw-r--r--src/pt/Makefile.am44
1 files changed, 34 insertions, 10 deletions
diff --git a/src/pt/Makefile.am b/src/pt/Makefile.am
index 650fabf09..9783ffc07 100644
--- a/src/pt/Makefile.am
+++ b/src/pt/Makefile.am
@@ -34,7 +34,29 @@ gnunet_daemon_pt_LDADD = \
34 34
35if HAVE_TESTING 35if HAVE_TESTING
36if HAVE_MHD 36if HAVE_MHD
37
37if HAVE_LIBGNURL 38if HAVE_LIBGNURL
39LIB_GNURL=@LIBGNURL@
40CPP_GNURL=@LIBGNURL_CPPFLAGS@
41if LINUX
42 VPN_TEST = \
43 test_gnunet_vpn-4_to_6 \
44 test_gnunet_vpn-6_to_4 \
45 test_gnunet_vpn-6_over \
46 test_gnunet_vpn-4_over \
47 test_gns_vpn
48endif
49if MINGW
50 VPN_TEST = \
51 test_gnunet_vpn-4_to_6 \
52 test_gnunet_vpn-6_to_4 \
53 test_gnunet_vpn-6_over \
54 test_gnunet_vpn-4_over
55endif
56else
57if HAVE_LIBCURL
58LIB_GNURL=@LIBCURL@
59CPP_GNURL=@LIBCURL_CPPFLAGS@
38if LINUX 60if LINUX
39 VPN_TEST = \ 61 VPN_TEST = \
40 test_gnunet_vpn-4_to_6 \ 62 test_gnunet_vpn-4_to_6 \
@@ -52,6 +74,8 @@ if MINGW
52endif 74endif
53endif 75endif
54endif 76endif
77
78endif
55endif 79endif
56 80
57check_PROGRAMS = $(VPN_TEST) 81check_PROGRAMS = $(VPN_TEST)
@@ -69,48 +93,48 @@ EXTRA_DIST = \
69 93
70test_gns_vpn_SOURCES = \ 94test_gns_vpn_SOURCES = \
71 test_gns_vpn.c 95 test_gns_vpn.c
72test_gns_vpn_LDADD = -lmicrohttpd @LIBGNURL@ \ 96test_gns_vpn_LDADD = -lmicrohttpd $(LIB_GNURL) \
73 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 97 $(top_builddir)/src/namestore/libgnunetnamestore.la \
74 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \ 98 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
75 $(top_builddir)/src/testing/libgnunettesting.la \ 99 $(top_builddir)/src/testing/libgnunettesting.la \
76 $(top_builddir)/src/util/libgnunetutil.la 100 $(top_builddir)/src/util/libgnunetutil.la
77test_gns_vpn_CPPFLAGS = \ 101test_gns_vpn_CPPFLAGS = \
78 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS) 102 $(CPP_GNURL) $(AM_CPPFLAGS)
79 103
80test_gnunet_vpn_4_over_SOURCES = \ 104test_gnunet_vpn_4_over_SOURCES = \
81 test_gnunet_vpn.c 105 test_gnunet_vpn.c
82test_gnunet_vpn_4_over_LDADD = -lmicrohttpd @LIBGNURL@ \ 106test_gnunet_vpn_4_over_LDADD = -lmicrohttpd $(LIB_GNURL) \
83 $(top_builddir)/src/vpn/libgnunetvpn.la \ 107 $(top_builddir)/src/vpn/libgnunetvpn.la \
84 $(top_builddir)/src/testing/libgnunettesting.la \ 108 $(top_builddir)/src/testing/libgnunettesting.la \
85 $(top_builddir)/src/util/libgnunetutil.la 109 $(top_builddir)/src/util/libgnunetutil.la
86test_gnunet_vpn_4_over_CPPFLAGS = \ 110test_gnunet_vpn_4_over_CPPFLAGS = \
87 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS) 111 $(LIB_GNURL) $(AM_CPPFLAGS)
88 112
89test_gnunet_vpn_6_over_SOURCES = \ 113test_gnunet_vpn_6_over_SOURCES = \
90 test_gnunet_vpn.c 114 test_gnunet_vpn.c
91test_gnunet_vpn_6_over_LDADD = -lmicrohttpd @LIBGNURL@ \ 115test_gnunet_vpn_6_over_LDADD = -lmicrohttpd $(LIB_GNURL) \
92 $(top_builddir)/src/vpn/libgnunetvpn.la \ 116 $(top_builddir)/src/vpn/libgnunetvpn.la \
93 $(top_builddir)/src/testing/libgnunettesting.la \ 117 $(top_builddir)/src/testing/libgnunettesting.la \
94 $(top_builddir)/src/util/libgnunetutil.la 118 $(top_builddir)/src/util/libgnunetutil.la
95test_gnunet_vpn_6_over_CPPFLAGS = \ 119test_gnunet_vpn_6_over_CPPFLAGS = \
96 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS) 120 $(CPP_GNURL) $(AM_CPPFLAGS)
97 121
98test_gnunet_vpn_4_to_6_SOURCES = \ 122test_gnunet_vpn_4_to_6_SOURCES = \
99 test_gnunet_vpn.c 123 test_gnunet_vpn.c
100test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd @LIBGNURL@ \ 124test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd $(LIB_GNURL) \
101 $(top_builddir)/src/vpn/libgnunetvpn.la \ 125 $(top_builddir)/src/vpn/libgnunetvpn.la \
102 $(top_builddir)/src/testing/libgnunettesting.la \ 126 $(top_builddir)/src/testing/libgnunettesting.la \
103 $(top_builddir)/src/util/libgnunetutil.la 127 $(top_builddir)/src/util/libgnunetutil.la
104test_gnunet_vpn_4_to_6_CPPFLAGS = \ 128test_gnunet_vpn_4_to_6_CPPFLAGS = \
105 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS) 129 $(CPP_GNURL) $(AM_CPPFLAGS)
106 130
107test_gnunet_vpn_6_to_4_SOURCES = \ 131test_gnunet_vpn_6_to_4_SOURCES = \
108 test_gnunet_vpn.c 132 test_gnunet_vpn.c
109test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd @LIBGNURL@ \ 133test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd $(LIB_GNURL) \
110 $(top_builddir)/src/vpn/libgnunetvpn.la \ 134 $(top_builddir)/src/vpn/libgnunetvpn.la \
111 $(top_builddir)/src/testing/libgnunettesting.la \ 135 $(top_builddir)/src/testing/libgnunettesting.la \
112 $(top_builddir)/src/util/libgnunetutil.la 136 $(top_builddir)/src/util/libgnunetutil.la
113test_gnunet_vpn_6_to_4_CPPFLAGS = \ 137test_gnunet_vpn_6_to_4_CPPFLAGS = \
114 @LIBGNURL_CPPFLAGS@ $(AM_CPPFLAGS) 138 $(CPP_GNURL) $(AM_CPPFLAGS)
115 139
116 140