aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am214
1 files changed, 0 insertions, 214 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
deleted file mode 100644
index 9a7466cb2..000000000
--- a/src/regex/Makefile.am
+++ /dev/null
@@ -1,214 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12plugindir = $(libdir)/gnunet
13
14pkgcfg_DATA = \
15 regex.conf
16
17libexec_PROGRAMS = \
18 gnunet-service-regex \
19 gnunet-daemon-regexprofiler
20
21
22gnunet_service_regex_SOURCES = \
23 gnunet-service-regex.c
24gnunet_service_regex_LDADD = -lm \
25 libgnunetregex_internal.a \
26 libgnunetregexblock.la \
27 $(top_builddir)/src/dht/libgnunetdht.la \
28 $(top_builddir)/src/statistics/libgnunetstatistics.la \
29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(GN_LIBINTL)
31
32noinst_LIBRARIES = \
33 libgnunetregex_internal.a \
34 libgnunetregextest.a
35
36lib_LTLIBRARIES = \
37 libgnunetregexblock.la \
38 libgnunetregex.la
39
40
41libgnunetregexblock_la_SOURCES = \
42 regex_block_lib.c regex_block_lib.h
43libgnunetregexblock_la_LIBADD = \
44 $(top_builddir)/src/util/libgnunetutil.la \
45 $(XLIB) \
46 $(LTLIBINTL)
47libgnunetregexblock_la_LDFLAGS = \
48 $(GN_LIB_LDFLAGS) \
49 -version-info 1:0:0
50
51
52libgnunetregex_internal_a_SOURCES = \
53 regex_internal_lib.h \
54 regex_internal.h regex_internal.c \
55 regex_internal_dht.c
56
57libgnunetregex_la_SOURCES = \
58 regex_api_announce.c \
59 regex_api_search.c \
60 regex_ipc.h
61libgnunetregex_la_LIBADD = \
62 $(top_builddir)/src/util/libgnunetutil.la
63libgnunetregex_la_LDFLAGS = \
64 $(GN_LIBINTL) \
65 $(GN_LIB_LDFLAGS) \
66 -version-info 3:1:0
67
68
69plugin_LTLIBRARIES = \
70 libgnunet_plugin_block_regex.la
71
72libgnunet_plugin_block_regex_la_SOURCES = \
73 plugin_block_regex.c
74libgnunet_plugin_block_regex_la_LIBADD = \
75 libgnunetregexblock.la \
76 $(top_builddir)/src/block/libgnunetblock.la \
77 $(top_builddir)/src/block/libgnunetblockgroup.la \
78 $(top_builddir)/src/util/libgnunetutil.la
79libgnunet_plugin_block_regex_la_LDFLAGS = \
80 $(GN_LIBINTL) \
81 $(GN_PLUGIN_LDFLAGS)
82
83if HAVE_MYSQL
84noinst_mysql_progs = \
85 gnunet-regex-simulation-profiler
86
87gnunet_regex_simulation_profiler_SOURCES = \
88 gnunet-regex-simulation-profiler.c
89gnunet_regex_simulation_profiler_LDADD = \
90 $(top_builddir)/src/util/libgnunetutil.la \
91 libgnunetregex_internal.a \
92 $(top_builddir)/src/dht/libgnunetdht.la \
93 $(top_builddir)/src/my/libgnunetmy.la \
94 $(top_builddir)/src/mysql/libgnunetmysql.la
95endif
96
97libgnunetregextest_a_SOURCES = \
98 regex_test_lib.c regex_test_lib.h \
99 regex_test_graph.c \
100 regex_test_random.c
101libgnunetregextest_a_LIBADD = \
102 $(top_builddir)/src/util/libgnunetutil.la \
103 libgnunetregex_internal.a
104
105if HAVE_TESTING
106noinst_PROGRAMS = $(noinst_mysql_progs) \
107 perf-regex \
108 gnunet-regex-profiler
109endif
110
111perf_regex_SOURCES = \
112 perf-regex.c
113perf_regex_LDADD = -lm \
114 libgnunetregex_internal.a \
115 $(top_builddir)/src/dht/libgnunetdht.la \
116 libgnunetregexblock.la \
117 libgnunetregextest.a \
118 $(top_builddir)/src/util/libgnunetutil.la
119perf_regex_LDFLAGS = \
120 $(GN_LIBINTL)
121
122gnunet_regex_profiler_SOURCES = \
123 gnunet-regex-profiler.c
124gnunet_regex_profiler_LDADD = -lm \
125 $(top_builddir)/src/arm/libgnunetarm.la \
126 $(top_builddir)/src/testing/libgnunettesting.la \
127 $(top_builddir)/src/testbed/libgnunettestbed.la \
128 libgnunetregex_internal.a \
129 $(top_builddir)/src/dht/libgnunetdht.la \
130 libgnunetregexblock.la \
131 libgnunetregextest.a \
132 $(top_builddir)/src/statistics/libgnunetstatistics.la \
133 $(top_builddir)/src/util/libgnunetutil.la
134gnunet_regex_profiler_LDFLAGS = \
135 $(GN_LIBINTL)
136
137gnunet_daemon_regexprofiler_SOURCES = \
138 gnunet-daemon-regexprofiler.c
139gnunet_daemon_regexprofiler_LDADD = -lm \
140 libgnunetregex_internal.a \
141 $(top_builddir)/src/dht/libgnunetdht.la \
142 libgnunetregexblock.la \
143 libgnunetregextest.a \
144 $(top_builddir)/src/statistics/libgnunetstatistics.la \
145 $(top_builddir)/src/util/libgnunetutil.la
146gnunet_daemon_regexprofiler_LDFLAGS = \
147 $(GN_LIBINTL)
148
149check_PROGRAMS = \
150 test_regex_integration \
151 test_regex_eval_api \
152 test_regex_iterate_api \
153 test_regex_proofs \
154 test_regex_graph_api \
155 test_regex_api
156
157if ENABLE_TEST_RUN
158 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
159 TESTS = $(check_PROGRAMS)
160endif
161
162test_regex_eval_api_SOURCES = \
163 test_regex_eval_api.c
164test_regex_eval_api_LDADD = -lm \
165 libgnunetregex_internal.a \
166 $(top_builddir)/src/dht/libgnunetdht.la \
167 libgnunetregextest.a \
168 libgnunetregexblock.la \
169 $(top_builddir)/src/util/libgnunetutil.la
170
171test_regex_integration_SOURCES = \
172 test_regex_integration.c
173test_regex_integration_LDADD = -lm \
174 libgnunetregex.la \
175 $(top_builddir)/src/testing/libgnunettesting.la \
176 $(top_builddir)/src/util/libgnunetutil.la
177
178test_regex_api_SOURCES = \
179 test_regex_api.c
180test_regex_api_LDADD = -lm \
181 libgnunetregex.la \
182 $(top_builddir)/src/testing/libgnunettesting.la \
183 $(top_builddir)/src/util/libgnunetutil.la
184
185test_regex_iterate_api_SOURCES = \
186 test_regex_iterate_api.c
187test_regex_iterate_api_LDADD = -lm \
188 libgnunetregex_internal.a \
189 libgnunetregexblock.la \
190 $(top_builddir)/src/dht/libgnunetdht.la \
191 $(top_builddir)/src/util/libgnunetutil.la
192
193test_regex_proofs_SOURCES = \
194 test_regex_proofs.c
195test_regex_proofs_LDADD = -lm \
196 libgnunetregex_internal.a \
197 $(top_builddir)/src/dht/libgnunetdht.la \
198 libgnunetregextest.a \
199 libgnunetregexblock.la \
200 $(top_builddir)/src/util/libgnunetutil.la
201
202test_regex_graph_api_SOURCES = \
203 test_regex_graph_api.c
204test_regex_graph_api_LDADD = -lm \
205 libgnunetregex_internal.a \
206 $(top_builddir)/src/dht/libgnunetdht.la \
207 libgnunetregextest.a \
208 libgnunetregexblock.la \
209 $(top_builddir)/src/util/libgnunetutil.la
210
211
212EXTRA_DIST = \
213 regex_simulation_profiler_test.conf \
214 test_regex_api_data.conf