aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am212
1 files changed, 0 insertions, 212 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
deleted file mode 100644
index 2dbf3a3f9..000000000
--- a/src/regex/Makefile.am
+++ /dev/null
@@ -1,212 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12plugindir = $(libdir)/gnunet
13
14pkgcfg_DATA = \
15 regex.conf
16
17libexec_PROGRAMS = \
18 gnunet-service-regex \
19 gnunet-daemon-regexprofiler
20
21
22gnunet_service_regex_SOURCES = \
23 gnunet-service-regex.c
24gnunet_service_regex_LDADD = -lm \
25 libgnunetregex_internal.a \
26 libgnunetregexblock.la \
27 $(top_builddir)/src/dht/libgnunetdht.la \
28 $(top_builddir)/src/statistics/libgnunetstatistics.la \
29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(GN_LIBINTL)
31
32noinst_LIBRARIES = \
33 libgnunetregex_internal.a \
34 libgnunetregextest.a
35
36lib_LTLIBRARIES = \
37 libgnunetregexblock.la \
38 libgnunetregex.la
39
40
41libgnunetregexblock_la_SOURCES = \
42 regex_block_lib.c regex_block_lib.h
43libgnunetregexblock_la_LIBADD = \
44 $(top_builddir)/src/util/libgnunetutil.la \
45 $(XLIB) \
46 $(LTLIBINTL)
47libgnunetregexblock_la_LDFLAGS = \
48 $(GN_LIB_LDFLAGS) \
49 -version-info 1:0:0
50
51
52libgnunetregex_internal_a_SOURCES = \
53 regex_internal_lib.h \
54 regex_internal.h regex_internal.c \
55 regex_internal_dht.c
56
57libgnunetregex_la_SOURCES = \
58 regex_api_announce.c \
59 regex_api_search.c \
60 regex_ipc.h
61libgnunetregex_la_LIBADD = \
62 $(top_builddir)/src/util/libgnunetutil.la
63libgnunetregex_la_LDFLAGS = \
64 $(GN_LIBINTL) \
65 $(GN_LIB_LDFLAGS) \
66 -version-info 3:1:0
67
68
69plugin_LTLIBRARIES = \
70 libgnunet_plugin_block_regex.la
71
72libgnunet_plugin_block_regex_la_SOURCES = \
73 plugin_block_regex.c
74libgnunet_plugin_block_regex_la_LIBADD = \
75 libgnunetregexblock.la \
76 $(top_builddir)/src/block/libgnunetblock.la \
77 $(top_builddir)/src/block/libgnunetblockgroup.la \
78 $(top_builddir)/src/util/libgnunetutil.la
79libgnunet_plugin_block_regex_la_LDFLAGS = \
80 $(GN_LIBINTL) \
81 $(GN_PLUGIN_LDFLAGS)
82
83if HAVE_MYSQL
84noinst_mysql_progs = \
85 gnunet-regex-simulation-profiler
86
87gnunet_regex_simulation_profiler_SOURCES = \
88 gnunet-regex-simulation-profiler.c
89gnunet_regex_simulation_profiler_LDADD = \
90 $(top_builddir)/src/util/libgnunetutil.la \
91 libgnunetregex_internal.a \
92 $(top_builddir)/src/dht/libgnunetdht.la \
93 $(top_builddir)/src/my/libgnunetmy.la \
94 $(top_builddir)/src/mysql/libgnunetmysql.la
95endif
96
97libgnunetregextest_a_SOURCES = \
98 regex_test_lib.c regex_test_lib.h \
99 regex_test_graph.c \
100 regex_test_random.c
101libgnunetregextest_a_LIBADD = \
102 $(top_builddir)/src/util/libgnunetutil.la \
103 libgnunetregex_internal.a
104
105noinst_PROGRAMS = $(noinst_mysql_progs) \
106 perf-regex \
107 gnunet-regex-profiler
108
109perf_regex_SOURCES = \
110 perf-regex.c
111perf_regex_LDADD = -lm \
112 libgnunetregex_internal.a \
113 $(top_builddir)/src/dht/libgnunetdht.la \
114 libgnunetregexblock.la \
115 libgnunetregextest.a \
116 $(top_builddir)/src/util/libgnunetutil.la
117perf_regex_LDFLAGS = \
118 $(GN_LIBINTL)
119
120gnunet_regex_profiler_SOURCES = \
121 gnunet-regex-profiler.c
122gnunet_regex_profiler_LDADD = -lm \
123 $(top_builddir)/src/arm/libgnunetarm.la \
124 $(top_builddir)/src/testing/libgnunettesting.la \
125 $(top_builddir)/src/testbed/libgnunettestbed.la \
126 libgnunetregex_internal.a \
127 $(top_builddir)/src/dht/libgnunetdht.la \
128 libgnunetregexblock.la \
129 libgnunetregextest.a \
130 $(top_builddir)/src/statistics/libgnunetstatistics.la \
131 $(top_builddir)/src/util/libgnunetutil.la
132gnunet_regex_profiler_LDFLAGS = \
133 $(GN_LIBINTL)
134
135gnunet_daemon_regexprofiler_SOURCES = \
136 gnunet-daemon-regexprofiler.c
137gnunet_daemon_regexprofiler_LDADD = -lm \
138 libgnunetregex_internal.a \
139 $(top_builddir)/src/dht/libgnunetdht.la \
140 libgnunetregexblock.la \
141 libgnunetregextest.a \
142 $(top_builddir)/src/statistics/libgnunetstatistics.la \
143 $(top_builddir)/src/util/libgnunetutil.la
144gnunet_daemon_regexprofiler_LDFLAGS = \
145 $(GN_LIBINTL)
146
147check_PROGRAMS = \
148 test_regex_integration \
149 test_regex_eval_api \
150 test_regex_iterate_api \
151 test_regex_proofs \
152 test_regex_graph_api \
153 test_regex_api
154
155if ENABLE_TEST_RUN
156 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
157 TESTS = $(check_PROGRAMS)
158endif
159
160test_regex_eval_api_SOURCES = \
161 test_regex_eval_api.c
162test_regex_eval_api_LDADD = -lm \
163 libgnunetregex_internal.a \
164 $(top_builddir)/src/dht/libgnunetdht.la \
165 libgnunetregextest.a \
166 libgnunetregexblock.la \
167 $(top_builddir)/src/util/libgnunetutil.la
168
169test_regex_integration_SOURCES = \
170 test_regex_integration.c
171test_regex_integration_LDADD = -lm \
172 libgnunetregex.la \
173 $(top_builddir)/src/testing/libgnunettesting.la \
174 $(top_builddir)/src/util/libgnunetutil.la
175
176test_regex_api_SOURCES = \
177 test_regex_api.c
178test_regex_api_LDADD = -lm \
179 libgnunetregex.la \
180 $(top_builddir)/src/testing/libgnunettesting.la \
181 $(top_builddir)/src/util/libgnunetutil.la
182
183test_regex_iterate_api_SOURCES = \
184 test_regex_iterate_api.c
185test_regex_iterate_api_LDADD = -lm \
186 libgnunetregex_internal.a \
187 libgnunetregexblock.la \
188 $(top_builddir)/src/dht/libgnunetdht.la \
189 $(top_builddir)/src/util/libgnunetutil.la
190
191test_regex_proofs_SOURCES = \
192 test_regex_proofs.c
193test_regex_proofs_LDADD = -lm \
194 libgnunetregex_internal.a \
195 $(top_builddir)/src/dht/libgnunetdht.la \
196 libgnunetregextest.a \
197 libgnunetregexblock.la \
198 $(top_builddir)/src/util/libgnunetutil.la
199
200test_regex_graph_api_SOURCES = \
201 test_regex_graph_api.c
202test_regex_graph_api_LDADD = -lm \
203 libgnunetregex_internal.a \
204 $(top_builddir)/src/dht/libgnunetdht.la \
205 libgnunetregextest.a \
206 libgnunetregexblock.la \
207 $(top_builddir)/src/util/libgnunetutil.la
208
209
210EXTRA_DIST = \
211 regex_simulation_profiler_test.conf \
212 test_regex_api_data.conf