aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
new file mode 100644
index 000000000..729773399
--- /dev/null
+++ b/src/regex/Makefile.am
@@ -0,0 +1,34 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage
9endif
10
11lib_LTLIBRARIES = libgnunetregex.la
12
13libgnunetregex_la_SOURCES = \
14 regex.c regex.h
15libgnunetregex_la_LIBADD = -lm \
16 $(top_builddir)/src/util/libgnunetutil.la
17libgnunetregex_la_LDFLAGS = \
18 $(GN_LIB_LDFLAGS) \
19 -version-info 0:0:0
20
21check_PROGRAMS = \
22 test_regex
23
24if ENABLE_TEST_RUN
25TESTS = $(check_PROGRAMS)
26endif
27
28test_regex_SOURCES = \
29 test_regex.c
30test_regex_LDADD = \
31 $(top_builddir)/src/regex/libgnunetregex.la \
32 $(top_builddir)/src/util/libgnunetutil.la
33
34EXTRA_DIST = test_regex_data.conf