aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am213
1 files changed, 0 insertions, 213 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
deleted file mode 100644
index 80997db40..000000000
--- a/src/regex/Makefile.am
+++ /dev/null
@@ -1,213 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if MINGW
5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
6endif
7
8if USE_COVERAGE
9 AM_CFLAGS = --coverage
10endif
11
12pkgcfgdir= $(pkgdatadir)/config.d/
13
14libexecdir= $(pkglibdir)/libexec/
15
16plugindir = $(libdir)/gnunet
17
18pkgcfg_DATA = \
19 regex.conf
20
21libexec_PROGRAMS = \
22 gnunet-service-regex \
23 gnunet-daemon-regexprofiler
24
25
26gnunet_service_regex_SOURCES = \
27 gnunet-service-regex.c
28gnunet_service_regex_LDADD = -lm \
29 libgnunetregex_internal.a \
30 libgnunetregexblock.la \
31 $(top_builddir)/src/dht/libgnunetdht.la \
32 $(top_builddir)/src/statistics/libgnunetstatistics.la \
33 $(top_builddir)/src/util/libgnunetutil.la \
34 $(GN_LIBINTL)
35
36noinst_LIBRARIES = \
37 libgnunetregex_internal.a \
38 libgnunetregextest.a
39
40lib_LTLIBRARIES = \
41 libgnunetregexblock.la \
42 libgnunetregex.la
43
44
45libgnunetregexblock_la_SOURCES = \
46 regex_block_lib.c regex_block_lib.h
47libgnunetregexblock_la_LIBADD = \
48 $(top_builddir)/src/util/libgnunetutil.la \
49 $(XLIB) \
50 $(LTLIBINTL)
51libgnunetregexblock_la_LDFLAGS = \
52 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
53 -version-info 1:0:0
54
55
56libgnunetregex_internal_a_SOURCES = \
57 regex_internal_lib.h \
58 regex_internal.h regex_internal.c \
59 regex_internal_dht.c
60libgnunetregex_internal_a_DEPENDENCIES = \
61 libgnunetregexblock.la
62
63
64libgnunetregex_la_SOURCES = \
65 regex_api_announce.c \
66 regex_api_search.c \
67 regex_ipc.h
68libgnunetregex_la_LIBADD = \
69 $(top_builddir)/src/util/libgnunetutil.la
70libgnunetregex_la_LDFLAGS = \
71 $(GN_LIB_LDFLAGS) \
72 -version-info 3:1:0
73
74
75plugin_LTLIBRARIES = \
76 libgnunet_plugin_block_regex.la
77
78libgnunet_plugin_block_regex_la_SOURCES = \
79 plugin_block_regex.c
80libgnunet_plugin_block_regex_la_LIBADD = \
81 libgnunetregexblock.la \
82 $(top_builddir)/src/block/libgnunetblock.la \
83 $(top_builddir)/src/block/libgnunetblockgroup.la \
84 $(top_builddir)/src/util/libgnunetutil.la
85libgnunet_plugin_block_regex_la_LDFLAGS = \
86 $(GN_PLUGIN_LDFLAGS)
87
88if HAVE_MYSQL
89noinst_mysql_progs = \
90 gnunet-regex-simulation-profiler
91
92gnunet_regex_simulation_profiler_SOURCES = \
93 gnunet-regex-simulation-profiler.c
94gnunet_regex_simulation_profiler_LDADD = \
95 $(top_builddir)/src/util/libgnunetutil.la \
96 libgnunetregex_internal.a \
97 $(top_builddir)/src/dht/libgnunetdht.la \
98 $(top_builddir)/src/my/libgnunetmy.la \
99 $(top_builddir)/src/mysql/libgnunetmysql.la
100endif
101
102libgnunetregextest_a_SOURCES = \
103 regex_test_lib.c regex_test_lib.h \
104 regex_test_graph.c \
105 regex_test_random.c
106libgnunetregextest_a_LIBADD = \
107 $(top_builddir)/src/util/libgnunetutil.la \
108 libgnunetregex_internal.a
109
110if HAVE_TESTING
111noinst_PROGRAMS = $(noinst_mysql_progs) \
112 perf-regex \
113 gnunet-regex-profiler
114endif
115
116perf_regex_SOURCES = \
117 perf-regex.c
118perf_regex_LDADD = -lm \
119 libgnunetregex_internal.a \
120 $(top_builddir)/src/dht/libgnunetdht.la \
121 libgnunetregexblock.la \
122 libgnunetregextest.a \
123 $(top_builddir)/src/util/libgnunetutil.la
124
125gnunet_regex_profiler_SOURCES = \
126 gnunet-regex-profiler.c
127gnunet_regex_profiler_LDADD = -lm \
128 $(top_builddir)/src/arm/libgnunetarm.la \
129 $(top_builddir)/src/testbed/libgnunettestbed.la \
130 libgnunetregex_internal.a \
131 $(top_builddir)/src/dht/libgnunetdht.la \
132 libgnunetregexblock.la \
133 libgnunetregextest.a \
134 $(top_builddir)/src/statistics/libgnunetstatistics.la \
135 $(top_builddir)/src/util/libgnunetutil.la
136
137gnunet_daemon_regexprofiler_SOURCES = \
138 gnunet-daemon-regexprofiler.c
139gnunet_daemon_regexprofiler_LDADD = -lm \
140 libgnunetregex_internal.a \
141 $(top_builddir)/src/dht/libgnunetdht.la \
142 libgnunetregexblock.la \
143 libgnunetregextest.a \
144 $(top_builddir)/src/statistics/libgnunetstatistics.la \
145 $(top_builddir)/src/util/libgnunetutil.la
146
147check_PROGRAMS = \
148 test_regex_integration \
149 test_regex_eval_api \
150 test_regex_iterate_api \
151 test_regex_proofs \
152 test_regex_graph_api \
153 test_regex_api
154
155if ENABLE_TEST_RUN
156 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
157 TESTS = $(check_PROGRAMS)
158endif
159
160test_regex_eval_api_SOURCES = \
161 test_regex_eval_api.c
162test_regex_eval_api_LDADD = -lm \
163 libgnunetregex_internal.a \
164 $(top_builddir)/src/dht/libgnunetdht.la \
165 libgnunetregextest.a \
166 libgnunetregexblock.la \
167 $(top_builddir)/src/util/libgnunetutil.la
168
169test_regex_integration_SOURCES = \
170 test_regex_integration.c
171test_regex_integration_LDADD = -lm \
172 libgnunetregex.la \
173 $(top_builddir)/src/testing/libgnunettesting.la \
174 $(top_builddir)/src/tun/libgnunettun.la \
175 $(top_builddir)/src/util/libgnunetutil.la
176
177test_regex_api_SOURCES = \
178 test_regex_api.c
179test_regex_api_LDADD = -lm \
180 libgnunetregex.la \
181 $(top_builddir)/src/testing/libgnunettesting.la \
182 $(top_builddir)/src/util/libgnunetutil.la
183
184test_regex_iterate_api_SOURCES = \
185 test_regex_iterate_api.c
186test_regex_iterate_api_LDADD = -lm \
187 libgnunetregex_internal.a \
188 libgnunetregexblock.la \
189 $(top_builddir)/src/dht/libgnunetdht.la \
190 $(top_builddir)/src/util/libgnunetutil.la
191
192test_regex_proofs_SOURCES = \
193 test_regex_proofs.c
194test_regex_proofs_LDADD = -lm \
195 libgnunetregex_internal.a \
196 $(top_builddir)/src/dht/libgnunetdht.la \
197 libgnunetregextest.a \
198 libgnunetregexblock.la \
199 $(top_builddir)/src/util/libgnunetutil.la
200
201test_regex_graph_api_SOURCES = \
202 test_regex_graph_api.c
203test_regex_graph_api_LDADD = -lm \
204 libgnunetregex_internal.a \
205 $(top_builddir)/src/dht/libgnunetdht.la \
206 libgnunetregextest.a \
207 libgnunetregexblock.la \
208 $(top_builddir)/src/util/libgnunetutil.la
209
210
211EXTRA_DIST = \
212 regex_simulation_profiler_test.conf \
213 test_regex_api_data.conf