aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am24
1 files changed, 17 insertions, 7 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index b5f712268..d477ade92 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -83,17 +83,18 @@ check_PROGRAMS = \
83 test_rps_churn 83 test_rps_churn
84endif 84endif
85 85
86rps_test_src = \
87 test_rps.c \
88 rps-test_util.h rps-test_util.c \
89 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c
90
86ld_rps_test_lib = \ 91ld_rps_test_lib = \
87 libgnunetrps.la \ 92 libgnunetrps.la \
88 $(top_builddir)/src/util/libgnunetutil.la \ 93 $(top_builddir)/src/util/libgnunetutil.la \
94 $(top_builddir)/src/statistics/libgnunetstatistics.la \
89 $(top_builddir)/src/testbed/libgnunettestbed.la \ 95 $(top_builddir)/src/testbed/libgnunettestbed.la \
90 -lm 96 -lm
91 97
92rps_test_src = \
93 test_rps.c \
94 rps-test_util.h rps-test_util.c \
95 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c
96
97if ENABLE_TEST_RUN 98if ENABLE_TEST_RUN
98AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 99AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
99TESTS = $(check_PROGRAMS) 100TESTS = $(check_PROGRAMS)
@@ -140,10 +141,19 @@ test_rps_seed_big_LDADD = $(ld_rps_test_lib)
140test_rps_churn_SOURCES = $(rps_test_src) 141test_rps_churn_SOURCES = $(rps_test_src)
141test_rps_churn_LDADD = $(ld_rps_test_lib) 142test_rps_churn_LDADD = $(ld_rps_test_lib)
142 143
143gnunet_rps_profiler_SOURCES = $(rps_test_src) 144gnunet_rps_profiler_SOURCES = \
145 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
146 rps-test_util.h rps-test_util.c \
147 gnunet-rps-profiler.c
148
149
144gnunet_rps_profiler_LDADD = \ 150gnunet_rps_profiler_LDADD = \
145 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 151 $(top_builddir)/src/statistics/libgnunetstatistics.la \
146 $(ld_rps_test_lib) 152 libgnunetrps.la \
153 $(top_builddir)/src/util/libgnunetutil.la \
154 $(top_builddir)/src/testbed/libgnunettestbed.la \
155 -lm
156
147 157
148EXTRA_DIST = \ 158EXTRA_DIST = \
149 test_rps.conf 159 test_rps.conf