aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am176
1 files changed, 0 insertions, 176 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
deleted file mode 100644
index b9de6b5e3..000000000
--- a/src/rps/Makefile.am
+++ /dev/null
@@ -1,176 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6 XLIB = -lgcov
7endif
8
9pkgcfgdir= $(pkgdatadir)/config.d/
10
11libexecdir= $(pkglibdir)/libexec/
12
13pkgcfg_DATA = \
14 rps.conf
15
16bin_PROGRAMS = gnunet-rps
17
18gnunet_rps_SOURCES = \
19 gnunet-rps.c
20
21gnunet_rps_LDADD = \
22 libgnunetrps.la \
23 $(top_builddir)/src/util/libgnunetutil.la \
24 $(XLIB) $(GN_LIBINTL)
25
26lib_LTLIBRARIES = libgnunetrps.la
27
28libgnunetrps_la_SOURCES = \
29 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
30 rps-test_util.h rps-test_util.c \
31 rps-sampler_common.h rps-sampler_common.c \
32 rps-sampler_client.h rps-sampler_client.c \
33 rps_api.c rps.h
34libgnunetrps_la_LIBADD = \
35 $(top_builddir)/src/nse/libgnunetnse.la \
36 $(top_builddir)/src/util/libgnunetutil.la \
37 $(GN_LIBINTL) $(XLIB)
38libgnunetrps_la_LDFLAGS = \
39 $(GN_LIB_LDFLAGS) \
40 -version-info 0:0:0
41# Fix 'created both with libtool and without' error:
42libgnunetrps_la_CFLAGS = $(AM_CFLAGS)
43
44
45libexec_PROGRAMS = \
46 gnunet-service-rps
47
48if HAVE_TESTING
49noinst_PROGRAMS = \
50 gnunet-rps-profiler
51endif
52
53
54gnunet_service_rps_SOURCES = \
55 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
56 rps-sampler_common.h rps-sampler_common.c \
57 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \
58 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \
59 gnunet-service-rps_view.h gnunet-service-rps_view.c \
60 gnunet-service-rps.c
61
62
63gnunet_service_rps_LDADD = \
64 libgnunetrps.la \
65 $(top_builddir)/src/util/libgnunetutil.la \
66 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
67 $(top_builddir)/src/cadet/libgnunetcadet.la \
68 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
69 $(top_builddir)/src/nse/libgnunetnse.la \
70 $(top_builddir)/src/statistics/libgnunetstatistics.la \
71 $(top_builddir)/src/core/libgnunetcore.la \
72 $(LIBGCRYPT_LIBS) \
73 -lm -lgcrypt \
74 $(GN_LIBINTL)
75
76
77if HAVE_TESTING
78check_PROGRAMS = \
79 test_service_rps_view \
80 test_service_rps_custommap \
81 test_service_rps_sampler_elem \
82 test_rps_single_req \
83 test_rps_req_cancel \
84 test_rps_sub \
85 test_rps_seed_request \
86 test_rps_seed_big \
87 test_rps_churn
88if ENABLE_MALICIOUS
89check_PROGRAMS += \
90 test_rps_malicious_1 \
91 test_rps_malicious_2 \
92 test_rps_malicious_3
93endif
94endif
95
96rps_test_src = \
97 test_rps.c \
98 rps-test_util.h rps-test_util.c \
99 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
100 rps-sampler_common.h rps-sampler_common.c \
101 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c
102
103ld_rps_test_lib = \
104 libgnunetrps.la \
105 $(top_builddir)/src/util/libgnunetutil.la \
106 $(top_builddir)/src/statistics/libgnunetstatistics.la \
107 $(top_builddir)/src/testbed/libgnunettestbed.la \
108 -lm
109
110if ENABLE_TEST_RUN
111AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
112TESTS = $(check_PROGRAMS)
113endif
114
115test_service_rps_view_SOURCES = \
116 gnunet-service-rps_view.h gnunet-service-rps_view.c \
117 test_service_rps_view.c
118test_service_rps_view_LDADD = $(top_builddir)/src/util/libgnunetutil.la
119
120test_service_rps_custommap_SOURCES = \
121 gnunet-service-rps_custommap.h gnunet-service-rps_custommap.c \
122 test_service_rps_custommap.c
123test_service_rps_custommap_LDADD = \
124 $(top_builddir)/src/util/libgnunetutil.la
125
126test_service_rps_sampler_elem_SOURCES = \
127 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
128 rps-test_util.h rps-test_util.c \
129 test_service_rps_sampler_elem.c
130test_service_rps_sampler_elem_LDADD = $(top_builddir)/src/util/libgnunetutil.la
131
132test_rps_single_req_SOURCES = $(rps_test_src)
133test_rps_single_req_LDADD = $(ld_rps_test_lib)
134
135test_rps_seed_request_SOURCES = $(rps_test_src)
136test_rps_seed_request_LDADD = $(ld_rps_test_lib)
137
138test_rps_req_cancel_SOURCES = $(rps_test_src)
139test_rps_req_cancel_LDADD = $(ld_rps_test_lib)
140
141test_rps_sub_SOURCES = $(rps_test_src)
142test_rps_sub_LDADD = $(ld_rps_test_lib)
143
144test_rps_seed_big_SOURCES = $(rps_test_src)
145test_rps_seed_big_LDADD = $(ld_rps_test_lib)
146
147test_rps_churn_SOURCES = $(rps_test_src)
148test_rps_churn_LDADD = $(ld_rps_test_lib)
149
150test_rps_malicious_1_SOURCES = $(rps_test_src)
151test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
152
153test_rps_malicious_2_SOURCES = $(rps_test_src)
154test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
155
156test_rps_malicious_3_SOURCES = $(rps_test_src)
157test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
158
159gnunet_rps_profiler_SOURCES = \
160 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c \
161 rps-sampler_common.h rps-sampler_common.c \
162 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \
163 rps-test_util.h rps-test_util.c \
164 gnunet-rps-profiler.c
165
166
167gnunet_rps_profiler_LDADD = \
168 $(top_builddir)/src/statistics/libgnunetstatistics.la \
169 libgnunetrps.la \
170 $(top_builddir)/src/util/libgnunetutil.la \
171 $(top_builddir)/src/testbed/libgnunettestbed.la \
172 -lm
173
174
175EXTRA_DIST = \
176 test_rps.conf