diff options
Diffstat (limited to 'src/service/identity/meson.build')
-rw-r--r-- | src/service/identity/meson.build | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/src/service/identity/meson.build b/src/service/identity/meson.build new file mode 100644 index 000000000..c9e4f9bb4 --- /dev/null +++ b/src/service/identity/meson.build | |||
@@ -0,0 +1,60 @@ | |||
1 | libgnunetidentity_src = ['identity_api.c', | ||
2 | 'identity_api_lookup.c', | ||
3 | 'identity_api_suffix_lookup.c'] | ||
4 | |||
5 | gnunetserviceidentity_src = ['gnunet-service-identity.c'] | ||
6 | |||
7 | configure_file(input : 'identity.conf.in', | ||
8 | output : 'identity.conf', | ||
9 | configuration : cdata, | ||
10 | install: true, | ||
11 | install_dir: pkgcfgdir) | ||
12 | |||
13 | |||
14 | if get_option('monolith') | ||
15 | foreach p : libgnunetidentity_src + gnunetserviceidentity_src | ||
16 | gnunet_src += 'identity/' + p | ||
17 | endforeach | ||
18 | subdir_done() | ||
19 | endif | ||
20 | |||
21 | libgnunetidentity = library('gnunetidentity', | ||
22 | libgnunetidentity_src, | ||
23 | soversion: '1', | ||
24 | version: '1.0.0', | ||
25 | dependencies: [libgnunetutil_dep, sodium_dep], | ||
26 | include_directories: [incdir, configuration_inc], | ||
27 | install: true, | ||
28 | install_dir: get_option('libdir')) | ||
29 | libgnunetidentity_dep = declare_dependency(link_with : libgnunetidentity) | ||
30 | pkg.generate(libgnunetidentity, url: 'https://www.gnunet.org', | ||
31 | description : 'API to access and organize private keys of the user egos') | ||
32 | shared_module('gnunet_plugin_rest_identity', | ||
33 | ['plugin_rest_identity.c'], | ||
34 | dependencies: [libgnunetrest_dep, | ||
35 | libgnunetidentity_dep, | ||
36 | libgnunetutil_dep, | ||
37 | json_dep, | ||
38 | mhd_dep], | ||
39 | include_directories: [incdir, configuration_inc], | ||
40 | install: true, | ||
41 | install_dir: get_option('libdir') / 'gnunet') | ||
42 | |||
43 | |||
44 | executable ('gnunet-identity', | ||
45 | ['gnunet-identity.c'], | ||
46 | dependencies: [libgnunetidentity_dep, | ||
47 | libgnunetutil_dep, | ||
48 | libgnunetstatistics_dep], | ||
49 | include_directories: [incdir, configuration_inc], | ||
50 | install: true, | ||
51 | install_dir: get_option('bindir')) | ||
52 | executable ('gnunet-service-identity', | ||
53 | gnunetserviceidentity_src, | ||
54 | dependencies: [libgnunetidentity_dep, | ||
55 | libgnunetutil_dep, | ||
56 | libgnunetstatistics_dep], | ||
57 | include_directories: [incdir, configuration_inc], | ||
58 | install: true, | ||
59 | install_dir: get_option('libdir')/'gnunet'/'libexec') | ||
60 | |||