aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am128
1 files changed, 0 insertions, 128 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
deleted file mode 100644
index d6b10a1f8..000000000
--- a/src/set/Makefile.am
+++ /dev/null
@@ -1,128 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10pkgcfg_DATA = \
11 set.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = -fprofile-arcs -ftest-coverage
15endif
16
17if HAVE_TESTING
18bin_PROGRAMS = \
19 gnunet-set-profiler
20
21noinst_PROGRAMS = \
22 gnunet-set-ibf-profiler
23endif
24
25libexec_PROGRAMS = \
26 gnunet-service-set
27
28lib_LTLIBRARIES = \
29 libgnunetset.la
30
31gnunet_set_profiler_SOURCES = \
32 gnunet-set-profiler.c
33gnunet_set_profiler_LDADD = \
34 $(top_builddir)/src/util/libgnunetutil.la \
35 $(top_builddir)/src/statistics/libgnunetstatistics.la \
36 libgnunetset.la \
37 $(top_builddir)/src/testing/libgnunettesting.la \
38 $(GN_LIBINTL)
39
40
41gnunet_set_ibf_profiler_SOURCES = \
42 gnunet-set-ibf-profiler.c \
43 ibf.c
44gnunet_set_ibf_profiler_LDADD = \
45 $(top_builddir)/src/util/libgnunetutil.la \
46 $(GN_LIBINTL)
47
48gnunet_service_set_SOURCES = \
49 gnunet-service-set.c gnunet-service-set.h \
50 gnunet-service-set_union.c gnunet-service-set_union.h \
51 gnunet-service-set_intersection.c gnunet-service-set_intersection.h \
52 ibf.c ibf.h \
53 gnunet-service-set_union_strata_estimator.c gnunet-service-set_union_strata_estimator.h \
54 gnunet-service-set_protocol.h
55gnunet_service_set_LDADD = \
56 $(top_builddir)/src/util/libgnunetutil.la \
57 $(top_builddir)/src/statistics/libgnunetstatistics.la \
58 $(top_builddir)/src/core/libgnunetcore.la \
59 $(top_builddir)/src/cadet/libgnunetcadet.la \
60 $(top_builddir)/src/block/libgnunetblock.la \
61 libgnunetset.la \
62 $(GN_LIBINTL)
63
64libgnunetset_la_SOURCES = \
65 set_api.c set.h
66libgnunetset_la_LIBADD = \
67 $(top_builddir)/src/util/libgnunetutil.la \
68 $(LTLIBINTL)
69libgnunetset_la_LDFLAGS = \
70 $(GN_LIB_LDFLAGS)
71
72if HAVE_TESTING
73check_PROGRAMS = \
74 test_set_api \
75 test_set_union_result_symmetric \
76 test_set_intersection_result_full \
77 test_set_union_copy
78endif
79
80if ENABLE_TEST_RUN
81AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
82TESTS = $(check_PROGRAMS)
83endif
84
85test_set_api_SOURCES = \
86 test_set_api.c
87test_set_api_LDADD = \
88 $(top_builddir)/src/util/libgnunetutil.la \
89 $(top_builddir)/src/testing/libgnunettesting.la \
90 libgnunetset.la
91
92test_set_union_result_symmetric_SOURCES = \
93 test_set_union_result_symmetric.c
94test_set_union_result_symmetric_LDADD = \
95 $(top_builddir)/src/util/libgnunetutil.la \
96 $(top_builddir)/src/testing/libgnunettesting.la \
97 libgnunetset.la
98
99test_set_intersection_result_full_SOURCES = \
100 test_set_intersection_result_full.c
101test_set_intersection_result_full_LDADD = \
102 $(top_builddir)/src/util/libgnunetutil.la \
103 $(top_builddir)/src/testing/libgnunettesting.la \
104 libgnunetset.la
105
106test_set_union_copy_SOURCES = \
107 test_set_union_copy.c
108test_set_union_copy_LDADD = \
109 $(top_builddir)/src/util/libgnunetutil.la \
110 $(top_builddir)/src/testing/libgnunettesting.la \
111 libgnunetset.la
112
113plugin_LTLIBRARIES = \
114 libgnunet_plugin_block_set_test.la
115
116libgnunet_plugin_block_set_test_la_SOURCES = \
117 plugin_block_set_test.c
118libgnunet_plugin_block_set_test_la_LIBADD = \
119 $(top_builddir)/src/block/libgnunetblock.la \
120 $(top_builddir)/src/block/libgnunetblockgroup.la \
121 $(top_builddir)/src/util/libgnunetutil.la \
122 $(LTLIBINTL)
123libgnunet_plugin_block_set_test_la_LDFLAGS = \
124 $(GN_PLUGIN_LDFLAGS)
125
126
127EXTRA_DIST = \
128 test_set.conf