aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am124
1 files changed, 0 insertions, 124 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
deleted file mode 100644
index 837d42ff5..000000000
--- a/src/set/Makefile.am
+++ /dev/null
@@ -1,124 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10pkgcfg_DATA = \
11 set.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = -fprofile-arcs -ftest-coverage
15endif
16
17bin_PROGRAMS = \
18 gnunet-set-profiler
19
20noinst_PROGRAMS = \
21 gnunet-set-ibf-profiler
22
23libexec_PROGRAMS = \
24 gnunet-service-set
25
26lib_LTLIBRARIES = \
27 libgnunetset.la
28
29gnunet_set_profiler_SOURCES = \
30 gnunet-set-profiler.c
31gnunet_set_profiler_LDADD = \
32 $(top_builddir)/src/util/libgnunetutil.la \
33 $(top_builddir)/src/statistics/libgnunetstatistics.la \
34 libgnunetset.la \
35 $(top_builddir)/src/testing/libgnunettesting.la \
36 $(GN_LIBINTL)
37
38
39gnunet_set_ibf_profiler_SOURCES = \
40 gnunet-set-ibf-profiler.c \
41 ibf.c
42gnunet_set_ibf_profiler_LDADD = \
43 $(top_builddir)/src/util/libgnunetutil.la \
44 $(GN_LIBINTL)
45
46gnunet_service_set_SOURCES = \
47 gnunet-service-set.c gnunet-service-set.h \
48 gnunet-service-set_union.c gnunet-service-set_union.h \
49 gnunet-service-set_intersection.c gnunet-service-set_intersection.h \
50 ibf.c ibf.h \
51 gnunet-service-set_union_strata_estimator.c gnunet-service-set_union_strata_estimator.h \
52 gnunet-service-set_protocol.h
53gnunet_service_set_LDADD = \
54 $(top_builddir)/src/util/libgnunetutil.la \
55 $(top_builddir)/src/statistics/libgnunetstatistics.la \
56 $(top_builddir)/src/core/libgnunetcore.la \
57 $(top_builddir)/src/cadet/libgnunetcadet.la \
58 $(top_builddir)/src/block/libgnunetblock.la \
59 libgnunetset.la \
60 $(GN_LIBINTL)
61
62libgnunetset_la_SOURCES = \
63 set_api.c set.h
64libgnunetset_la_LIBADD = \
65 $(top_builddir)/src/util/libgnunetutil.la \
66 $(LTLIBINTL)
67libgnunetset_la_LDFLAGS = \
68 $(GN_LIB_LDFLAGS)
69
70check_PROGRAMS = \
71 test_set_api \
72 test_set_union_result_symmetric \
73 test_set_intersection_result_full \
74 test_set_union_copy
75
76if ENABLE_TEST_RUN
77AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
78TESTS = $(check_PROGRAMS)
79endif
80
81test_set_api_SOURCES = \
82 test_set_api.c
83test_set_api_LDADD = \
84 $(top_builddir)/src/util/libgnunetutil.la \
85 $(top_builddir)/src/testing/libgnunettesting.la \
86 libgnunetset.la
87
88test_set_union_result_symmetric_SOURCES = \
89 test_set_union_result_symmetric.c
90test_set_union_result_symmetric_LDADD = \
91 $(top_builddir)/src/util/libgnunetutil.la \
92 $(top_builddir)/src/testing/libgnunettesting.la \
93 libgnunetset.la
94
95test_set_intersection_result_full_SOURCES = \
96 test_set_intersection_result_full.c
97test_set_intersection_result_full_LDADD = \
98 $(top_builddir)/src/util/libgnunetutil.la \
99 $(top_builddir)/src/testing/libgnunettesting.la \
100 libgnunetset.la
101
102test_set_union_copy_SOURCES = \
103 test_set_union_copy.c
104test_set_union_copy_LDADD = \
105 $(top_builddir)/src/util/libgnunetutil.la \
106 $(top_builddir)/src/testing/libgnunettesting.la \
107 libgnunetset.la
108
109plugin_LTLIBRARIES = \
110 libgnunet_plugin_block_set_test.la
111
112libgnunet_plugin_block_set_test_la_SOURCES = \
113 plugin_block_set_test.c
114libgnunet_plugin_block_set_test_la_LIBADD = \
115 $(top_builddir)/src/block/libgnunetblock.la \
116 $(top_builddir)/src/block/libgnunetblockgroup.la \
117 $(top_builddir)/src/util/libgnunetutil.la \
118 $(LTLIBINTL)
119libgnunet_plugin_block_set_test_la_LDFLAGS = \
120 $(GN_PLUGIN_LDFLAGS)
121
122
123EXTRA_DIST = \
124 test_set.conf