aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am34
1 files changed, 2 insertions, 32 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index a609840b1..13278b05c 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -16,7 +16,7 @@ if USE_COVERAGE
16endif 16endif
17 17
18bin_PROGRAMS = \ 18bin_PROGRAMS = \
19 gnunet-set gnunet-set-bug 19 gnunet-set
20 20
21libexec_PROGRAMS = \ 21libexec_PROGRAMS = \
22 gnunet-service-set 22 gnunet-service-set
@@ -35,17 +35,9 @@ gnunet_set_LDADD = \
35gnunet_set_DEPENDENCIES = \ 35gnunet_set_DEPENDENCIES = \
36 libgnunetset.la 36 libgnunetset.la
37 37
38gnunet_set_bug_SOURCES = \
39 gnunet-set-bug.c
40gnunet_set_bug_LDADD = \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(top_builddir)/src/stream/libgnunetstream.la \
43 $(GN_LIBINTL)
44
45gnunet_service_set_SOURCES = \ 38gnunet_service_set_SOURCES = \
46 gnunet-service-set.c \ 39 gnunet-service-set.c \
47 gnunet-service-set_union.c \ 40 gnunet-service-set_union.c \
48 mq.c \
49 ibf.c \ 41 ibf.c \
50 strata_estimator.c 42 strata_estimator.c
51gnunet_service_set_LDADD = \ 43gnunet_service_set_LDADD = \
@@ -54,13 +46,9 @@ gnunet_service_set_LDADD = \
54 $(top_builddir)/src/stream/libgnunetstream.la \ 46 $(top_builddir)/src/stream/libgnunetstream.la \
55 $(top_builddir)/src/mesh/libgnunetmesh.la \ 47 $(top_builddir)/src/mesh/libgnunetmesh.la \
56 $(GN_LIBINTL) 48 $(GN_LIBINTL)
57# hack for mq.c, see automake Objects ‘created with both libtool and without’
58# remove once GNUNET_MQ is in util/
59gnunet_service_set_CFLAGS = $(AM_CFLAGS)
60 49
61libgnunetset_la_SOURCES = \ 50libgnunetset_la_SOURCES = \
62 set_api.c \ 51 set_api.c
63 mq.c
64libgnunetset_la_LIBADD = \ 52libgnunetset_la_LIBADD = \
65 $(top_builddir)/src/util/libgnunetutil.la \ 53 $(top_builddir)/src/util/libgnunetutil.la \
66 $(top_builddir)/src/stream/libgnunetstream.la \ 54 $(top_builddir)/src/stream/libgnunetstream.la \
@@ -84,24 +72,6 @@ test_set_api_LDADD = \
84test_set_api_DEPENDENCIES = \ 72test_set_api_DEPENDENCIES = \
85 libgnunetset.la 73 libgnunetset.la
86 74
87
88test_mq_SOURCES = \
89 test_mq.c \
90 mq.c
91test_mq_LDADD = \
92 $(top_builddir)/src/util/libgnunetutil.la \
93 $(top_builddir)/src/stream/libgnunetstream.la
94test_mq_CFLAGS = $(AM_CFLAGS)
95
96
97test_mq_client_SOURCES = \
98 test_mq_client.c \
99 mq.c
100test_mq_client_LDADD = \
101 $(top_builddir)/src/util/libgnunetutil.la \
102 $(top_builddir)/src/stream/libgnunetstream.la
103test_mq_client_CFLAGS = $(AM_CFLAGS)
104
105EXTRA_DIST = \ 75EXTRA_DIST = \
106 test_set.conf 76 test_set.conf
107 77