aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index 2de531ce3..a609840b1 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -69,7 +69,7 @@ libgnunetset_la_LDFLAGS = \
69 $(GN_LIB_LDFLAGS) 69 $(GN_LIB_LDFLAGS)
70 70
71check_PROGRAMS = \ 71check_PROGRAMS = \
72 test_set_api 72 test_set_api test_mq test_mq_client
73 73
74if ENABLE_TEST_RUN 74if ENABLE_TEST_RUN
75TESTS = $(check_PROGRAMS) 75TESTS = $(check_PROGRAMS)
@@ -84,6 +84,24 @@ test_set_api_LDADD = \
84test_set_api_DEPENDENCIES = \ 84test_set_api_DEPENDENCIES = \
85 libgnunetset.la 85 libgnunetset.la
86 86
87
88test_mq_SOURCES = \
89 test_mq.c \
90 mq.c
91test_mq_LDADD = \
92 $(top_builddir)/src/util/libgnunetutil.la \
93 $(top_builddir)/src/stream/libgnunetstream.la
94test_mq_CFLAGS = $(AM_CFLAGS)
95
96
97test_mq_client_SOURCES = \
98 test_mq_client.c \
99 mq.c
100test_mq_client_LDADD = \
101 $(top_builddir)/src/util/libgnunetutil.la \
102 $(top_builddir)/src/stream/libgnunetstream.la
103test_mq_client_CFLAGS = $(AM_CFLAGS)
104
87EXTRA_DIST = \ 105EXTRA_DIST = \
88 test_set.conf 106 test_set.conf
89 107