aboutsummaryrefslogtreecommitdiff
path: root/src/seti/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/seti/Makefile.am')
-rw-r--r--src/seti/Makefile.am86
1 files changed, 0 insertions, 86 deletions
diff --git a/src/seti/Makefile.am b/src/seti/Makefile.am
deleted file mode 100644
index 8441c5060..000000000
--- a/src/seti/Makefile.am
+++ /dev/null
@@ -1,86 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10pkgcfg_DATA = \
11 seti.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = -fprofile-arcs -ftest-coverage
15endif
16
17bin_PROGRAMS = \
18 gnunet-seti-profiler
19
20libexec_PROGRAMS = \
21 gnunet-service-seti
22
23lib_LTLIBRARIES = \
24 libgnunetseti.la
25
26gnunet_seti_profiler_SOURCES = \
27 gnunet-seti-profiler.c
28gnunet_seti_profiler_LDADD = \
29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(top_builddir)/src/statistics/libgnunetstatistics.la \
31 libgnunetseti.la \
32 $(top_builddir)/src/testing/libgnunettesting.la \
33 $(GN_LIBINTL)
34
35
36gnunet_service_seti_SOURCES = \
37 gnunet-service-seti.c \
38 gnunet-service-seti_protocol.h
39gnunet_service_seti_LDADD = \
40 $(top_builddir)/src/util/libgnunetutil.la \
41 $(top_builddir)/src/statistics/libgnunetstatistics.la \
42 $(top_builddir)/src/core/libgnunetcore.la \
43 $(top_builddir)/src/cadet/libgnunetcadet.la \
44 $(top_builddir)/src/block/libgnunetblock.la \
45 libgnunetseti.la \
46 $(GN_LIBINTL)
47
48libgnunetseti_la_SOURCES = \
49 seti_api.c seti.h
50libgnunetseti_la_LIBADD = \
51 $(top_builddir)/src/util/libgnunetutil.la \
52 $(LTLIBINTL)
53libgnunetseti_la_LDFLAGS = \
54 $(GN_LIB_LDFLAGS)
55
56check_PROGRAMS = \
57 test_seti_api
58
59if ENABLE_TEST_RUN
60AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
61TESTS = $(check_PROGRAMS)
62endif
63
64test_seti_api_SOURCES = \
65 test_seti_api.c
66test_seti_api_LDADD = \
67 $(top_builddir)/src/util/libgnunetutil.la \
68 $(top_builddir)/src/testing/libgnunettesting.la \
69 libgnunetseti.la
70
71plugin_LTLIBRARIES = \
72 libgnunet_plugin_block_seti_test.la
73
74libgnunet_plugin_block_seti_test_la_SOURCES = \
75 plugin_block_seti_test.c
76libgnunet_plugin_block_seti_test_la_LIBADD = \
77 $(top_builddir)/src/block/libgnunetblock.la \
78 $(top_builddir)/src/block/libgnunetblockgroup.la \
79 $(top_builddir)/src/util/libgnunetutil.la \
80 $(LTLIBINTL)
81libgnunet_plugin_block_seti_test_la_LDFLAGS = \
82 $(GN_PLUGIN_LDFLAGS)
83
84
85EXTRA_DIST = \
86 test_seti.conf