aboutsummaryrefslogtreecommitdiff
path: root/src/seti/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/seti/Makefile.am')
-rw-r--r--src/seti/Makefile.am90
1 files changed, 0 insertions, 90 deletions
diff --git a/src/seti/Makefile.am b/src/seti/Makefile.am
deleted file mode 100644
index 522f33ece..000000000
--- a/src/seti/Makefile.am
+++ /dev/null
@@ -1,90 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10pkgcfg_DATA = \
11 seti.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = -fprofile-arcs -ftest-coverage
15endif
16
17if HAVE_TESTING
18bin_PROGRAMS = \
19 gnunet-seti-profiler
20endif
21
22libexec_PROGRAMS = \
23 gnunet-service-seti
24
25lib_LTLIBRARIES = \
26 libgnunetseti.la
27
28gnunet_seti_profiler_SOURCES = \
29 gnunet-seti-profiler.c
30gnunet_seti_profiler_LDADD = \
31 $(top_builddir)/src/util/libgnunetutil.la \
32 $(top_builddir)/src/statistics/libgnunetstatistics.la \
33 libgnunetseti.la \
34 $(top_builddir)/src/testing/libgnunettesting.la \
35 $(GN_LIBINTL)
36
37
38gnunet_service_seti_SOURCES = \
39 gnunet-service-seti.c \
40 gnunet-service-seti_protocol.h
41gnunet_service_seti_LDADD = \
42 $(top_builddir)/src/util/libgnunetutil.la \
43 $(top_builddir)/src/statistics/libgnunetstatistics.la \
44 $(top_builddir)/src/core/libgnunetcore.la \
45 $(top_builddir)/src/cadet/libgnunetcadet.la \
46 $(top_builddir)/src/block/libgnunetblock.la \
47 libgnunetseti.la \
48 $(GN_LIBINTL)
49
50libgnunetseti_la_SOURCES = \
51 seti_api.c seti.h
52libgnunetseti_la_LIBADD = \
53 $(top_builddir)/src/util/libgnunetutil.la \
54 $(LTLIBINTL)
55libgnunetseti_la_LDFLAGS = \
56 $(GN_LIB_LDFLAGS)
57
58if HAVE_TESTING
59check_PROGRAMS = \
60 test_seti_api
61endif
62
63if ENABLE_TEST_RUN
64AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
65TESTS = $(check_PROGRAMS)
66endif
67
68test_seti_api_SOURCES = \
69 test_seti_api.c
70test_seti_api_LDADD = \
71 $(top_builddir)/src/util/libgnunetutil.la \
72 $(top_builddir)/src/testing/libgnunettesting.la \
73 libgnunetseti.la
74
75plugin_LTLIBRARIES = \
76 libgnunet_plugin_block_seti_test.la
77
78libgnunet_plugin_block_seti_test_la_SOURCES = \
79 plugin_block_seti_test.c
80libgnunet_plugin_block_seti_test_la_LIBADD = \
81 $(top_builddir)/src/block/libgnunetblock.la \
82 $(top_builddir)/src/block/libgnunetblockgroup.la \
83 $(top_builddir)/src/util/libgnunetutil.la \
84 $(LTLIBINTL)
85libgnunet_plugin_block_seti_test_la_LDFLAGS = \
86 $(GN_PLUGIN_LDFLAGS)
87
88
89EXTRA_DIST = \
90 test_seti.conf