aboutsummaryrefslogtreecommitdiff
path: root/src/setu/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/setu/Makefile.am')
-rw-r--r--src/setu/Makefile.am106
1 files changed, 0 insertions, 106 deletions
diff --git a/src/setu/Makefile.am b/src/setu/Makefile.am
deleted file mode 100644
index 5c33148cd..000000000
--- a/src/setu/Makefile.am
+++ /dev/null
@@ -1,106 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10pkgcfg_DATA = \
11 setu.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = -fprofile-arcs -ftest-coverage
15endif
16
17noinst_PROGRAMS = \
18 gnunet-setu-ibf-profiler \
19 gnunet-setu-profiler
20
21libexec_PROGRAMS = \
22 gnunet-service-setu
23
24lib_LTLIBRARIES = \
25 libgnunetsetu.la
26
27gnunet_setu_profiler_SOURCES = \
28 gnunet-setu-profiler.c
29gnunet_setu_profiler_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(top_builddir)/src/statistics/libgnunetstatistics.la \
32 libgnunetsetu.la \
33 $(top_builddir)/src/testing/libgnunettesting.la \
34 $(GN_LIBINTL)
35
36
37gnunet_setu_ibf_profiler_SOURCES = \
38 gnunet-setu-ibf-profiler.c \
39 ibf.c
40gnunet_setu_ibf_profiler_LDADD = \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(GN_LIBINTL)
43
44gnunet_service_setu_SOURCES = \
45 gnunet-service-setu.c gnunet-service-setu_protocol.h \
46 ibf.c ibf.h \
47 gnunet-service-setu_strata_estimator.c gnunet-service-setu_strata_estimator.h \
48 gnunet-service-setu_protocol.h
49gnunet_service_setu_LDADD = \
50 $(top_builddir)/src/util/libgnunetutil.la \
51 $(top_builddir)/src/statistics/libgnunetstatistics.la \
52 $(top_builddir)/src/core/libgnunetcore.la \
53 $(top_builddir)/src/cadet/libgnunetcadet.la \
54 $(top_builddir)/src/block/libgnunetblock.la \
55 libgnunetsetu.la \
56 $(GN_LIBINTL)
57
58libgnunetsetu_la_SOURCES = \
59 setu_api.c setu.h
60libgnunetsetu_la_LIBADD = \
61 $(top_builddir)/src/util/libgnunetutil.la \
62 $(LTLIBINTL)
63libgnunetsetu_la_LDFLAGS = \
64 $(GN_LIB_LDFLAGS)
65
66check_PROGRAMS = \
67 test_setu_api \
68 perf_setu_api
69
70if ENABLE_TEST_RUN
71AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
72TESTS = $(check_PROGRAMS)
73endif
74
75test_setu_api_SOURCES = \
76 test_setu_api.c
77test_setu_api_LDADD = \
78 $(top_builddir)/src/util/libgnunetutil.la \
79 $(top_builddir)/src/testing/libgnunettesting.la \
80 libgnunetsetu.la
81
82
83perf_setu_api_SOURCES = \
84 perf_setu_api.c
85perf_setu_api_LDADD = \
86 $(top_builddir)/src/util/libgnunetutil.la \
87 $(top_builddir)/src/testing/libgnunettesting.la \
88 libgnunetsetu.la
89
90
91plugin_LTLIBRARIES = \
92 libgnunet_plugin_block_setu_test.la
93
94libgnunet_plugin_block_setu_test_la_SOURCES = \
95 plugin_block_setu_test.c
96libgnunet_plugin_block_setu_test_la_LIBADD = \
97 $(top_builddir)/src/block/libgnunetblock.la \
98 $(top_builddir)/src/block/libgnunetblockgroup.la \
99 $(top_builddir)/src/util/libgnunetutil.la \
100 $(LTLIBINTL)
101libgnunet_plugin_block_setu_test_la_LDFLAGS = \
102 $(GN_PLUGIN_LDFLAGS)
103
104
105EXTRA_DIST = \
106 test_setu.conf