aboutsummaryrefslogtreecommitdiff
path: root/src/setu/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/setu/Makefile.am')
-rw-r--r--src/setu/Makefile.am112
1 files changed, 0 insertions, 112 deletions
diff --git a/src/setu/Makefile.am b/src/setu/Makefile.am
deleted file mode 100644
index 77d048add..000000000
--- a/src/setu/Makefile.am
+++ /dev/null
@@ -1,112 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8plugindir = $(libdir)/gnunet
9
10pkgcfg_DATA = \
11 setu.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = -fprofile-arcs -ftest-coverage
15endif
16
17if HAVE_TESTING
18bin_PROGRAMS = \
19 gnunet-setu-profiler
20
21noinst_PROGRAMS = \
22 gnunet-setu-ibf-profiler
23endif
24
25libexec_PROGRAMS = \
26 gnunet-service-setu
27
28lib_LTLIBRARIES = \
29 libgnunetsetu.la
30
31gnunet_setu_profiler_SOURCES = \
32 gnunet-setu-profiler.c
33gnunet_setu_profiler_LDADD = \
34 $(top_builddir)/src/util/libgnunetutil.la \
35 $(top_builddir)/src/statistics/libgnunetstatistics.la \
36 libgnunetsetu.la \
37 $(top_builddir)/src/testing/libgnunettesting.la \
38 $(GN_LIBINTL)
39
40
41gnunet_setu_ibf_profiler_SOURCES = \
42 gnunet-setu-ibf-profiler.c \
43 ibf.c
44gnunet_setu_ibf_profiler_LDADD = \
45 $(top_builddir)/src/util/libgnunetutil.la \
46 $(GN_LIBINTL)
47
48gnunet_service_setu_SOURCES = \
49 gnunet-service-setu.c gnunet-service-setu_protocol.h \
50 ibf.c ibf.h \
51 gnunet-service-setu_strata_estimator.c gnunet-service-setu_strata_estimator.h \
52 gnunet-service-setu_protocol.h
53gnunet_service_setu_LDADD = \
54 $(top_builddir)/src/util/libgnunetutil.la \
55 $(top_builddir)/src/statistics/libgnunetstatistics.la \
56 $(top_builddir)/src/core/libgnunetcore.la \
57 $(top_builddir)/src/cadet/libgnunetcadet.la \
58 $(top_builddir)/src/block/libgnunetblock.la \
59 libgnunetsetu.la \
60 $(GN_LIBINTL)
61
62libgnunetsetu_la_SOURCES = \
63 setu_api.c setu.h
64libgnunetsetu_la_LIBADD = \
65 $(top_builddir)/src/util/libgnunetutil.la \
66 $(LTLIBINTL)
67libgnunetsetu_la_LDFLAGS = \
68 $(GN_LIB_LDFLAGS)
69
70if HAVE_TESTING
71check_PROGRAMS = \
72 test_setu_api \
73 perf_setu_api
74endif
75
76if ENABLE_TEST_RUN
77AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
78TESTS = $(check_PROGRAMS)
79endif
80
81test_setu_api_SOURCES = \
82 test_setu_api.c
83test_setu_api_LDADD = \
84 $(top_builddir)/src/util/libgnunetutil.la \
85 $(top_builddir)/src/testing/libgnunettesting.la \
86 libgnunetsetu.la
87
88
89perf_setu_api_SOURCES = \
90 perf_setu_api.c
91perf_setu_api_LDADD = \
92 $(top_builddir)/src/util/libgnunetutil.la \
93 $(top_builddir)/src/testing/libgnunettesting.la \
94 libgnunetsetu.la
95
96
97plugin_LTLIBRARIES = \
98 libgnunet_plugin_block_setu_test.la
99
100libgnunet_plugin_block_setu_test_la_SOURCES = \
101 plugin_block_setu_test.c
102libgnunet_plugin_block_setu_test_la_LIBADD = \
103 $(top_builddir)/src/block/libgnunetblock.la \
104 $(top_builddir)/src/block/libgnunetblockgroup.la \
105 $(top_builddir)/src/util/libgnunetutil.la \
106 $(LTLIBINTL)
107libgnunet_plugin_block_setu_test_la_LDFLAGS = \
108 $(GN_PLUGIN_LDFLAGS)
109
110
111EXTRA_DIST = \
112 test_setu.conf