aboutsummaryrefslogtreecommitdiff
path: root/src/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/template/Makefile.am')
-rw-r--r--src/template/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/template/Makefile.am b/src/template/Makefile.am
new file mode 100644
index 000000000..47d6b4165
--- /dev/null
+++ b/src/template/Makefile.am
@@ -0,0 +1,37 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = -fprofile-arcs -ftest-coverage
9endif
10
11bin_PROGRAMS = \
12 gnunet-template \
13 gnunet-service-template
14
15gnunet_template_SOURCES = \
16 gnunet-template.c
17gnunet_template_LDADD = \
18 $(top_builddir)/src/util/libgnunetutil.la \
19 $(GN_LIBINTL)
20
21gnunet_service_template_SOURCES = \
22 gnunet-service-template.c
23gnunet_service_template_LDADD = \
24 $(top_builddir)/src/util/libgnunetutil.la \
25 $(GN_LIBINTL)
26
27
28check_PROGRAMS = \
29 test_template_api
30
31TESTS = $(check_PROGRAMS)
32
33test_template_api_SOURCES = \
34 test_template_api.c
35test_template_api_LDADD = \
36 $(top_builddir)/src/util/libgnunetutil.la
37