aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 25cf2cbe2..dc357fbf7 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -89,7 +89,8 @@ check_PROGRAMS = \
89 test_testing_topology_erdos_renyi \ 89 test_testing_topology_erdos_renyi \
90 test_testing_topology_internat \ 90 test_testing_topology_internat \
91 test_testing_topology_none \ 91 test_testing_topology_none \
92 test_testing_topology_scale_free 92 test_testing_topology_scale_free \
93 test_testing_new_portreservation
93 94
94if ENABLE_TEST_RUN 95if ENABLE_TEST_RUN
95TESTS = \ 96TESTS = \
@@ -97,7 +98,8 @@ TESTS = \
97 test_testing_connect \ 98 test_testing_connect \
98 test_testing_reconnect \ 99 test_testing_reconnect \
99 test_testing_group \ 100 test_testing_group \
100 test_testing_peergroup 101 test_testing_peergroup \
102 test_testing_new_portreservation
101endif 103endif
102 104
103gnunet_testing_SOURCES = \ 105gnunet_testing_SOURCES = \
@@ -263,6 +265,12 @@ test_testing_topology_none_LDADD = \
263 $(top_builddir)/src/core/libgnunetcore.la \ 265 $(top_builddir)/src/core/libgnunetcore.la \
264 $(top_builddir)/src/util/libgnunetutil.la 266 $(top_builddir)/src/util/libgnunetutil.la
265 267
268test_testing_new_portreservation_SOURCES = \
269 test_testing_new_portreservation.c
270test_testing_new_portreservation_LDADD = \
271 $(top_builddir)/src/testing/libgnunettesting_new.la \
272 $(top_builddir)/src/util/libgnunetutil.la
273
266 274
267EXTRA_DIST = \ 275EXTRA_DIST = \
268 test_testing_defaults.conf \ 276 test_testing_defaults.conf \