aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am19
1 files changed, 8 insertions, 11 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 07caeb44e..3daa29e1e 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -42,20 +42,19 @@ libgnunet_test_testing_plugin_testcmd_la_LIBADD = \
42libgnunet_test_testing_plugin_testcmd_la_LDFLAGS = \ 42libgnunet_test_testing_plugin_testcmd_la_LDFLAGS = \
43 $(GN_PLUGIN_LDFLAGS) 43 $(GN_PLUGIN_LDFLAGS)
44 44
45
45libgnunettesting_la_SOURCES = \ 46libgnunettesting_la_SOURCES = \
47 testing_api_cmd_end.c \
48 testing_api_cmd_finish.c \
46 testing_api_cmd_local_test_finished.c \ 49 testing_api_cmd_local_test_finished.c \
47 testing_api_cmd_local_test_prepared.c \ 50 testing_api_cmd_local_test_prepared.c \
48 testing_api_cmd_send_peer_ready.c \ 51 testing_api_cmd_send_peer_ready.c \
49 testing_api_cmd_block_until_all_peers_started.c \ 52 testing_api_cmd_block_until_all_peers_started.c \
50 testing_api_cmd_block_until_external_trigger.c \ 53 testing_api_cmd_block_until_external_trigger.c \
51 testing_api_cmd_netjail_start.c \ 54 testing_api_cmd_netjail_start.c \
52 testing_api_cmd_netjail_start_v2.c \
53 testing_api_cmd_netjail_start_testsystem.c \ 55 testing_api_cmd_netjail_start_testsystem.c \
54 testing_api_cmd_netjail_start_testsystem_v2.c \
55 testing_api_cmd_netjail_stop_testsystem.c \ 56 testing_api_cmd_netjail_stop_testsystem.c \
56 testing_api_cmd_netjail_stop_testsystem_v2.c \
57 testing_api_cmd_netjail_stop.c \ 57 testing_api_cmd_netjail_stop.c \
58 testing_api_cmd_netjail_stop_v2.c \
59 testing.c testing.h \ 58 testing.c testing.h \
60 testing_api_cmd_system_create.c \ 59 testing_api_cmd_system_create.c \
61 testing_api_cmd_system_destroy.c \ 60 testing_api_cmd_system_destroy.c \
@@ -95,7 +94,6 @@ list_keys_LDADD = \
95 94
96 95
97check_PROGRAMS = \ 96check_PROGRAMS = \
98 test_testing_topology \
99 test_testing_api_cmd_netjail \ 97 test_testing_api_cmd_netjail \
100 test_testing_hello_world \ 98 test_testing_hello_world \
101 test_testing_portreservation \ 99 test_testing_portreservation \
@@ -107,7 +105,6 @@ check_PROGRAMS = \
107if ENABLE_TEST_RUN 105if ENABLE_TEST_RUN
108AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 106AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
109TESTS = \ 107TESTS = \
110 test_testing_topology \
111 test_testing_api_cmd_netjail \ 108 test_testing_api_cmd_netjail \
112 test_testing_hello_world \ 109 test_testing_hello_world \
113 test_testing_portreservation \ 110 test_testing_portreservation \
@@ -116,11 +113,11 @@ TESTS = \
116 test_testing_servicestartup 113 test_testing_servicestartup
117endif 114endif
118 115
119test_testing_topology_SOURCES = \ 116#test_testing_topology_SOURCES = \
120 test_testing_topology.c 117# test_testing_topology.c
121test_testing_topology_LDADD = \ 118#test_testing_topology_LDADD = \
122 libgnunettesting.la \ 119# libgnunettesting.la \
123 $(top_builddir)/src/util/libgnunetutil.la 120# $(top_builddir)/src/util/libgnunetutil.la
124 121
125test_testing_api_cmd_netjail_SOURCES = \ 122test_testing_api_cmd_netjail_SOURCES = \
126 test_testing_api_cmd_netjail.c 123 test_testing_api_cmd_netjail.c