aboutsummaryrefslogtreecommitdiff
path: root/src/topology/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/topology/Makefile.am')
-rw-r--r--src/topology/Makefile.am63
1 files changed, 0 insertions, 63 deletions
diff --git a/src/topology/Makefile.am b/src/topology/Makefile.am
deleted file mode 100644
index 8580d200c..000000000
--- a/src/topology/Makefile.am
+++ /dev/null
@@ -1,63 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12dist_pkgcfg_DATA = \
13 topology.conf
14
15
16lib_LTLIBRARIES = libgnunetfriends.la
17
18libgnunetfriends_la_SOURCES = \
19 friends.c
20libgnunetfriends_la_LIBADD = \
21 $(top_builddir)/src/util/libgnunetutil.la \
22 $(GN_LIBINTL) $(XLIB)
23libgnunetfriends_la_LDFLAGS = \
24 $(GN_LIB_LDFLAGS) \
25 -version-info 0:0:0
26
27
28libexec_PROGRAMS = \
29 gnunet-daemon-topology
30
31gnunet_daemon_topology_SOURCES = \
32 gnunet-daemon-topology.c
33gnunet_daemon_topology_LDADD = \
34 libgnunetfriends.la \
35 $(top_builddir)/src/core/libgnunetcore.la \
36 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
37 $(top_builddir)/src/statistics/libgnunetstatistics.la \
38 $(top_builddir)/src/transport/libgnunettransport.la \
39 $(top_builddir)/src/ats/libgnunetats.la \
40 $(top_builddir)/src/hello/libgnunethello.la \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(GN_LIBINTL)
43
44
45if HAVE_TESTING
46check_PROGRAMS = \
47 test_gnunet_daemon_topology
48endif
49
50if ENABLE_TEST_RUN
51AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
52TESTS = $(check_PROGRAMS)
53endif
54
55test_gnunet_daemon_topology_SOURCES = \
56 test_gnunet_daemon_topology.c
57test_gnunet_daemon_topology_LDADD = \
58 $(top_builddir)/src/testbed/libgnunettestbed.la \
59 $(top_builddir)/src/statistics/libgnunetstatistics.la \
60 $(top_builddir)/src/util/libgnunetutil.la
61
62EXTRA_DIST = \
63 test_gnunet_daemon_topology_data.conf