aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 3028b29b4..02e87da0f 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -11,12 +11,10 @@ pkgcfg_DATA = \
11 transport.conf \ 11 transport.conf \
12 communicator-unix.conf 12 communicator-unix.conf
13 13
14if HAVE_MHD 14HTTP_SERVER_PLUGIN_LA = libgnunet_plugin_transport_http_server.la
15 HTTP_SERVER_PLUGIN_LA = libgnunet_plugin_transport_http_server.la 15HTTPS_SERVER_PLUGIN_LA = libgnunet_plugin_transport_https_server.la
16 HTTPS_SERVER_PLUGIN_LA = libgnunet_plugin_transport_https_server.la 16HTTP_SERVER_PLUGIN_TEST = test_plugin_http_server
17 HTTP_SERVER_PLUGIN_TEST = test_plugin_http_server 17HTTPS_SERVER_PLUGIN_TEST = test_plugin_https_server
18 HTTPS_SERVER_PLUGIN_TEST = test_plugin_https_server
19endif
20 18
21if HAVE_LIBGNURL 19if HAVE_LIBGNURL
22 HTTP_CLIENT_PLUGIN_TEST = test_plugin_http_client 20 HTTP_CLIENT_PLUGIN_TEST = test_plugin_http_client
@@ -36,7 +34,6 @@ CPP_GNURL=@LIBCURL_CPPFLAGS@
36endif 34endif
37endif 35endif
38 36
39if HAVE_MHD
40if HAVE_LIBGNURL 37if HAVE_LIBGNURL
41 HTTP_API_TEST = test_transport_api_http 38 HTTP_API_TEST = test_transport_api_http
42 HTTP_REVERSE_API_TEST = test_transport_api_http_reverse 39 HTTP_REVERSE_API_TEST = test_transport_api_http_reverse
@@ -76,7 +73,6 @@ endif
76 HTTPS_SWITCH = test_transport_address_switch_https 73 HTTPS_SWITCH = test_transport_address_switch_https
77endif 74endif
78endif 75endif
79endif
80 76
81if USE_COVERAGE 77if USE_COVERAGE
82 AM_CFLAGS = --coverage -O0 78 AM_CFLAGS = --coverage -O0