aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am29
1 files changed, 20 insertions, 9 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 8ca6bf99a..a2fa0f0e9 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -29,6 +29,9 @@ if HAVE_LIBCURL
29 HTTP_API_TEST = test_transport_api_http 29 HTTP_API_TEST = test_transport_api_http
30 HTTP_API_TIMEOUT_TEST = test_transport_api_timeout_http 30 HTTP_API_TIMEOUT_TEST = test_transport_api_timeout_http
31 HTTP_REL_TEST = test_transport_api_reliability_http 31 HTTP_REL_TEST = test_transport_api_reliability_http
32 HTTP_QUOTA_TEST = test_quota_compliance_http \
33 test_quota_compliance_http_asymmetric
34
32 35
33 HTTPS_API_TEST = test_transport_api_https 36 HTTPS_API_TEST = test_transport_api_https
34endif 37endif
@@ -38,8 +41,6 @@ if FALSE
38 41
39 HTTP_REL_TEST = test_transport_api_reliability_http 42 HTTP_REL_TEST = test_transport_api_reliability_http
40 HTTP_NAT_REL_TEST = test_transport_api_reliability_http_nat 43 HTTP_NAT_REL_TEST = test_transport_api_reliability_http_nat
41 HTTP_QUOTA_TEST = test_quota_compliance_http \
42 test_quota_compliance_http_asymmetric
43 44
44 HTTPS_NAT_API_TEST = test_transport_api_https_nat 45 HTTPS_NAT_API_TEST = test_transport_api_https_nat
45 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https 46 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https
@@ -688,6 +689,23 @@ test_transport_api_reliability_http_LDADD = \
688 $(top_builddir)/src/util/libgnunetutil.la \ 689 $(top_builddir)/src/util/libgnunetutil.la \
689 $(top_builddir)/src/transport/libgnunettransporttesting.la 690 $(top_builddir)/src/transport/libgnunettransporttesting.la
690 691
692test_quota_compliance_http_SOURCES = \
693 test_quota_compliance.c
694test_quota_compliance_http_LDADD = \
695 $(top_builddir)/src/transport/libgnunettransport.la \
696 $(top_builddir)/src/hello/libgnunethello.la \
697 $(top_builddir)/src/util/libgnunetutil.la \
698 $(top_builddir)/src/transport/libgnunettransporttesting.la
699
700test_quota_compliance_http_asymmetric_SOURCES = \
701 test_quota_compliance.c
702test_quota_compliance_http_asymmetric_LDADD = \
703 $(top_builddir)/src/transport/libgnunettransport.la \
704 $(top_builddir)/src/hello/libgnunethello.la \
705 $(top_builddir)/src/util/libgnunetutil.la \
706 $(top_builddir)/src/transport/libgnunettransporttesting.la
707
708
691# HTTPS tests 709# HTTPS tests
692test_transport_api_https_SOURCES = \ 710test_transport_api_https_SOURCES = \
693 test_transport_api.c 711 test_transport_api.c
@@ -755,13 +773,6 @@ test_quota_compliance_http_LDADD = \
755 $(top_builddir)/src/util/libgnunetutil.la \ 773 $(top_builddir)/src/util/libgnunetutil.la \
756 $(top_builddir)/src/transport/libgnunettransporttesting.la 774 $(top_builddir)/src/transport/libgnunettransporttesting.la
757 775
758test_quota_compliance_http_asymmetric_SOURCES = \
759 test_quota_compliance.c
760test_quota_compliance_http_asymmetric_LDADD = \
761 $(top_builddir)/src/transport/libgnunettransport.la \
762 $(top_builddir)/src/hello/libgnunethello.la \
763 $(top_builddir)/src/util/libgnunetutil.la \
764 $(top_builddir)/src/transport/libgnunettransporttesting.la
765 776
766test_quota_compliance_https_SOURCES = \ 777test_quota_compliance_https_SOURCES = \
767 test_quota_compliance.c 778 test_quota_compliance.c