aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 2f30a212a..3112f0f30 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -103,6 +103,9 @@ UNIX_PLUGIN_TIMEOUT_TEST = test_transport_api_timeout_unix
103UNIX_REL_TEST = test_transport_api_unreliability_unix 103UNIX_REL_TEST = test_transport_api_unreliability_unix
104UNIX_QUOTA_TEST = test_quota_compliance_unix \ 104UNIX_QUOTA_TEST = test_quota_compliance_unix \
105 test_quota_compliance_unix_asymmetric 105 test_quota_compliance_unix_asymmetric
106if LINUX
107 UNIX_API_ABSTRACT_TEST = test_transport_api_unix_abstract
108endif
106endif 109endif
107 110
108noinst_PROGRAMS = \ 111noinst_PROGRAMS = \
@@ -396,6 +399,7 @@ check_PROGRAMS = \
396 test_transport_api_timeout_udp \ 399 test_transport_api_timeout_udp \
397 $(UNIX_PLUGIN_TEST) \ 400 $(UNIX_PLUGIN_TEST) \
398 $(UNIX_PLUGIN_TIMEOUT_TEST) \ 401 $(UNIX_PLUGIN_TIMEOUT_TEST) \
402 $(UNIX_API_ABSTRACT_TEST) \
399 test_transport_api_udp_nat \ 403 test_transport_api_udp_nat \
400 $(HTTP_API_TEST) \ 404 $(HTTP_API_TEST) \
401 $(HTTP_REVERSE_API_TEST) \ 405 $(HTTP_REVERSE_API_TEST) \
@@ -464,6 +468,7 @@ TESTS = \
464 test_transport_api_timeout_udp \ 468 test_transport_api_timeout_udp \
465 $(UNIX_PLUGIN_TEST) \ 469 $(UNIX_PLUGIN_TEST) \
466 $(UNIX_PLUGIN_TIMEOUT_TEST) \ 470 $(UNIX_PLUGIN_TIMEOUT_TEST) \
471 $(UNIX_API_ABSTRACT_TEST) \
467 test_transport_api_udp_nat \ 472 test_transport_api_udp_nat \
468 $(HTTP_API_TEST) \ 473 $(HTTP_API_TEST) \
469 $(HTTP_API_TIMEOUT_TEST) \ 474 $(HTTP_API_TIMEOUT_TEST) \
@@ -886,6 +891,14 @@ test_transport_api_unix_LDADD = \
886 $(top_builddir)/src/util/libgnunetutil.la \ 891 $(top_builddir)/src/util/libgnunetutil.la \
887 $(top_builddir)/src/transport/libgnunettransporttesting.la 892 $(top_builddir)/src/transport/libgnunettransporttesting.la
888 893
894test_transport_api_unix_abstract_SOURCES = \
895 test_transport_api.c
896test_transport_api_unix_abstract_LDADD = \
897 $(top_builddir)/src/transport/libgnunettransport.la \
898 $(top_builddir)/src/hello/libgnunethello.la \
899 $(top_builddir)/src/util/libgnunetutil.la \
900 $(top_builddir)/src/transport/libgnunettransporttesting.la
901
889# HTTP tests 902# HTTP tests
890test_transport_api_http_SOURCES = \ 903test_transport_api_http_SOURCES = \
891 test_transport_api.c 904 test_transport_api.c
@@ -1197,6 +1210,8 @@ test_transport_api_timeout_udp_peer1.conf\
1197test_transport_api_timeout_udp_peer2.conf\ 1210test_transport_api_timeout_udp_peer2.conf\
1198test_transport_api_unix_peer1.conf\ 1211test_transport_api_unix_peer1.conf\
1199test_transport_api_unix_peer2.conf\ 1212test_transport_api_unix_peer2.conf\
1213test_transport_api_unix_abstract_peer1.conf \
1214test_transport_api_unix_abstract_peer2.conf \
1200test_transport_api_timeout_unix_peer1.conf\ 1215test_transport_api_timeout_unix_peer1.conf\
1201test_transport_api_timeout_unix_peer2.conf\ 1216test_transport_api_timeout_unix_peer2.conf\
1202test_transport_api_timeout_wlan_peer1.conf \ 1217test_transport_api_timeout_wlan_peer1.conf \