aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am18
1 files changed, 4 insertions, 14 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index a9b0d19d6..0f5b2e8be 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -114,18 +114,12 @@ if HAVE_LIBBLUETOOTH
114 BT_QUOTA_TEST = test_quota_compliance_bluetooth \ 114 BT_QUOTA_TEST = test_quota_compliance_bluetooth \
115 test_quota_compliance_bluetooth_asymmetric 115 test_quota_compliance_bluetooth_asymmetric
116endif 116endif
117else
118if MINGW
119 BT_BIN = gnunet-helper-transport-bluetooth
120 BT_PLUGIN_LA = libgnunet_plugin_transport_bluetooth.la
121endif
122endif 117endif
123 118
124# end of HAVE_EXPERIMENTAL 119# end of HAVE_EXPERIMENTAL
125endif 120endif
126 121
127 122
128if !MINGW
129UNIX_PLUGIN_LA = libgnunet_plugin_transport_unix.la 123UNIX_PLUGIN_LA = libgnunet_plugin_transport_unix.la
130UNIX_PLUGIN_TEST = test_transport_api_unix 124UNIX_PLUGIN_TEST = test_transport_api_unix
131UNIX_TEST = test_plugin_unix 125UNIX_TEST = test_plugin_unix
@@ -136,7 +130,7 @@ UNIX_QUOTA_TEST = test_quota_compliance_unix \
136if LINUX 130if LINUX
137 UNIX_API_ABSTRACT_TEST = test_transport_api_unix_abstract 131 UNIX_API_ABSTRACT_TEST = test_transport_api_unix_abstract
138endif 132endif
139endif 133
140 134
141noinst_PROGRAMS = \ 135noinst_PROGRAMS = \
142 gnunet-transport-profiler \ 136 gnunet-transport-profiler \
@@ -319,13 +313,9 @@ gnunet_transport_wlan_receiver_LDADD = \
319 313
320gnunet_helper_transport_bluetooth_SOURCES = \ 314gnunet_helper_transport_bluetooth_SOURCES = \
321 gnunet-helper-transport-bluetooth.c 315 gnunet-helper-transport-bluetooth.c
322if MINGW 316
323 gnunet_helper_transport_bluetooth_LDADD = \ 317gnunet_helper_transport_bluetooth_LDFLAGS = -lbluetooth
324 $(top_builddir)/src/util/libgnunetutil.la 318
325 gnunet_helper_transport_bluetooth_LDFLAGS = -lws2_32
326else
327 gnunet_helper_transport_bluetooth_LDFLAGS = -lbluetooth
328endif
329 319
330gnunet_transport_profiler_SOURCES = \ 320gnunet_transport_profiler_SOURCES = \
331 gnunet-transport-profiler.c 321 gnunet-transport-profiler.c