aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am84
1 files changed, 84 insertions, 0 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
new file mode 100644
index 000000000..236dec7c4
--- /dev/null
+++ b/src/transport/Makefile.am
@@ -0,0 +1,84 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3plugindir = $(libdir)/gnunet
4
5if MINGW
6 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
7endif
8
9if USE_COVERAGE
10 AM_CFLAGS = -fprofile-arcs -ftest-coverage
11endif
12
13
14lib_LTLIBRARIES = \
15 libgnunettransport.la
16
17libgnunettransport_la_SOURCES = \
18 transport_api.c transport.h
19libgnunettransport_la_LIBADD = \
20 $(top_builddir)/src/arm/libgnunetarm.la \
21 $(top_builddir)/src/hello/libgnunethello.la \
22 $(top_builddir)/src/util/libgnunetutil.la \
23 $(GN_LIBINTL)
24libgnunettransport_la_LDFLAGS = \
25 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
26 -version-info 0:0:0
27
28
29bin_PROGRAMS = \
30 gnunet-transport \
31 gnunet-service-transport
32
33gnunet_transport_SOURCES = \
34 gnunet-transport.c
35gnunet_transport_LDADD = \
36 $(top_builddir)/src/transport/libgnunettransport.la \
37 $(top_builddir)/src/util/libgnunetutil.la \
38 $(GN_LIBINTL)
39
40gnunet_service_transport_SOURCES = \
41 gnunet-service-transport.c
42gnunet_service_transport_LDADD = \
43 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
44 $(top_builddir)/src/util/libgnunetutil.la \
45 $(GN_LIBINTL)
46
47
48
49plugin_LTLIBRARIES = \
50 libgnunet_plugin_transport_tcp.la \
51 libgnunet_plugin_transport_template.la
52# TODO: add udp, http, nat, etc.
53
54libgnunet_plugin_transport_tcp_la_SOURCES = \
55 plugin_transport_tcp.c
56libgnunet_plugin_transport_tcp_la_LIBADD = \
57 $(top_builddir)/src/resolver/libgnunetresolver.la \
58 $(top_builddir)/src/util/libgnunetutil.la
59libgnunet_plugin_transport_tcp_la_LDFLAGS = \
60 $(GN_PLUGIN_LDFLAGS)
61
62libgnunet_plugin_transport_template_la_SOURCES = \
63 plugin_transport_template.c
64libgnunet_plugin_transport_template_la_LDFLAGS = \
65 $(GN_PLUGIN_LDFLAGS)
66
67
68check_PROGRAMS = \
69 test_transport_api
70# TODO: add tests for tcp, udp, http, nat, etc.
71
72TESTS = $(check_PROGRAMS)
73
74test_transport_api_SOURCES = \
75 test_transport_api.c
76test_transport_api_LDADD = \
77 $(top_builddir)/src/transport/libgnunettransport.la \
78 $(top_builddir)/src/util/libgnunetutil.la
79
80
81EXTRA_DIST = \
82 test_transport_api_data.conf \
83 test_transport_api_peer1.conf \
84 test_transport_api_peer2.conf