aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 067e882a2..fbda1c614 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -202,7 +202,8 @@ check_PROGRAMS = \
202 $(HTTP_REL_TEST) \ 202 $(HTTP_REL_TEST) \
203 $(HTTPS_REL_TEST) \ 203 $(HTTPS_REL_TEST) \
204 test_quota_compliance_tcp \ 204 test_quota_compliance_tcp \
205 test_quota_compliance_http 205 test_quota_compliance_http \
206 test_quota_compliance_https
206# TODO: add tests for nat, etc. 207# TODO: add tests for nat, etc.
207 208
208if !DISABLE_TEST_RUN 209if !DISABLE_TEST_RUN
@@ -220,7 +221,8 @@ TESTS = \
220 $(HTTP_REL_TEST) \ 221 $(HTTP_REL_TEST) \
221 $(HTTPS_REL_TEST) \ 222 $(HTTPS_REL_TEST) \
222 test_quota_compliance_tcp \ 223 test_quota_compliance_tcp \
223 test_quota_compliance_http 224 test_quota_compliance_http \
225 test_quota_compliance_https
224endif 226endif
225 227
226test_transport_api_tcp_SOURCES = \ 228test_transport_api_tcp_SOURCES = \
@@ -319,6 +321,12 @@ test_quota_compliance_http_LDADD = \
319 $(top_builddir)/src/transport/libgnunettransport.la \ 321 $(top_builddir)/src/transport/libgnunettransport.la \
320 $(top_builddir)/src/util/libgnunetutil.la 322 $(top_builddir)/src/util/libgnunetutil.la
321 323
324test_quota_compliance_https_SOURCES = \
325 test_quota_compliance.c
326test_quota_compliance_https_LDADD = \
327 $(top_builddir)/src/transport/libgnunettransport.la \
328 $(top_builddir)/src/util/libgnunetutil.la
329
322endif 330endif
323 331
324EXTRA_DIST = \ 332EXTRA_DIST = \
@@ -346,4 +354,6 @@ EXTRA_DIST = \
346 test_quota_compliance_tcp_peer1.conf \ 354 test_quota_compliance_tcp_peer1.conf \
347 test_quota_compliance_tcp_peer2.conf \ 355 test_quota_compliance_tcp_peer2.conf \
348 test_quota_compliance_http_peer1.conf \ 356 test_quota_compliance_http_peer1.conf \
349 test_quota_compliance_http_peer2.conf \ No newline at end of file 357 test_quota_compliance_http_peer2.conf \
358 test_quota_compliance_https_peer1.conf \
359 test_quota_compliance_https_peer2.conf \ No newline at end of file