aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index bc3004a70..9f680ad3b 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -167,6 +167,9 @@ libgnunettransporttesting_la_LDFLAGS = \
167 $(GN_LIB_LDFLAGS) 167 $(GN_LIB_LDFLAGS)
168 168
169libgnunettransporttesting2_la_SOURCES = \ 169libgnunettransporttesting2_la_SOURCES = \
170 transport_api_cmd_connecting_peers.c \
171 transport_api_cmd_start_peer.c \
172 transport_api_cmd_send_simple.c \
170 transport-testing2.c transport-testing2.h \ 173 transport-testing2.c transport-testing2.h \
171 transport-testing-filenames2.c \ 174 transport-testing-filenames2.c \
172 transport-testing-loggers2.c \ 175 transport-testing-loggers2.c \
@@ -394,7 +397,19 @@ plugin_LTLIBRARIES = \
394 $(HTTP_SERVER_PLUGIN_LA) \ 397 $(HTTP_SERVER_PLUGIN_LA) \
395 $(HTTPS_SERVER_PLUGIN_LA) \ 398 $(HTTPS_SERVER_PLUGIN_LA) \
396 $(WLAN_PLUGIN_LA) \ 399 $(WLAN_PLUGIN_LA) \
397 $(BT_PLUGIN_LA) 400 $(BT_PLUGIN_LA)
401 # libgnunet_plugin_simple_send.la
402
403# libgnunet_plugin_cmd_simple_send_la_SOURCES = \
404# plugin_cmd_simple_send.c
405# libgnunet_plugin_cmd_simple_send_la_LIBADD = \
406# $(top_builddir)/src/util/libgnunetutil.la \
407# $(top_builddir)/src/testing/libgnunettesting.la \
408# $(top_builddir)/src/statistics/libgnunetstatistics.la \
409# $(top_builddir)/src/testbed/libgnunettestbed.la \
410# $(LTLIBINTL)
411# libgnunet_plugin_cmd_simple_send_la_LDFLAGS = \
412# $(GN_PLUGIN_LDFLAGS)
398 413
399if HAVE_EXPERIMENTAL 414if HAVE_EXPERIMENTAL
400plugin_LTLIBRARIES += libgnunet_plugin_transport_udp.la 415plugin_LTLIBRARIES += libgnunet_plugin_transport_udp.la
@@ -541,6 +556,7 @@ libgnunet_plugin_transport_https_server_la_CFLAGS = \
541 556
542if HAVE_TESTING 557if HAVE_TESTING
543check_PROGRAMS = \ 558check_PROGRAMS = \
559 test_transport_api_cmd_simple_send \
544 test_transport_address_switch_tcp \ 560 test_transport_address_switch_tcp \
545 test_transport_testing_startstop \ 561 test_transport_testing_startstop \
546 test_transport_testing_restart \ 562 test_transport_testing_restart \
@@ -629,6 +645,7 @@ endif
629if ENABLE_TEST_RUN 645if ENABLE_TEST_RUN
630AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 646AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
631TESTS = \ 647TESTS = \
648 test_transport_api_cmd_simple_send \
632 test_transport_address_switch_tcp \ 649 test_transport_address_switch_tcp \
633 $(HTTP_SWITCH) \ 650 $(HTTP_SWITCH) \
634 $(HTTPS_SWITCH) \ 651 $(HTTPS_SWITCH) \
@@ -705,6 +722,16 @@ TESTS += \
705endif 722endif
706endif 723endif
707 724
725test_transport_api_cmd_simple_send_SOURCES = \
726 test_transport_api_cmd_simple_send.c
727test_transport_api_cmd_simple_send_LDADD = \
728 $(top_builddir)/src/testing/libgnunettesting.la \
729 $(top_builddir)/src/util/libgnunetutil.la \
730 $(top_builddir)/src/testbed/libgnunettestbed.la \
731 libgnunettransport.la \
732 $(top_builddir)/src/hello/libgnunethello.la \
733 libgnunettransporttesting.la
734
708test_transport_testing_startstop_SOURCES = \ 735test_transport_testing_startstop_SOURCES = \
709 test_transport_testing_startstop.c 736 test_transport_testing_startstop.c
710test_transport_testing_startstop_LDADD = \ 737test_transport_testing_startstop_LDADD = \