aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am39
1 files changed, 36 insertions, 3 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 4ea3b58c4..8bd35b5a3 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -161,11 +161,13 @@ libgnunettransporttesting_la_LDFLAGS = \
161 161
162libgnunettransporttesting2_la_SOURCES = \ 162libgnunettransporttesting2_la_SOURCES = \
163 transport_api_cmd_connecting_peers.c \ 163 transport_api_cmd_connecting_peers.c \
164 transport_api_cmd_connecting_peers_v2.c \
164 transport_api_cmd_start_peer.c \ 165 transport_api_cmd_start_peer.c \
166 transport_api_cmd_start_peer_v2.c \
165 transport_api_cmd_stop_peer.c \ 167 transport_api_cmd_stop_peer.c \
166 transport_api_cmd_send_simple.c \ 168 transport_api_cmd_send_simple.c \
169 transport_api_cmd_send_simple_v2.c \
167 transport-testing2.c transport-testing2.h \ 170 transport-testing2.c transport-testing2.h \
168 transport-testing-ng.h \
169 transport-testing-cmds.h \ 171 transport-testing-cmds.h \
170 transport-testing-filenames2.c \ 172 transport-testing-filenames2.c \
171 transport-testing-loggers2.c \ 173 transport-testing-loggers2.c \
@@ -391,7 +393,8 @@ plugin_LTLIBRARIES = \
391 $(HTTPS_SERVER_PLUGIN_LA) \ 393 $(HTTPS_SERVER_PLUGIN_LA) \
392 $(WLAN_PLUGIN_LA) \ 394 $(WLAN_PLUGIN_LA) \
393 $(BT_PLUGIN_LA) \ 395 $(BT_PLUGIN_LA) \
394 libgnunet_test_transport_plugin_cmd_simple_send.la 396 libgnunet_test_transport_plugin_cmd_simple_send.la \
397 libgnunet_test_transport_plugin_cmd_simple_send_v2.la
395 398
396libgnunet_test_transport_plugin_cmd_simple_send_la_SOURCES = \ 399libgnunet_test_transport_plugin_cmd_simple_send_la_SOURCES = \
397 test_transport_plugin_cmd_simple_send.c 400 test_transport_plugin_cmd_simple_send.c
@@ -410,6 +413,23 @@ libgnunet_test_transport_plugin_cmd_simple_send_la_LIBADD = \
410libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \ 413libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \
411 $(GN_PLUGIN_LDFLAGS) 414 $(GN_PLUGIN_LDFLAGS)
412 415
416libgnunet_test_transport_plugin_cmd_simple_send_v2_la_SOURCES = \
417 test_transport_plugin_cmd_simple_send_v2.c
418libgnunet_test_transport_plugin_cmd_simple_send_v2_la_LIBADD = \
419 libgnunettransporttesting2.la \
420 libgnunettransportapplication.la \
421 libgnunettransport.la \
422 $(top_builddir)/src/testing/libgnunettesting.la \
423 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
424 $(top_builddir)/src/statistics/libgnunetstatistics.la \
425 $(top_builddir)/src/hello/libgnunethello.la \
426 $(top_builddir)/src/ats/libgnunetats.la \
427 $(top_builddir)/src/arm/libgnunetarm.la \
428 $(top_builddir)/src/util/libgnunetutil.la \
429 $(LTLIBINTL)
430libgnunet_test_transport_plugin_cmd_simple_send_v2_la_LDFLAGS = \
431 $(GN_PLUGIN_LDFLAGS)
432
413if HAVE_EXPERIMENTAL 433if HAVE_EXPERIMENTAL
414plugin_LTLIBRARIES += \ 434plugin_LTLIBRARIES += \
415 libgnunet_plugin_transport_udp.la 435 libgnunet_plugin_transport_udp.la
@@ -557,6 +577,7 @@ libgnunet_plugin_transport_https_server_la_CFLAGS = \
557if HAVE_TESTING 577if HAVE_TESTING
558check_PROGRAMS = \ 578check_PROGRAMS = \
559 test_transport_simple_send \ 579 test_transport_simple_send \
580 test_transport_simple_send_v2 \
560 test_transport_address_switch_tcp \ 581 test_transport_address_switch_tcp \
561 test_transport_testing_startstop \ 582 test_transport_testing_startstop \
562 test_transport_testing_restart \ 583 test_transport_testing_restart \
@@ -706,6 +727,7 @@ endif
706if HAVE_EXPERIMENTAL 727if HAVE_EXPERIMENTAL
707TESTS += \ 728TESTS += \
708 test_transport_simple_send \ 729 test_transport_simple_send \
730 test_transport_simple_send_v2 \
709 test_transport_address_switch_udp \ 731 test_transport_address_switch_udp \
710 test_plugin_udp \ 732 test_plugin_udp \
711 test_transport_api_udp \ 733 test_transport_api_udp \
@@ -724,7 +746,8 @@ endif
724endif 746endif
725 747
726check_SCRIPTS= \ 748check_SCRIPTS= \
727 test_transport_simple_send.sh 749 test_transport_simple_send.sh \
750 test_transport_simple_send_v2.sh
728 751
729test_transport_simple_send_SOURCES = \ 752test_transport_simple_send_SOURCES = \
730 test_transport_simple_send.c 753 test_transport_simple_send.c
@@ -736,6 +759,16 @@ test_transport_simple_send_LDADD = \
736 libgnunettransport.la \ 759 libgnunettransport.la \
737 libgnunettransporttesting.la 760 libgnunettransporttesting.la
738 761
762test_transport_simple_send_v2_SOURCES = \
763 test_transport_simple_send_v2.c
764test_transport_simple_send_v2_LDADD = \
765 $(top_builddir)/src/testing/libgnunettesting.la \
766 $(top_builddir)/src/util/libgnunetutil.la \
767 $(top_builddir)/src/testbed/libgnunettestbed.la \
768 $(top_builddir)/src/hello/libgnunethello.la \
769 libgnunettransport.la \
770 libgnunettransporttesting.la
771
739test_transport_testing_startstop_SOURCES = \ 772test_transport_testing_startstop_SOURCES = \
740 test_transport_testing_startstop.c 773 test_transport_testing_startstop.c
741test_transport_testing_startstop_LDADD = \ 774test_transport_testing_startstop_LDADD = \