aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index d0db6b141..92b53137f 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -140,6 +140,7 @@ endif
140 140
141noinst_PROGRAMS = \ 141noinst_PROGRAMS = \
142 gnunet-transport-profiler \ 142 gnunet-transport-profiler \
143 gnunet-communicator-unix \
143 $(WLAN_BIN_SENDER) \ 144 $(WLAN_BIN_SENDER) \
144 $(WLAN_BIN_RECEIVER) 145 $(WLAN_BIN_RECEIVER)
145 146
@@ -149,6 +150,7 @@ endif
149 150
150lib_LTLIBRARIES = \ 151lib_LTLIBRARIES = \
151 libgnunettransport.la \ 152 libgnunettransport.la \
153 libgnunettransportcommunicator.la \
152 $(TESTING_LIBS) 154 $(TESTING_LIBS)
153 155
154libgnunettransporttesting_la_SOURCES = \ 156libgnunettransporttesting_la_SOURCES = \
@@ -187,6 +189,17 @@ libgnunettransport_la_LDFLAGS = \
187 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 189 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
188 -version-info 4:0:2 190 -version-info 4:0:2
189 191
192
193
194libgnunettransportcommunicator_la_SOURCES = \
195 transport_api2_communication.c
196libgnunettransportcommunicator_la_LIBADD = \
197 $(top_builddir)/src/util/libgnunetutil.la \
198 $(GN_LIBINTL)
199libgnunettransportcommunicator_la_LDFLAGS = \
200 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
201 -version-info 0:0:0
202
190libexec_PROGRAMS = \ 203libexec_PROGRAMS = \
191 $(WLAN_BIN) \ 204 $(WLAN_BIN) \
192 $(WLAN_BIN_DUMMY) \ 205 $(WLAN_BIN_DUMMY) \
@@ -207,6 +220,14 @@ gnunet_transport_certificate_creation_SOURCES = \
207gnunet_transport_certificate_creation_LDADD = \ 220gnunet_transport_certificate_creation_LDADD = \
208 $(top_builddir)/src/util/libgnunetutil.la 221 $(top_builddir)/src/util/libgnunetutil.la
209 222
223gnunet_communicator_unix_SOURCES = \
224 gnunet-communicator-unix.c
225gnunet_communicator_unix_LDADD = \
226 libgnunettransportcommunicator.la \
227 $(top_builddir)/src/statistics/libgnunetstatistics.la \
228 $(top_builddir)/src/util/libgnunetutil.la
229
230
210gnunet_helper_transport_wlan_SOURCES = \ 231gnunet_helper_transport_wlan_SOURCES = \
211 gnunet-helper-transport-wlan.c 232 gnunet-helper-transport-wlan.c
212 233