aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 5d0ba2218..26a37c8bc 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -588,7 +588,8 @@ check_PROGRAMS += \
588test_transport_api_slow_ats 588test_transport_api_slow_ats
589endif 589endif
590check_PROGRAMS += \ 590check_PROGRAMS += \
591test_communicator_basic_unix 591test_communicator_basic_unix \
592test_communicator_basic_tcp
592if HAVE_EXPERIMENTAL 593if HAVE_EXPERIMENTAL
593check_PROGRAMS += \ 594check_PROGRAMS += \
594 test_transport_address_switch_udp \ 595 test_transport_address_switch_udp \
@@ -789,6 +790,14 @@ test_communicator_basic_unix_LDADD = \
789 $(top_builddir)/src/testing/libgnunettesting.la \ 790 $(top_builddir)/src/testing/libgnunettesting.la \
790 $(top_builddir)/src/util/libgnunetutil.la 791 $(top_builddir)/src/util/libgnunetutil.la
791 792
793test_communicator_basic_tcp_SOURCES = \
794 test_communicator_basic.c
795test_communicator_basic_tcp_LDADD = \
796 libgnunettransporttesting2.la \
797 $(top_builddir)/src/testing/libgnunettesting.la \
798 $(top_builddir)/src/util/libgnunetutil.la
799
800
792test_plugin_unix_SOURCES = \ 801test_plugin_unix_SOURCES = \
793 test_plugin_transport.c 802 test_plugin_transport.c
794test_plugin_unix_LDADD = \ 803test_plugin_unix_LDADD = \
@@ -1487,4 +1496,6 @@ test_transport_api_slow_ats_peer2.conf \
1487 tcp_server_legacy.c \ 1496 tcp_server_legacy.c \
1488 tcp_service_legacy.c \ 1497 tcp_service_legacy.c \
1489test_communicator_unix_peer1.conf \ 1498test_communicator_unix_peer1.conf \
1490test_communicator_unix_peer2.conf 1499test_communicator_unix_peer2.conf \
1500test_communicator_tcp_peer1.conf \
1501test_communicator_tcp_peer2.conf