aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index bb30e4cea..2e49b0cf0 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -53,6 +53,7 @@ if LINUX
53 WLAN_PLUGIN_LA = libgnunet_plugin_transport_wlan.la 53 WLAN_PLUGIN_LA = libgnunet_plugin_transport_wlan.la
54 WLAN_PLUGIN_TEST = test_plugin_wlan 54 WLAN_PLUGIN_TEST = test_plugin_wlan
55 WLAN_API_TEST = test_transport_api_wlan 55 WLAN_API_TEST = test_transport_api_wlan
56 WLAN_TIMEOUT_TEST = test_transport_api_timeout_wlan
56 WLAN_REL_TEST = test_transport_api_reliability_wlan 57 WLAN_REL_TEST = test_transport_api_reliability_wlan
57 WLAN_UREL_TEST = test_transport_api_unreliability_wlan 58 WLAN_UREL_TEST = test_transport_api_unreliability_wlan
58 WLAN_QUOTA_TEST = test_quota_compliance_wlan \ 59 WLAN_QUOTA_TEST = test_quota_compliance_wlan \
@@ -72,6 +73,7 @@ if HAVE_LIBBLUETOOTH
72 BT_PLUGIN_LA = libgnunet_plugin_transport_bluetooth.la 73 BT_PLUGIN_LA = libgnunet_plugin_transport_bluetooth.la
73 BT_PLUGIN_TEST = test_plugin_bluetooth 74 BT_PLUGIN_TEST = test_plugin_bluetooth
74 BT_API_TEST = test_transport_api_bluetooth 75 BT_API_TEST = test_transport_api_bluetooth
76 BT_TIMEOUT_TEST = test_transport_api_timeout_bluetooth
75 BT_REL_TEST = test_transport_api_reliability_bluetooth 77 BT_REL_TEST = test_transport_api_reliability_bluetooth
76 BT_UREL_TEST = test_transport_api_unreliability_bluetooth 78 BT_UREL_TEST = test_transport_api_unreliability_bluetooth
77 BT_QUOTA_TEST = test_quota_compliance_bluetooth \ 79 BT_QUOTA_TEST = test_quota_compliance_bluetooth \
@@ -398,7 +400,9 @@ check_PROGRAMS = \
398 $(HTTPS_API_TEST) \ 400 $(HTTPS_API_TEST) \
399 $(HTTPS_API_TIMEOUT_TEST) \ 401 $(HTTPS_API_TIMEOUT_TEST) \
400 $(WLAN_API_TEST) \ 402 $(WLAN_API_TEST) \
403 $(WLAN_TIMEOUT_TEST) \
401 $(BT_API_TEST) \ 404 $(BT_API_TEST) \
405 $(BT_TIMEOUT_TEST) \
402 test_transport_api_multi \ 406 test_transport_api_multi \
403 test_transport_blacklisting_no_bl \ 407 test_transport_blacklisting_no_bl \
404 test_transport_blacklisting_outbound_bl_full \ 408 test_transport_blacklisting_outbound_bl_full \
@@ -786,6 +790,22 @@ test_transport_api_timeout_unix_LDADD = \
786 $(top_builddir)/src/util/libgnunetutil.la \ 790 $(top_builddir)/src/util/libgnunetutil.la \
787 $(top_builddir)/src/transport/libgnunettransporttesting.la 791 $(top_builddir)/src/transport/libgnunettransporttesting.la
788 792
793test_transport_api_timeout_wlan_SOURCES = \
794 test_transport_api_timeout.c
795test_transport_api_timeout_wlan_LDADD = \
796 $(top_builddir)/src/transport/libgnunettransport.la \
797 $(top_builddir)/src/hello/libgnunethello.la \
798 $(top_builddir)/src/util/libgnunetutil.la \
799 $(top_builddir)/src/transport/libgnunettransporttesting.la
800
801test_transport_api_timeout_bluetooth_SOURCES = \
802 test_transport_api_timeout.c
803test_transport_api_timeout_bluetooth_LDADD = \
804 $(top_builddir)/src/transport/libgnunettransport.la \
805 $(top_builddir)/src/hello/libgnunethello.la \
806 $(top_builddir)/src/util/libgnunetutil.la \
807 $(top_builddir)/src/transport/libgnunettransporttesting.la
808
789test_transport_api_reliability_tcp_nat_SOURCES = \ 809test_transport_api_reliability_tcp_nat_SOURCES = \
790 test_transport_api_reliability.c 810 test_transport_api_reliability.c
791test_transport_api_reliability_tcp_nat_LDADD = \ 811test_transport_api_reliability_tcp_nat_LDADD = \
@@ -1155,6 +1175,10 @@ test_transport_api_unix_peer1.conf\
1155test_transport_api_unix_peer2.conf\ 1175test_transport_api_unix_peer2.conf\
1156test_transport_api_timeout_unix_peer1.conf\ 1176test_transport_api_timeout_unix_peer1.conf\
1157test_transport_api_timeout_unix_peer2.conf\ 1177test_transport_api_timeout_unix_peer2.conf\
1178test_transport_api_timeout_wlan_peer1.conf \
1179test_transport_api_timeout_wlan_peer2.conf \
1180test_transport_api_timeout_bluetooth_peer1.conf\
1181test_transport_api_timeout_bluetooth_peer2.conf\
1158test_transport_api_unreliability_udp_peer1.conf\ 1182test_transport_api_unreliability_udp_peer1.conf\
1159test_transport_api_unreliability_udp_peer2.conf\ 1183test_transport_api_unreliability_udp_peer2.conf\
1160test_transport_api_unreliability_unix_peer1.conf\ 1184test_transport_api_unreliability_unix_peer1.conf\