aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am54
1 files changed, 12 insertions, 42 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 842e7455f..ce05e6d55 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -55,7 +55,6 @@ if LINUX
55 WLAN_API_TEST = test_transport_api_wlan 55 WLAN_API_TEST = test_transport_api_wlan
56 WLAN_TIMEOUT_TEST = test_transport_api_timeout_wlan 56 WLAN_TIMEOUT_TEST = test_transport_api_timeout_wlan
57 WLAN_REL_TEST = test_transport_api_reliability_wlan 57 WLAN_REL_TEST = test_transport_api_reliability_wlan
58 WLAN_UREL_TEST = test_transport_api_unreliability_wlan
59 WLAN_QUOTA_TEST = test_quota_compliance_wlan \ 58 WLAN_QUOTA_TEST = test_quota_compliance_wlan \
60 test_quota_compliance_wlan_asymmetric 59 test_quota_compliance_wlan_asymmetric
61endif 60endif
@@ -75,7 +74,6 @@ if HAVE_LIBBLUETOOTH
75 BT_API_TEST = test_transport_api_bluetooth 74 BT_API_TEST = test_transport_api_bluetooth
76 BT_TIMEOUT_TEST = test_transport_api_timeout_bluetooth 75 BT_TIMEOUT_TEST = test_transport_api_timeout_bluetooth
77 BT_REL_TEST = test_transport_api_reliability_bluetooth 76 BT_REL_TEST = test_transport_api_reliability_bluetooth
78 BT_UREL_TEST = test_transport_api_unreliability_bluetooth
79 BT_QUOTA_TEST = test_quota_compliance_bluetooth \ 77 BT_QUOTA_TEST = test_quota_compliance_bluetooth \
80 test_quota_compliance_bluetooth_asymmetric 78 test_quota_compliance_bluetooth_asymmetric
81endif 79endif
@@ -100,7 +98,7 @@ UNIX_PLUGIN_LA = libgnunet_plugin_transport_unix.la
100UNIX_PLUGIN_TEST = test_transport_api_unix 98UNIX_PLUGIN_TEST = test_transport_api_unix
101UNIX_TEST = test_plugin_unix 99UNIX_TEST = test_plugin_unix
102UNIX_PLUGIN_TIMEOUT_TEST = test_transport_api_timeout_unix 100UNIX_PLUGIN_TIMEOUT_TEST = test_transport_api_timeout_unix
103UNIX_REL_TEST = test_transport_api_unreliability_unix 101UNIX_REL_TEST = test_transport_api_reliability_unix
104UNIX_QUOTA_TEST = test_quota_compliance_unix \ 102UNIX_QUOTA_TEST = test_quota_compliance_unix \
105 test_quota_compliance_unix_asymmetric 103 test_quota_compliance_unix_asymmetric
106if LINUX 104if LINUX
@@ -430,8 +428,7 @@ check_PROGRAMS = \
430 test_transport_api_manipulation_cfg \ 428 test_transport_api_manipulation_cfg \
431 test_transport_api_reliability_tcp \ 429 test_transport_api_reliability_tcp \
432 test_transport_api_reliability_tcp_nat \ 430 test_transport_api_reliability_tcp_nat \
433 test_transport_api_unreliability_udp \ 431 test_transport_api_reliability_udp \
434 test_transport_api_unreliability_constant_udp \
435 $(UNIX_REL_TEST) \ 432 $(UNIX_REL_TEST) \
436 $(HTTP_REL_TEST) \ 433 $(HTTP_REL_TEST) \
437 $(HTTPS_REL_TEST) \ 434 $(HTTPS_REL_TEST) \
@@ -498,8 +495,7 @@ TESTS = \
498 test_transport_api_manipulation_cfg \ 495 test_transport_api_manipulation_cfg \
499 test_transport_api_reliability_tcp \ 496 test_transport_api_reliability_tcp \
500 test_transport_api_reliability_tcp_nat \ 497 test_transport_api_reliability_tcp_nat \
501 test_transport_api_unreliability_udp \ 498 test_transport_api_reliability_udp \
502 test_transport_api_unreliability_constant_udp \
503 $(UNIX_REL_TEST) \ 499 $(UNIX_REL_TEST) \
504 $(HTTP_REL_TEST) \ 500 $(HTTP_REL_TEST) \
505 $(HTTPS_REL_TEST) \ 501 $(HTTPS_REL_TEST) \
@@ -833,14 +829,6 @@ test_transport_api_reliability_tcp_nat_LDADD = \
833 $(top_builddir)/src/util/libgnunetutil.la \ 829 $(top_builddir)/src/util/libgnunetutil.la \
834 $(top_builddir)/src/transport/libgnunettransporttesting.la 830 $(top_builddir)/src/transport/libgnunettransporttesting.la
835 831
836test_transport_api_reliability_wlan_SOURCES = \
837 test_transport_api_reliability.c
838test_transport_api_reliability_wlan_LDADD = \
839 $(top_builddir)/src/transport/libgnunettransport.la \
840 $(top_builddir)/src/hello/libgnunethello.la \
841 $(top_builddir)/src/util/libgnunetutil.la \
842 $(top_builddir)/src/transport/libgnunettransporttesting.la
843
844test_transport_api_reliability_bluetooth_SOURCES = \ 832test_transport_api_reliability_bluetooth_SOURCES = \
845 test_transport_api_reliability.c 833 test_transport_api_reliability.c
846test_transport_api_reliability_bluetooth_LDADD = \ 834test_transport_api_reliability_bluetooth_LDADD = \
@@ -849,17 +837,9 @@ test_transport_api_reliability_bluetooth_LDADD = \
849 $(top_builddir)/src/util/libgnunetutil.la \ 837 $(top_builddir)/src/util/libgnunetutil.la \
850 $(top_builddir)/src/transport/libgnunettransporttesting.la 838 $(top_builddir)/src/transport/libgnunettransporttesting.la
851 839
852test_transport_api_unreliability_wlan_SOURCES = \ 840test_transport_api_reliability_wlan_SOURCES = \
853 test_transport_api_unreliability.c 841 test_transport_api_reliability.c
854test_transport_api_unreliability_wlan_LDADD = \ 842test_transport_api_reliability_wlan_LDADD = \
855 $(top_builddir)/src/transport/libgnunettransport.la \
856 $(top_builddir)/src/hello/libgnunethello.la \
857 $(top_builddir)/src/util/libgnunetutil.la \
858 $(top_builddir)/src/transport/libgnunettransporttesting.la
859
860test_transport_api_unreliability_bluetooth_SOURCES = \
861 test_transport_api_unreliability.c
862test_transport_api_unreliability_bluetooth_LDADD = \
863 $(top_builddir)/src/transport/libgnunettransport.la \ 843 $(top_builddir)/src/transport/libgnunettransport.la \
864 $(top_builddir)/src/hello/libgnunethello.la \ 844 $(top_builddir)/src/hello/libgnunethello.la \
865 $(top_builddir)/src/util/libgnunetutil.la \ 845 $(top_builddir)/src/util/libgnunetutil.la \
@@ -996,25 +976,17 @@ test_transport_api_reliability_https_LDADD = \
996 $(top_builddir)/src/util/libgnunetutil.la \ 976 $(top_builddir)/src/util/libgnunetutil.la \
997 $(top_builddir)/src/transport/libgnunettransporttesting.la 977 $(top_builddir)/src/transport/libgnunettransporttesting.la
998 978
999test_transport_api_unreliability_unix_SOURCES = \ 979test_transport_api_reliability_unix_SOURCES = \
1000 test_transport_api_unreliability.c 980 test_transport_api_reliability.c
1001test_transport_api_unreliability_unix_LDADD = \ 981test_transport_api_reliability_unix_LDADD = \
1002 $(top_builddir)/src/transport/libgnunettransport.la \
1003 $(top_builddir)/src/hello/libgnunethello.la \
1004 $(top_builddir)/src/util/libgnunetutil.la \
1005 $(top_builddir)/src/transport/libgnunettransporttesting.la
1006
1007test_transport_api_unreliability_udp_SOURCES = \
1008 test_transport_api_unreliability.c
1009test_transport_api_unreliability_udp_LDADD = \
1010 $(top_builddir)/src/transport/libgnunettransport.la \ 982 $(top_builddir)/src/transport/libgnunettransport.la \
1011 $(top_builddir)/src/hello/libgnunethello.la \ 983 $(top_builddir)/src/hello/libgnunethello.la \
1012 $(top_builddir)/src/util/libgnunetutil.la \ 984 $(top_builddir)/src/util/libgnunetutil.la \
1013 $(top_builddir)/src/transport/libgnunettransporttesting.la 985 $(top_builddir)/src/transport/libgnunettransporttesting.la
1014 986
1015test_transport_api_unreliability_constant_udp_SOURCES = \ 987test_transport_api_reliability_udp_SOURCES = \
1016 test_transport_api_unreliability_constant.c 988 test_transport_api_reliability.c
1017test_transport_api_unreliability_constant_udp_LDADD = \ 989test_transport_api_reliability_udp_LDADD = \
1018 $(top_builddir)/src/transport/libgnunettransport.la \ 990 $(top_builddir)/src/transport/libgnunettransport.la \
1019 $(top_builddir)/src/hello/libgnunethello.la \ 991 $(top_builddir)/src/hello/libgnunethello.la \
1020 $(top_builddir)/src/util/libgnunetutil.la \ 992 $(top_builddir)/src/util/libgnunetutil.la \
@@ -1249,8 +1221,6 @@ test_transport_api_timeout_http_peer1.conf\
1249test_transport_api_timeout_http_peer2.conf\ 1221test_transport_api_timeout_http_peer2.conf\
1250test_transport_api_timeout_https_peer1.conf\ 1222test_transport_api_timeout_https_peer1.conf\
1251test_transport_api_timeout_https_peer2.conf\ 1223test_transport_api_timeout_https_peer2.conf\
1252test_transport_api_unreliability_constant_udp_peer1.conf\
1253test_transport_api_unreliability_constant_udp_peer2.conf\
1254test_transport_blacklisting_cfg_peer1.conf \ 1224test_transport_blacklisting_cfg_peer1.conf \
1255test_transport_blacklisting_cfg_peer2.conf \ 1225test_transport_blacklisting_cfg_peer2.conf \
1256test_transport_blacklisting_cfg_blp_peer1_full.conf\ 1226test_transport_blacklisting_cfg_blp_peer1_full.conf\