aboutsummaryrefslogtreecommitdiff
path: root/src/tun/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/tun/Makefile.am')
-rw-r--r--src/tun/Makefile.am46
1 files changed, 0 insertions, 46 deletions
diff --git a/src/tun/Makefile.am b/src/tun/Makefile.am
deleted file mode 100644
index c741f5654..000000000
--- a/src/tun/Makefile.am
+++ /dev/null
@@ -1,46 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if MINGW
5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
6endif
7
8if USE_COVERAGE
9 AM_CFLAGS = --coverage -O0
10 XLIB = -lgcov
11endif
12
13lib_LTLIBRARIES = libgnunettun.la
14
15libgnunettun_la_SOURCES = \
16 tun.c \
17 regex.c
18libgnunettun_la_LIBADD = \
19 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
20 $(LTLIBINTL)
21libgnunettun_la_LDFLAGS = \
22 $(GN_LIB_LDFLAGS) \
23 -version-info 1:0:1
24
25
26check_PROGRAMS = \
27 test_tun \
28 test_regex
29
30if ENABLE_TEST_RUN
31AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
32TESTS = $(check_PROGRAMS)
33endif
34
35test_tun_SOURCES = \
36 test_tun.c
37test_tun_LDADD = \
38 $(top_builddir)/src/util/libgnunetutil.la \
39 libgnunettun.la
40
41
42test_regex_SOURCES = \
43 test_regex.c
44test_regex_LDADD = \
45 $(top_builddir)/src/util/libgnunetutil.la \
46 libgnunettun.la