aboutsummaryrefslogtreecommitdiff
path: root/src/upnp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/upnp/Makefile.am')
-rw-r--r--src/upnp/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/src/upnp/Makefile.am b/src/upnp/Makefile.am
new file mode 100644
index 000000000..02a2b139d
--- /dev/null
+++ b/src/upnp/Makefile.am
@@ -0,0 +1,59 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = -fprofile-arcs -ftest-coverage
9endif
10
11lib_LTLIBRARIES = libgnunetupnp.la
12
13libgnunetupnp_la_SOURCES = \
14 upnp.c upnp.h \
15 upnp_ip.c upnp_ip.h \
16 upnp_util.c upnp_util.h \
17 upnp_xmlnode.c upnp_xmlnode.h
18libgnunetupnp_la_CFLAGS = \
19 -I$(top_scrdir)/include \
20 @LIBCURL_CPPFLAGS@ @XML_CPPFLAGS@
21libgnunetupnp_la_LIBADD = \
22 $(top_builddir)/src/util/libgnunetutil.la \
23 $(GN_LIBINTL) @EXT_LIBS@ @XML_LIBS@ @LIBCURL@
24libgnunetupnp_la_LDFLAGS = \
25 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
26 -version-info 0:0:0
27
28
29bin_PROGRAMS = \
30 gnunet-upnp \
31 gnunet-service-upnp
32
33gnunet_upnp_SOURCES = \
34 gnunet-upnp.c
35gnunet_upnp_LDADD = \
36 $(top_builddir)/src/upnp/libgnunetupnp.la \
37 $(top_builddir)/src/util/libgnunetutil.la \
38 $(GN_LIBINTL)
39
40gnunet_service_upnp_SOURCES = \
41 gnunet-service-upnp.c
42gnunet_service_upnp_LDADD = \
43 $(top_builddir)/src/util/libgnunetutil.la \
44 $(GN_LIBINTL)
45
46
47check_PROGRAMS = \
48 test_upnp
49
50TESTS = $(check_PROGRAMS)
51
52test_upnp_SOURCES = \
53 test_upnp.c
54test_upnp_LDADD = \
55 $(top_builddir)/src/transport/libgnunetupnp.la \
56 $(top_builddir)/src/util/libgnunetutil.la
57
58
59# EXTRA_DIST = test_upnp_data.conf