aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 6b9e083a7..e2614e5e3 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -25,6 +25,11 @@ if ENABLE_BENCHMARK
25 PTHREAD = -lpthread 25 PTHREAD = -lpthread
26endif 26endif
27 27
28if HAVE_NOLIBGCRYPT19
29 DLOG = crypto_ecc_dlog.c
30 DLOG_TEST = test_crypto_ecc_dlog
31endif
32
28gnunet_config_diff_SOURCES = \ 33gnunet_config_diff_SOURCES = \
29 gnunet-config-diff.c 34 gnunet-config-diff.c
30gnunet_config_diff_LDADD = \ 35gnunet_config_diff_LDADD = \
@@ -58,7 +63,7 @@ libgnunetutil_la_SOURCES = \
58 crypto_symmetric.c \ 63 crypto_symmetric.c \
59 crypto_crc.c \ 64 crypto_crc.c \
60 crypto_ecc.c \ 65 crypto_ecc.c \
61 crypto_ecc_dlog.c \ 66 $(DLOG) \
62 crypto_ecc_setup.c \ 67 crypto_ecc_setup.c \
63 crypto_hash.c \ 68 crypto_hash.c \
64 crypto_hash_file.c \ 69 crypto_hash_file.c \
@@ -248,7 +253,6 @@ libgnunet_plugin_test_la_LDFLAGS = \
248if HAVE_BENCHMARKS 253if HAVE_BENCHMARKS
249 BENCHMARKS = \ 254 BENCHMARKS = \
250 perf_crypto_hash \ 255 perf_crypto_hash \
251 perf_crypto_ecc_dlog \
252 perf_crypto_rsa \ 256 perf_crypto_rsa \
253 perf_crypto_paillier \ 257 perf_crypto_paillier \
254 perf_crypto_symmetric \ 258 perf_crypto_symmetric \
@@ -256,6 +260,10 @@ if HAVE_BENCHMARKS
256 perf_malloc \ 260 perf_malloc \
257 perf_mq \ 261 perf_mq \
258 perf_scheduler 262 perf_scheduler
263
264if HAVE_NOLIBGCRYPT19
265 BENCHMARKS += perf_crypto_ecc_dlog
266endif
259endif 267endif
260 268
261if HAVE_SSH_KEY 269if HAVE_SSH_KEY
@@ -287,7 +295,7 @@ check_PROGRAMS = \
287 test_crypto_ecdhe \ 295 test_crypto_ecdhe \
288 test_crypto_ecdh_eddsa \ 296 test_crypto_ecdh_eddsa \
289 test_crypto_ecdh_ecdsa \ 297 test_crypto_ecdh_ecdsa \
290 test_crypto_ecc_dlog \ 298 $(DLOG_TEST) \
291 test_crypto_hash \ 299 test_crypto_hash \
292 test_crypto_hash_context \ 300 test_crypto_hash_context \
293 test_crypto_hkdf \ 301 test_crypto_hkdf \
@@ -448,11 +456,13 @@ test_crypto_eddsa_LDADD = \
448 libgnunetutil.la \ 456 libgnunetutil.la \
449 $(LIBGCRYPT_LIBS) 457 $(LIBGCRYPT_LIBS)
450 458
459if HAVE_NOLIBGCRYPT19
451test_crypto_ecc_dlog_SOURCES = \ 460test_crypto_ecc_dlog_SOURCES = \
452 test_crypto_ecc_dlog.c 461 test_crypto_ecc_dlog.c
453test_crypto_ecc_dlog_LDADD = \ 462test_crypto_ecc_dlog_LDADD = \
454 libgnunetutil.la \ 463 libgnunetutil.la \
455 $(LIBGCRYPT_LIBS) 464 $(LIBGCRYPT_LIBS)
465endif
456 466
457test_crypto_ecdhe_SOURCES = \ 467test_crypto_ecdhe_SOURCES = \
458 test_crypto_ecdhe.c 468 test_crypto_ecdhe.c
@@ -595,11 +605,13 @@ perf_crypto_hash_SOURCES = \
595perf_crypto_hash_LDADD = \ 605perf_crypto_hash_LDADD = \
596 libgnunetutil.la 606 libgnunetutil.la
597 607
608if HAVE_NOLIBGCRYPT19
598perf_crypto_ecc_dlog_SOURCES = \ 609perf_crypto_ecc_dlog_SOURCES = \
599 perf_crypto_ecc_dlog.c 610 perf_crypto_ecc_dlog.c
600perf_crypto_ecc_dlog_LDADD = \ 611perf_crypto_ecc_dlog_LDADD = \
601 libgnunetutil.la \ 612 libgnunetutil.la \
602 -lgcrypt 613 -lgcrypt
614endif
603 615
604perf_crypto_rsa_SOURCES = \ 616perf_crypto_rsa_SOURCES = \
605 perf_crypto_rsa.c 617 perf_crypto_rsa.c