aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 09620aee0..9c1fb01a4 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -43,6 +43,7 @@ libgnunetutil_la_SOURCES = \
43 $(BENCHMARK) \ 43 $(BENCHMARK) \
44 bio.c \ 44 bio.c \
45 buffer.c \ 45 buffer.c \
46 child_management.c \
46 client.c \ 47 client.c \
47 common_allocation.c \ 48 common_allocation.c \
48 common_endian.c \ 49 common_endian.c \
@@ -271,6 +272,7 @@ check_SCRIPTS = \
271 272
272check_PROGRAMS = \ 273check_PROGRAMS = \
273 test_bio \ 274 test_bio \
275 test_child_management \
274 test_client.nc \ 276 test_client.nc \
275 $(TEST_CLIENT_UNIX_NC) \ 277 $(TEST_CLIENT_UNIX_NC) \
276 test_common_allocation \ 278 test_common_allocation \
@@ -323,6 +325,14 @@ check_PROGRAMS = \
323 test_common_logging_runtime_loglevels 325 test_common_logging_runtime_loglevels
324 326
325 327
328test_child_management_SOURCES = \
329 test_child_management.c
330test_child_management_LDADD = \
331 libgnunetutil.la \
332 $(XLIB)
333
334
335
326# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart 336# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart
327# sequential execution order for them 337# sequential execution order for them
328TEST_EXTENSIONS = .nc 338TEST_EXTENSIONS = .nc
@@ -650,4 +660,5 @@ EXTRA_DIST = \
650 test_program_data.conf \ 660 test_program_data.conf \
651 test_resolver_api_data.conf \ 661 test_resolver_api_data.conf \
652 test_service_data.conf \ 662 test_service_data.conf \
653 test_speedup_data.conf 663 test_speedup_data.conf \
664 child_management_test.sh