summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am43
1 files changed, 3 insertions, 40 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 647f09224..c240053ff 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -13,27 +13,7 @@ dist_pkgcfg_DATA = \
13pkgcfg_DATA = \ 13pkgcfg_DATA = \
14 resolver.conf 14 resolver.conf
15 15
16if MINGW 16TEST_CLIENT_UNIX_NC = test_client_unix.nc
17noinst_LTLIBRARIES = \
18 libgnunetutilwin.la
19libgnunetutilwin_la_SOURCES = \
20 win.c \
21 winproc.c
22libgnunetutilwin_la_LDFLAGS = \
23 -no-undefined -Wl,--export-all-symbols
24libgnunetutilwin_la_LIBADD = \
25 -lshell32 -liconv -lstdc++ \
26 -lcomdlg32 -lgdi32 -liphlpapi
27WINLIB = libgnunetutilwin.la
28W32CAT = w32cat
29W32CONSOLEHELPER = gnunet-helper-w32-console
30endif
31
32if !MINGW
33 TEST_CLIENT_UNIX_NC = test_client_unix.nc
34else
35 TEST_CLIENT_UNIX_NC =
36endif
37 17
38if USE_COVERAGE 18if USE_COVERAGE
39 AM_CFLAGS = --coverage -O0 19 AM_CFLAGS = --coverage -O0
@@ -45,14 +25,6 @@ if ENABLE_BENCHMARK
45 PTHREAD = -lpthread 25 PTHREAD = -lpthread
46endif 26endif
47 27
48w32cat_SOURCES = w32cat.c
49
50gnunet_helper_w32_console_SOURCES = \
51 gnunet-helper-w32-console.c \
52 gnunet-helper-w32-console.h
53gnunet_helper_w32_console_LDADD = \
54 libgnunetutil.la
55
56gnunet_config_diff_SOURCES = \ 28gnunet_config_diff_SOURCES = \
57 gnunet-config-diff.c 29 gnunet-config-diff.c
58gnunet_config_diff_LDADD = \ 30gnunet_config_diff_LDADD = \
@@ -202,8 +174,7 @@ lib_LTLIBRARIES = libgnunetutil.la
202 174
203libexec_PROGRAMS = \ 175libexec_PROGRAMS = \
204 gnunet-service-resolver \ 176 gnunet-service-resolver \
205 gnunet-timeout \ 177 gnunet-timeout
206 $(W32CONSOLEHELPER)
207 178
208bin_PROGRAMS = \ 179bin_PROGRAMS = \
209 gnunet-resolver \ 180 gnunet-resolver \
@@ -217,7 +188,6 @@ endif
217 188
218noinst_PROGRAMS = \ 189noinst_PROGRAMS = \
219 gnunet-config-diff \ 190 gnunet-config-diff \
220 $(W32CAT) \
221 test_common_logging_dummy 191 test_common_logging_dummy
222 192
223 193
@@ -228,14 +198,8 @@ endif
228 198
229endif 199endif
230 200
231
232if !MINGW
233gnunet_timeout_SOURCES = \ 201gnunet_timeout_SOURCES = \
234 gnunet-timeout.c 202 gnunet-timeout.c
235else
236gnunet_timeout_SOURCES = \
237 gnunet-timeout-w32.c
238endif
239 203
240gnunet_service_resolver_SOURCES = \ 204gnunet_service_resolver_SOURCES = \
241 gnunet-service-resolver.c 205 gnunet-service-resolver.c
@@ -393,8 +357,7 @@ test_os_start_process_SOURCES = \
393test_os_start_process_LDADD = \ 357test_os_start_process_LDADD = \
394 libgnunetutil.la 358 libgnunetutil.la
395test_os_start_process_DEPENDENCIES = \ 359test_os_start_process_DEPENDENCIES = \
396 libgnunetutil.la \ 360 libgnunetutil.la
397 $(WINCAT)
398 361
399test_client_nc_SOURCES = \ 362test_client_nc_SOURCES = \
400 test_client.c 363 test_client.c