aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am38
1 files changed, 36 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index eb655157d..4ae073c2c 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -89,6 +89,8 @@ libgnunetutil_la_SOURCES = \
89 crypto_rsa.c \ 89 crypto_rsa.c \
90 disk.c \ 90 disk.c \
91 disk.h \ 91 disk.h \
92 dnsparser.c \
93 dnsstub.c \
92 getopt.c \ 94 getopt.c \
93 getopt_helpers.c \ 95 getopt_helpers.c \
94 helper.c \ 96 helper.c \
@@ -104,12 +106,14 @@ libgnunetutil_la_SOURCES = \
104 peer.c \ 106 peer.c \
105 plugin.c \ 107 plugin.c \
106 program.c \ 108 program.c \
109 regex.c \
107 resolver_api.c resolver.h \ 110 resolver_api.c resolver.h \
108 scheduler.c \ 111 scheduler.c \
109 service.c \ 112 service.c \
110 signal.c \ 113 signal.c \
111 strings.c \ 114 strings.c \
112 time.c \ 115 time.c \
116 tun.c \
113 speedup.c speedup.h 117 speedup.c speedup.h
114 118
115libgnunetutil_la_LIBADD = \ 119libgnunetutil_la_LIBADD = \
@@ -117,7 +121,7 @@ libgnunetutil_la_LIBADD = \
117 $(LIBGCRYPT_LIBS) \ 121 $(LIBGCRYPT_LIBS) \
118 $(LTLIBICONV) \ 122 $(LTLIBICONV) \
119 $(LTLIBINTL) \ 123 $(LTLIBINTL) \
120 -lltdl $(Z_LIBS) -lunistring $(XLIB) 124 -lltdl -lidn $(Z_LIBS) -lunistring $(XLIB)
121 125
122libgnunetutil_la_LDFLAGS = \ 126libgnunetutil_la_LDFLAGS = \
123 $(GN_LIB_LDFLAGS) \ 127 $(GN_LIB_LDFLAGS) \
@@ -162,6 +166,7 @@ lib_LTLIBRARIES = libgnunetutil.la
162 166
163libexec_PROGRAMS = \ 167libexec_PROGRAMS = \
164 gnunet-service-resolver \ 168 gnunet-service-resolver \
169 gnunet-timeout \
165 $(W32CONSOLEHELPER) 170 $(W32CONSOLEHELPER)
166 171
167bin_SCRIPTS =\ 172bin_SCRIPTS =\
@@ -188,6 +193,15 @@ endif
188endif 193endif
189 194
190 195
196if !MINGW
197gnunet_timeout_SOURCES = \
198 gnunet-timeout.c
199else
200gnunet_timeout_SOURCES = \
201 gnunet-timeout-w32.c
202endif
203
204
191do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g' 205do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
192 206
193gnunet-qr: gnunet-qr.py.in Makefile 207gnunet-qr: gnunet-qr.py.in Makefile
@@ -199,6 +213,9 @@ gnunet_service_resolver_SOURCES = \
199gnunet_service_resolver_LDADD = \ 213gnunet_service_resolver_LDADD = \
200 libgnunetutil.la \ 214 libgnunetutil.la \
201 $(GN_LIBINTL) 215 $(GN_LIBINTL)
216if HAVE_GETADDRINFO_A
217gnunet_service_resolver_LDADD += -lanl
218endif
202 219
203 220
204gnunet_resolver_SOURCES = \ 221gnunet_resolver_SOURCES = \
@@ -288,19 +305,22 @@ check_PROGRAMS = \
288 test_crypto_rsa \ 305 test_crypto_rsa \
289 test_disk \ 306 test_disk \
290 test_getopt \ 307 test_getopt \
308 test_hexcoder \
291 test_mq \ 309 test_mq \
292 test_os_network \ 310 test_os_network \
293 test_peer \ 311 test_peer \
294 test_plugin \ 312 test_plugin \
295 test_program \ 313 test_program \
314 test_regex \
296 test_resolver_api.nc \ 315 test_resolver_api.nc \
297 test_scheduler \ 316 test_scheduler \
298 test_scheduler_delay \ 317 test_scheduler_delay \
299 test_service \ 318 test_service \
300 test_strings \ 319 test_strings \
301 test_strings_to_data \ 320 test_strings_to_data \
302 test_time \
303 test_speedup \ 321 test_speedup \
322 test_time \
323 test_tun \
304 $(BENCHMARKS) \ 324 $(BENCHMARKS) \
305 test_os_start_process \ 325 test_os_start_process \
306 test_common_logging_runtime_loglevels 326 test_common_logging_runtime_loglevels
@@ -316,6 +336,20 @@ test_bio_SOURCES = \
316test_bio_LDADD = \ 336test_bio_LDADD = \
317 libgnunetutil.la 337 libgnunetutil.la
318 338
339test_hexcoder_SOURCES = \
340 test_hexcoder.c
341test_hexcoder_LDADD = \
342 libgnunetutil.la
343
344test_tun_SOURCES = \
345 test_tun.c
346test_tun_LDADD = \
347 libgnunetutil.la
348
349test_regex_SOURCES = \
350 test_regex.c
351test_regex_LDADD = \
352 libgnunetutil.la
319 353
320test_os_start_process_SOURCES = \ 354test_os_start_process_SOURCES = \
321 test_os_start_process.c 355 test_os_start_process.c