aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am665
1 files changed, 0 insertions, 665 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
deleted file mode 100644
index d21ac5e86..000000000
--- a/src/util/Makefile.am
+++ /dev/null
@@ -1,665 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6libexecdir= $(pkglibdir)/libexec/
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10dist_pkgcfg_DATA = \
11 util.conf
12
13pkgcfg_DATA = \
14 resolver.conf
15
16TEST_CLIENT_UNIX_NC = test_client_unix.nc
17
18if USE_COVERAGE
19 AM_CFLAGS = --coverage -O0
20 XLIB = -lgcov
21endif
22
23if ENABLE_BENCHMARK
24 BENCHMARK = benchmark.c benchmark.h
25 PTHREAD = -lpthread
26endif
27
28DLOG = crypto_ecc_dlog.c
29DLOG_TEST = test_crypto_ecc_dlog
30
31gnunet_config_diff_SOURCES = \
32 gnunet-config-diff.c
33gnunet_config_diff_LDADD = \
34 libgnunetutil.la
35
36test_common_logging_dummy_SOURCES = \
37 test_common_logging_dummy.c
38test_common_logging_dummy_LDADD = \
39 libgnunetutil.la
40
41libgnunetutil_la_SOURCES = \
42 bandwidth.c \
43 $(BENCHMARK) \
44 bio.c \
45 buffer.c \
46 child_management.c \
47 client.c \
48 common_allocation.c \
49 common_endian.c \
50 common_logging.c \
51 configuration.c \
52 configuration_helper.c \
53 consttime_memcmp.c \
54 container_bloomfilter.c \
55 container_heap.c \
56 container_meta_data.c \
57 container_multihashmap.c \
58 container_multishortmap.c \
59 container_multiuuidmap.c \
60 container_multipeermap.c \
61 container_multihashmap32.c \
62 crypto_symmetric.c \
63 crypto_crc.c \
64 crypto_ecc.c \
65 crypto_ecc_gnsrecord.c \
66 $(DLOG) \
67 crypto_ecc_setup.c \
68 crypto_hash.c \
69 crypto_hash_file.c \
70 crypto_hkdf.c \
71 crypto_kdf.c \
72 crypto_mpi.c \
73 crypto_paillier.c \
74 crypto_pow.c \
75 crypto_random.c \
76 crypto_rsa.c \
77 disk.c \
78 disk.h \
79 dnsparser.c \
80 dnsstub.c \
81 getopt.c \
82 getopt_helpers.c \
83 helper.c \
84 load.c \
85 mst.c \
86 mq.c \
87 nc.c \
88 network.c \
89 op.c \
90 os_installation.c \
91 os_network.c \
92 os_priority.c \
93 peer.c \
94 plugin.c \
95 program.c \
96 regex.c \
97 resolver_api.c resolver.h \
98 scheduler.c \
99 service.c \
100 signal.c \
101 strings.c \
102 time.c \
103 tun.c \
104 uri.c \
105 speedup.c speedup.h \
106 proc_compat.c
107
108if HAVE_LIBATOMIC
109if DARWIN
110 LIBATOMIC=
111else
112 LIBATOMIC= -latomic
113endif
114else
115 LIBATOMIC=
116endif
117
118if HAVE_LIBIDN
119 LIBIDN= -lidn
120else
121 LIBIDN=
122endif
123
124if HAVE_LIBIDN2
125 LIBIDN2= -lidn2
126else
127 LIBIDN2=
128endif
129
130libgnunetutil_la_LIBADD = \
131 $(GCLIBADD) $(WINLIB) \
132 $(LIBATOMIC) \
133 $(LIBGCRYPT_LIBS) \
134 $(LTLIBICONV) \
135 $(LTLIBINTL) \
136 -lltdl \
137 $(LIBIDN) $(LIBIDN2) \
138 $(Z_LIBS) \
139 -lunistring \
140 -lsodium \
141 $(XLIB) \
142 $(PTHREAD)
143
144libgnunetutil_la_LDFLAGS = \
145 $(GN_LIB_LDFLAGS) \
146 -version-info 14:0:0
147
148GNUNET_ECC = gnunet-ecc
149GNUNET_SCRYPT = gnunet-scrypt
150
151lib_LTLIBRARIES = libgnunetutil.la
152
153libexec_PROGRAMS = \
154 gnunet-service-resolver \
155 gnunet-timeout
156
157bin_PROGRAMS = \
158 gnunet-base32 \
159 gnunet-config \
160 gnunet-crypto-tvg \
161 gnunet-resolver \
162 $(GNUNET_ECC) \
163 $(GNUNET_SCRYPT) \
164 gnunet-uri
165if HAVE_ZBAR
166bin_PROGRAMS += gnunet-qr
167endif
168
169noinst_PROGRAMS = \
170 gnunet-config-diff \
171 test_common_logging_dummy
172
173
174if ENABLE_TEST_RUN
175AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
176TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
177endif
178
179gnunet_timeout_SOURCES = \
180 gnunet-timeout.c
181
182gnunet_service_resolver_SOURCES = \
183 gnunet-service-resolver.c
184gnunet_service_resolver_LDADD = \
185 libgnunetutil.la \
186 $(GN_LIBINTL)
187if HAVE_GETADDRINFO_A
188gnunet_service_resolver_LDADD += -lanl
189endif
190
191
192gnunet_resolver_SOURCES = \
193 gnunet-resolver.c
194gnunet_resolver_LDADD = \
195 libgnunetutil.la \
196 $(GN_LIBINTL)
197
198gnunet_crypto_tvg_SOURCES = \
199 gnunet-crypto-tvg.c
200gnunet_crypto_tvg_LDADD = \
201 libgnunetutil.la \
202 $(GN_LIBINTL) -lgcrypt -ljansson
203
204gnunet_ecc_SOURCES = \
205 gnunet-ecc.c
206gnunet_ecc_LDADD = \
207 libgnunetutil.la \
208 $(GN_LIBINTL) -lgcrypt
209
210gnunet_base32_SOURCES = \
211 gnunet-base32.c
212gnunet_base32_LDADD = \
213 libgnunetutil.la \
214 $(GN_LIBINTL)
215
216gnunet_scrypt_SOURCES = \
217 gnunet-scrypt.c
218gnunet_scrypt_LDADD = \
219 libgnunetutil.la \
220 $(GN_LIBINTL) -lgcrypt
221
222
223gnunet_config_SOURCES = \
224 gnunet-config.c
225gnunet_config_LDADD = \
226 libgnunetutil.la \
227 $(GN_LIBINTL)
228
229gnunet_uri_SOURCES = \
230 gnunet-uri.c
231gnunet_uri_LDADD = \
232 libgnunetutil.la \
233 $(GN_LIBINTL)
234
235
236gnunet_qr_SOURCES = \
237 gnunet-qr.c
238gnunet_qr_LDADD = \
239 libgnunetutil.la \
240 $(GN_LIBINTL)
241gnunet_qr_LDFLAGS= -lzbar
242if HAVE_PNG
243gnunet_qr_LDFLAGS += -lpng
244endif
245
246plugin_LTLIBRARIES = \
247 libgnunet_plugin_utiltest.la
248
249libgnunet_plugin_utiltest_la_SOURCES = \
250 test_plugin_plug.c
251libgnunet_plugin_utiltest_la_LDFLAGS = \
252 $(GN_PLUGIN_LDFLAGS)
253
254if HAVE_BENCHMARKS
255 BENCHMARKS = \
256 perf_crypto_hash \
257 perf_crypto_rsa \
258 perf_crypto_paillier \
259 perf_crypto_symmetric \
260 perf_crypto_asymmetric \
261 perf_malloc \
262 perf_mq \
263 perf_scheduler \
264 perf_crypto_ecc_dlog
265endif
266
267if HAVE_SSH_KEY
268# SSH_USING_TESTS = test_socks.nc
269endif
270
271check_SCRIPTS = \
272 test_crypto_vectors.sh
273
274check_PROGRAMS = \
275 test_bio \
276 test_child_management \
277 test_client.nc \
278 $(TEST_CLIENT_UNIX_NC) \
279 test_common_allocation \
280 test_common_endian \
281 test_common_logging \
282 test_configuration \
283 test_container_bloomfilter \
284 test_container_dll \
285 test_container_meta_data \
286 test_container_multihashmap \
287 test_container_multihashmap32 \
288 test_container_multipeermap \
289 test_container_heap \
290 test_crypto_symmetric \
291 test_crypto_crc \
292 test_crypto_ecdsa \
293 test_crypto_eddsa \
294 test_crypto_ecdhe \
295 test_crypto_ecdh_eddsa \
296 test_crypto_ecdh_ecdsa \
297 $(DLOG_TEST) \
298 test_crypto_hash \
299 test_crypto_hash_context \
300 test_crypto_hkdf \
301 test_crypto_kdf \
302 test_crypto_paillier \
303 test_crypto_random \
304 test_crypto_rsa \
305 test_disk \
306 test_getopt \
307 test_hexcoder \
308 test_mq \
309 test_os_network \
310 test_peer \
311 test_plugin \
312 test_program \
313 test_regex \
314 test_resolver_api.nc \
315 test_scheduler \
316 test_scheduler_delay \
317 test_service \
318 test_strings \
319 test_strings_to_data \
320 test_speedup \
321 test_time \
322 test_tun \
323 test_uri \
324 $(BENCHMARKS) \
325 test_os_start_process \
326 test_common_logging_runtime_loglevels
327
328
329test_child_management_SOURCES = \
330 test_child_management.c
331test_child_management_LDADD = \
332 libgnunetutil.la \
333 $(XLIB)
334
335
336
337# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart
338# sequential execution order for them
339TEST_EXTENSIONS = .nc
340test_test_client_unix.log: test_client.log
341
342test_bio_SOURCES = \
343 test_bio.c
344test_bio_LDADD = \
345 libgnunetutil.la
346
347test_hexcoder_SOURCES = \
348 test_hexcoder.c
349test_hexcoder_LDADD = \
350 libgnunetutil.la
351
352test_tun_SOURCES = \
353 test_tun.c
354test_tun_LDADD = \
355 libgnunetutil.la
356
357test_regex_SOURCES = \
358 test_regex.c
359test_regex_LDADD = \
360 libgnunetutil.la
361
362test_os_start_process_SOURCES = \
363 test_os_start_process.c
364test_os_start_process_LDADD = \
365 libgnunetutil.la
366
367test_client_nc_SOURCES = \
368 test_client.c
369test_client_nc_LDADD = \
370 libgnunetutil.la
371
372test_client_unix_nc_SOURCES = \
373 test_client.c
374test_client_unix_nc_LDADD = \
375 libgnunetutil.la
376
377#test_socks_nc_SOURCES = \
378# test_socks.c
379#test_socks_nc_LDADD = \
380# libgnunetutil.la
381
382test_common_allocation_SOURCES = \
383 test_common_allocation.c
384test_common_allocation_LDADD = \
385 libgnunetutil.la
386
387test_common_endian_SOURCES = \
388 test_common_endian.c
389test_common_endian_LDADD = \
390 libgnunetutil.la
391
392test_common_logging_SOURCES = \
393 test_common_logging.c
394test_common_logging_LDADD = \
395 libgnunetutil.la
396
397test_common_logging_runtime_loglevels_SOURCES = \
398 test_common_logging_runtime_loglevels.c
399test_common_logging_runtime_loglevels_LDADD = \
400 libgnunetutil.la
401
402test_configuration_SOURCES = \
403 test_configuration.c
404test_configuration_LDADD = \
405 libgnunetutil.la
406
407test_container_bloomfilter_SOURCES = \
408 test_container_bloomfilter.c
409test_container_bloomfilter_LDADD = \
410 libgnunetutil.la
411
412test_container_dll_SOURCES = \
413 test_container_dll.c
414test_container_dll_LDADD = \
415 libgnunetutil.la
416
417test_container_meta_data_SOURCES = \
418 test_container_meta_data.c
419test_container_meta_data_LDADD = \
420 libgnunetutil.la
421
422test_container_multihashmap_SOURCES = \
423 test_container_multihashmap.c
424test_container_multihashmap_LDADD = \
425 libgnunetutil.la
426
427test_container_multihashmap32_SOURCES = \
428 test_container_multihashmap32.c
429test_container_multihashmap32_LDADD = \
430 libgnunetutil.la
431
432test_container_multipeermap_SOURCES = \
433 test_container_multipeermap.c
434test_container_multipeermap_LDADD = \
435 libgnunetutil.la
436
437test_container_heap_SOURCES = \
438 test_container_heap.c
439test_container_heap_LDADD = \
440 libgnunetutil.la
441
442test_crypto_symmetric_SOURCES = \
443 test_crypto_symmetric.c
444test_crypto_symmetric_LDADD = \
445 libgnunetutil.la
446
447test_crypto_crc_SOURCES = \
448 test_crypto_crc.c
449test_crypto_crc_LDADD = \
450 libgnunetutil.la
451
452test_crypto_ecdsa_SOURCES = \
453 test_crypto_ecdsa.c
454test_crypto_ecdsa_LDADD = \
455 libgnunetutil.la \
456 $(LIBGCRYPT_LIBS)
457
458test_crypto_eddsa_SOURCES = \
459 test_crypto_eddsa.c
460test_crypto_eddsa_LDADD = \
461 libgnunetutil.la \
462 $(LIBGCRYPT_LIBS)
463
464test_crypto_ecc_dlog_SOURCES = \
465 test_crypto_ecc_dlog.c
466test_crypto_ecc_dlog_LDADD = \
467 -lsodium \
468 libgnunetutil.la \
469 $(LIBGCRYPT_LIBS)
470
471test_crypto_ecdhe_SOURCES = \
472 test_crypto_ecdhe.c
473test_crypto_ecdhe_LDADD = \
474 libgnunetutil.la \
475 $(LIBGCRYPT_LIBS)
476
477test_crypto_ecdh_eddsa_SOURCES = \
478 test_crypto_ecdh_eddsa.c
479test_crypto_ecdh_eddsa_LDADD = \
480 libgnunetutil.la \
481 $(LIBGCRYPT_LIBS)
482
483test_crypto_ecdh_ecdsa_SOURCES = \
484 test_crypto_ecdh_ecdsa.c
485test_crypto_ecdh_ecdsa_LDADD = \
486 libgnunetutil.la \
487 $(LIBGCRYPT_LIBS)
488
489
490test_crypto_hash_SOURCES = \
491 test_crypto_hash.c
492test_crypto_hash_LDADD = \
493 libgnunetutil.la
494
495test_crypto_hash_context_SOURCES = \
496 test_crypto_hash_context.c
497test_crypto_hash_context_LDADD = \
498 libgnunetutil.la
499
500test_crypto_hkdf_SOURCES = \
501 test_crypto_hkdf.c
502test_crypto_hkdf_LDADD = \
503 libgnunetutil.la
504
505test_crypto_kdf_SOURCES = \
506 test_crypto_kdf.c
507test_crypto_kdf_LDADD = \
508 libgnunetutil.la -lgcrypt
509
510test_crypto_paillier_SOURCES = \
511 test_crypto_paillier.c
512test_crypto_paillier_LDADD = \
513 $(LIBGCRYPT_LIBS) \
514 libgnunetutil.la
515
516test_crypto_random_SOURCES = \
517 test_crypto_random.c
518test_crypto_random_LDADD = \
519 libgnunetutil.la
520
521test_crypto_rsa_SOURCES = \
522 test_crypto_rsa.c
523test_crypto_rsa_LDADD = \
524 libgnunetutil.la -lgcrypt
525
526test_disk_SOURCES = \
527 test_disk.c
528test_disk_LDADD = \
529 libgnunetutil.la
530
531test_getopt_SOURCES = \
532 test_getopt.c
533test_getopt_LDADD = \
534 libgnunetutil.la
535
536test_mq_SOURCES = \
537 test_mq.c
538test_mq_LDADD = \
539 libgnunetutil.la
540
541test_os_network_SOURCES = \
542 test_os_network.c
543test_os_network_LDADD = \
544 libgnunetutil.la
545
546test_peer_SOURCES = \
547 test_peer.c
548test_peer_LDADD = \
549 libgnunetutil.la -lgcrypt
550
551test_plugin_SOURCES = \
552 test_plugin.c
553test_plugin_LDADD = \
554 libgnunetutil.la
555
556test_program_SOURCES = \
557 test_program.c
558test_program_LDADD = \
559 libgnunetutil.la
560
561test_resolver_api_nc_SOURCES = \
562 test_resolver_api.c
563test_resolver_api_nc_LDADD = \
564 libgnunetutil.la
565
566test_scheduler_SOURCES = \
567 test_scheduler.c
568test_scheduler_LDADD = \
569 libgnunetutil.la
570
571test_scheduler_delay_SOURCES = \
572 test_scheduler_delay.c
573test_scheduler_delay_LDADD = \
574 libgnunetutil.la
575
576test_service_SOURCES = \
577 test_service.c
578test_service_LDADD = \
579 libgnunetutil.la
580
581test_strings_SOURCES = \
582 test_strings.c
583test_strings_LDADD = \
584 libgnunetutil.la
585
586test_strings_to_data_SOURCES = \
587 test_strings_to_data.c
588test_strings_to_data_LDADD = \
589 libgnunetutil.la
590
591
592test_time_SOURCES = \
593 test_time.c
594test_time_LDADD = \
595 libgnunetutil.la
596
597test_speedup_SOURCES = \
598 test_speedup.c
599test_speedup_LDADD = \
600 libgnunetutil.la
601
602test_uri_SOURCES = \
603 test_uri.c
604test_uri_LDADD = \
605 libgnunetutil.la
606
607perf_crypto_hash_SOURCES = \
608 perf_crypto_hash.c
609perf_crypto_hash_LDADD = \
610 libgnunetutil.la
611
612perf_crypto_ecc_dlog_SOURCES = \
613 perf_crypto_ecc_dlog.c
614perf_crypto_ecc_dlog_LDADD = \
615 libgnunetutil.la \
616 -lsodium
617
618perf_crypto_rsa_SOURCES = \
619 perf_crypto_rsa.c
620perf_crypto_rsa_LDADD = \
621 libgnunetutil.la
622
623perf_crypto_symmetric_SOURCES = \
624 perf_crypto_symmetric.c
625perf_crypto_symmetric_LDADD = \
626 libgnunetutil.la
627
628perf_crypto_asymmetric_SOURCES = \
629 perf_crypto_asymmetric.c
630perf_crypto_asymmetric_LDADD = \
631 libgnunetutil.la
632
633perf_crypto_paillier_SOURCES = \
634 perf_crypto_paillier.c
635perf_crypto_paillier_LDADD = \
636 libgnunetutil.la \
637 -lgcrypt
638
639perf_malloc_SOURCES = \
640 perf_malloc.c
641perf_malloc_LDADD = \
642 libgnunetutil.la
643
644perf_mq_SOURCES = \
645 perf_mq.c
646perf_mq_LDADD = \
647 libgnunetutil.la
648
649perf_scheduler_SOURCES = \
650 perf_scheduler.c
651perf_scheduler_LDADD = \
652 libgnunetutil.la
653
654
655EXTRA_DIST = \
656 test_client_data.conf \
657 test_client_unix.conf \
658 test_configuration_data.conf \
659 test_program_data.conf \
660 test_resolver_api_data.conf \
661 test_service_data.conf \
662 test_speedup_data.conf \
663 child_management_test.sh \
664 test_crypto_vectors.sh \
665 crypto-test-vectors.json