aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am687
1 files changed, 0 insertions, 687 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
deleted file mode 100644
index 9cb7da15b..000000000
--- a/src/util/Makefile.am
+++ /dev/null
@@ -1,687 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6libexecdir= $(pkglibdir)/libexec/
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10dist_pkgcfg_DATA = \
11 util.conf
12
13pkgcfg_DATA = \
14 resolver.conf
15
16TEST_CLIENT_UNIX_NC = test_client_unix.nc
17
18if USE_COVERAGE
19 AM_CFLAGS = --coverage -O0
20 XLIB = -lgcov
21endif
22
23if ENABLE_BENCHMARK
24 BENCHMARK = benchmark.c benchmark.h
25 PTHREAD = -lpthread
26endif
27
28DLOG = crypto_ecc_dlog.c
29DLOG_TEST = test_crypto_ecc_dlog
30
31gnunet_config_diff_SOURCES = \
32 gnunet-config-diff.c
33gnunet_config_diff_LDADD = \
34 libgnunetutil.la
35
36test_common_logging_dummy_SOURCES = \
37 test_common_logging_dummy.c
38test_common_logging_dummy_LDADD = \
39 libgnunetutil.la
40
41libgnunetutil_la_SOURCES = \
42 bandwidth.c \
43 $(BENCHMARK) \
44 bio.c \
45 buffer.c \
46 child_management.c \
47 client.c \
48 common_allocation.c \
49 common_endian.c \
50 common_logging.c \
51 configuration.c \
52 configuration_helper.c \
53 consttime_memcmp.c \
54 container_bloomfilter.c \
55 container_heap.c \
56 container_meta_data.c \
57 container_multihashmap.c \
58 container_multishortmap.c \
59 container_multiuuidmap.c \
60 container_multipeermap.c \
61 container_multihashmap32.c \
62 crypto_symmetric.c \
63 crypto_crc.c \
64 crypto_cs.c \
65 crypto_ecc.c \
66 crypto_ecc_gnsrecord.c \
67 $(DLOG) \
68 crypto_ecc_setup.c \
69 crypto_edx25519.c \
70 crypto_hash.c \
71 crypto_hash_file.c \
72 crypto_hkdf.c \
73 crypto_kdf.c \
74 crypto_mpi.c \
75 crypto_paillier.c \
76 crypto_pow.c \
77 crypto_random.c \
78 crypto_rsa.c \
79 disk.c \
80 disk.h \
81 dnsparser.c \
82 dnsstub.c \
83 getopt.c \
84 getopt_helpers.c \
85 helper.c \
86 load.c \
87 mst.c \
88 mq.c \
89 nc.c \
90 network.c \
91 op.c \
92 os_installation.c \
93 os_network.c \
94 os_priority.c \
95 peer.c \
96 plugin.c \
97 program.c \
98 regex.c \
99 resolver_api.c resolver.h \
100 scheduler.c \
101 service.c \
102 signal.c \
103 strings.c \
104 time.c \
105 tun.c \
106 uri.c \
107 speedup.c speedup.h \
108 proc_compat.c
109
110if HAVE_LIBATOMIC
111if DARWIN
112 LIBATOMIC=
113else
114 LIBATOMIC= -latomic
115endif
116else
117 LIBATOMIC=
118endif
119
120if HAVE_LIBIDN
121 LIBIDN= -lidn
122else
123 LIBIDN=
124endif
125
126if HAVE_LIBIDN2
127 LIBIDN2= -lidn2
128else
129 LIBIDN2=
130endif
131
132libgnunetutil_la_LIBADD = \
133 $(GCLIBADD) $(WINLIB) \
134 $(LIBATOMIC) \
135 $(LIBGCRYPT_LIBS) \
136 $(LTLIBICONV) \
137 $(LTLIBINTL) \
138 -lltdl \
139 $(LIBIDN) $(LIBIDN2) \
140 $(Z_LIBS) \
141 -lunistring \
142 -lsodium \
143 $(XLIB) \
144 $(PTHREAD)
145
146libgnunetutil_la_LDFLAGS = \
147 $(GN_LIB_LDFLAGS) \
148 -version-info 15:0:0
149
150GNUNET_ECC = gnunet-ecc
151GNUNET_SCRYPT = gnunet-scrypt
152
153lib_LTLIBRARIES = libgnunetutil.la
154
155libexec_PROGRAMS = \
156 gnunet-service-resolver \
157 gnunet-timeout
158
159bin_PROGRAMS = \
160 gnunet-base32 \
161 gnunet-config \
162 gnunet-crypto-tvg \
163 gnunet-resolver \
164 $(GNUNET_ECC) \
165 $(GNUNET_SCRYPT) \
166 gnunet-uri
167if HAVE_ZBAR
168bin_PROGRAMS += gnunet-qr
169endif
170
171noinst_PROGRAMS = \
172 gnunet-config-diff \
173 test_common_logging_dummy
174
175
176if ENABLE_TEST_RUN
177AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
178TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
179endif
180
181gnunet_timeout_SOURCES = \
182 gnunet-timeout.c
183
184gnunet_service_resolver_SOURCES = \
185 gnunet-service-resolver.c
186gnunet_service_resolver_LDADD = \
187 libgnunetutil.la \
188 $(GN_LIBINTL)
189if HAVE_GETADDRINFO_A
190gnunet_service_resolver_LDADD += -lanl
191endif
192
193
194gnunet_resolver_SOURCES = \
195 gnunet-resolver.c
196gnunet_resolver_LDADD = \
197 libgnunetutil.la \
198 $(GN_LIBINTL)
199
200gnunet_crypto_tvg_SOURCES = \
201 gnunet-crypto-tvg.c
202gnunet_crypto_tvg_LDADD = \
203 libgnunetutil.la \
204 $(GN_LIBINTL) -lgcrypt -ljansson
205
206gnunet_ecc_SOURCES = \
207 gnunet-ecc.c
208gnunet_ecc_LDADD = \
209 libgnunetutil.la \
210 $(GN_LIBINTL) -lgcrypt
211
212gnunet_base32_SOURCES = \
213 gnunet-base32.c
214gnunet_base32_LDADD = \
215 libgnunetutil.la \
216 $(GN_LIBINTL)
217
218gnunet_scrypt_SOURCES = \
219 gnunet-scrypt.c
220gnunet_scrypt_LDADD = \
221 libgnunetutil.la \
222 $(GN_LIBINTL) -lgcrypt
223
224
225gnunet_config_SOURCES = \
226 gnunet-config.c
227gnunet_config_LDADD = \
228 libgnunetutil.la \
229 $(GN_LIBINTL)
230
231gnunet_uri_SOURCES = \
232 gnunet-uri.c
233gnunet_uri_LDADD = \
234 libgnunetutil.la \
235 $(GN_LIBINTL)
236
237
238gnunet_qr_SOURCES = \
239 gnunet-qr.c
240gnunet_qr_LDADD = \
241 libgnunetutil.la \
242 $(GN_LIBINTL)
243gnunet_qr_LDFLAGS= -lzbar
244if HAVE_PNG
245gnunet_qr_LDFLAGS += -lpng
246endif
247
248plugin_LTLIBRARIES = \
249 libgnunet_plugin_utiltest.la
250
251libgnunet_plugin_utiltest_la_SOURCES = \
252 test_plugin_plug.c
253libgnunet_plugin_utiltest_la_LDFLAGS = \
254 $(GN_PLUGIN_LDFLAGS)
255
256if HAVE_BENCHMARKS
257 BENCHMARKS = \
258 perf_crypto_cs \
259 perf_crypto_hash \
260 perf_crypto_rsa \
261 perf_crypto_paillier \
262 perf_crypto_symmetric \
263 perf_crypto_asymmetric \
264 perf_malloc \
265 perf_mq \
266 perf_scheduler \
267 perf_crypto_ecc_dlog
268endif
269
270if HAVE_SSH_KEY
271# SSH_USING_TESTS = test_socks.nc
272endif
273
274check_SCRIPTS = \
275 test_crypto_vectors.sh
276
277check_PROGRAMS = \
278 test_bio \
279 test_child_management \
280 test_client.nc \
281 $(TEST_CLIENT_UNIX_NC) \
282 test_common_allocation \
283 test_common_endian \
284 test_common_logging \
285 test_configuration \
286 test_container_bloomfilter \
287 test_container_dll \
288 test_container_meta_data \
289 test_container_multihashmap \
290 test_container_multihashmap32 \
291 test_container_multipeermap \
292 test_container_heap \
293 test_crypto_symmetric \
294 test_crypto_crc \
295 test_crypto_cs \
296 test_crypto_ecdsa \
297 test_crypto_eddsa \
298 test_crypto_ecdhe \
299 test_crypto_ecdh_eddsa \
300 test_crypto_ecdh_ecdsa \
301 test_crypto_edx25519 \
302 $(DLOG_TEST) \
303 test_crypto_hash \
304 test_crypto_hash_context \
305 test_crypto_hkdf \
306 test_crypto_kdf \
307 test_crypto_paillier \
308 test_crypto_random \
309 test_crypto_rsa \
310 test_disk \
311 test_getopt \
312 test_hexcoder \
313 test_mq \
314 test_os_network \
315 test_peer \
316 test_plugin \
317 test_program \
318 test_regex \
319 test_resolver_api.nc \
320 test_scheduler \
321 test_scheduler_delay \
322 test_service \
323 test_strings \
324 test_strings_to_data \
325 test_speedup \
326 test_time \
327 test_tun \
328 test_uri \
329 $(BENCHMARKS) \
330 test_os_start_process \
331 test_common_logging_runtime_loglevels
332
333
334test_child_management_SOURCES = \
335 test_child_management.c
336test_child_management_LDADD = \
337 libgnunetutil.la \
338 $(XLIB)
339
340
341
342# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart
343# sequential execution order for them
344TEST_EXTENSIONS = .nc
345test_test_client_unix.log: test_client.log
346
347test_bio_SOURCES = \
348 test_bio.c
349test_bio_LDADD = \
350 libgnunetutil.la
351
352test_hexcoder_SOURCES = \
353 test_hexcoder.c
354test_hexcoder_LDADD = \
355 libgnunetutil.la
356
357test_tun_SOURCES = \
358 test_tun.c
359test_tun_LDADD = \
360 libgnunetutil.la
361
362test_regex_SOURCES = \
363 test_regex.c
364test_regex_LDADD = \
365 libgnunetutil.la
366
367test_os_start_process_SOURCES = \
368 test_os_start_process.c
369test_os_start_process_LDADD = \
370 libgnunetutil.la
371
372test_client_nc_SOURCES = \
373 test_client.c
374test_client_nc_LDADD = \
375 libgnunetutil.la
376
377test_client_unix_nc_SOURCES = \
378 test_client.c
379test_client_unix_nc_LDADD = \
380 libgnunetutil.la
381
382#test_socks_nc_SOURCES = \
383# test_socks.c
384#test_socks_nc_LDADD = \
385# libgnunetutil.la
386
387test_common_allocation_SOURCES = \
388 test_common_allocation.c
389test_common_allocation_LDADD = \
390 libgnunetutil.la
391
392test_common_endian_SOURCES = \
393 test_common_endian.c
394test_common_endian_LDADD = \
395 libgnunetutil.la
396
397test_common_logging_SOURCES = \
398 test_common_logging.c
399test_common_logging_LDADD = \
400 libgnunetutil.la
401
402test_common_logging_runtime_loglevels_SOURCES = \
403 test_common_logging_runtime_loglevels.c
404test_common_logging_runtime_loglevels_LDADD = \
405 libgnunetutil.la
406
407test_configuration_SOURCES = \
408 test_configuration.c
409test_configuration_LDADD = \
410 libgnunetutil.la
411
412test_container_bloomfilter_SOURCES = \
413 test_container_bloomfilter.c
414test_container_bloomfilter_LDADD = \
415 libgnunetutil.la
416
417test_container_dll_SOURCES = \
418 test_container_dll.c
419test_container_dll_LDADD = \
420 libgnunetutil.la
421
422test_container_meta_data_SOURCES = \
423 test_container_meta_data.c
424test_container_meta_data_LDADD = \
425 libgnunetutil.la
426
427test_container_multihashmap_SOURCES = \
428 test_container_multihashmap.c
429test_container_multihashmap_LDADD = \
430 libgnunetutil.la
431
432test_container_multihashmap32_SOURCES = \
433 test_container_multihashmap32.c
434test_container_multihashmap32_LDADD = \
435 libgnunetutil.la
436
437test_container_multipeermap_SOURCES = \
438 test_container_multipeermap.c
439test_container_multipeermap_LDADD = \
440 libgnunetutil.la
441
442test_container_heap_SOURCES = \
443 test_container_heap.c
444test_container_heap_LDADD = \
445 libgnunetutil.la
446
447test_crypto_symmetric_SOURCES = \
448 test_crypto_symmetric.c
449test_crypto_symmetric_LDADD = \
450 libgnunetutil.la
451
452test_crypto_crc_SOURCES = \
453 test_crypto_crc.c
454test_crypto_crc_LDADD = \
455 libgnunetutil.la
456
457test_crypto_cs_SOURCES = \
458 test_crypto_cs.c
459test_crypto_cs_LDADD = \
460 libgnunetutil.la \
461 -lsodium
462
463test_crypto_ecdsa_SOURCES = \
464 test_crypto_ecdsa.c
465test_crypto_ecdsa_LDADD = \
466 libgnunetutil.la \
467 $(LIBGCRYPT_LIBS)
468
469test_crypto_eddsa_SOURCES = \
470 test_crypto_eddsa.c
471test_crypto_eddsa_LDADD = \
472 libgnunetutil.la \
473 $(LIBGCRYPT_LIBS)
474
475test_crypto_edx25519_SOURCES = \
476 test_crypto_edx25519.c
477test_crypto_edx25519_LDADD = \
478 libgnunetutil.la \
479 $(LIBGCRYPT_LIBS)
480
481test_crypto_ecc_dlog_SOURCES = \
482 test_crypto_ecc_dlog.c
483test_crypto_ecc_dlog_LDADD = \
484 -lsodium \
485 libgnunetutil.la \
486 $(LIBGCRYPT_LIBS)
487
488test_crypto_ecdhe_SOURCES = \
489 test_crypto_ecdhe.c
490test_crypto_ecdhe_LDADD = \
491 libgnunetutil.la \
492 $(LIBGCRYPT_LIBS)
493
494test_crypto_ecdh_eddsa_SOURCES = \
495 test_crypto_ecdh_eddsa.c
496test_crypto_ecdh_eddsa_LDADD = \
497 libgnunetutil.la \
498 $(LIBGCRYPT_LIBS)
499
500test_crypto_ecdh_ecdsa_SOURCES = \
501 test_crypto_ecdh_ecdsa.c
502test_crypto_ecdh_ecdsa_LDADD = \
503 libgnunetutil.la \
504 $(LIBGCRYPT_LIBS)
505
506
507test_crypto_hash_SOURCES = \
508 test_crypto_hash.c
509test_crypto_hash_LDADD = \
510 libgnunetutil.la
511
512test_crypto_hash_context_SOURCES = \
513 test_crypto_hash_context.c
514test_crypto_hash_context_LDADD = \
515 libgnunetutil.la
516
517test_crypto_hkdf_SOURCES = \
518 test_crypto_hkdf.c
519test_crypto_hkdf_LDADD = \
520 libgnunetutil.la
521
522test_crypto_kdf_SOURCES = \
523 test_crypto_kdf.c
524test_crypto_kdf_LDADD = \
525 libgnunetutil.la -lgcrypt
526
527test_crypto_paillier_SOURCES = \
528 test_crypto_paillier.c
529test_crypto_paillier_LDADD = \
530 $(LIBGCRYPT_LIBS) \
531 libgnunetutil.la
532
533test_crypto_random_SOURCES = \
534 test_crypto_random.c
535test_crypto_random_LDADD = \
536 libgnunetutil.la
537
538test_crypto_rsa_SOURCES = \
539 test_crypto_rsa.c
540test_crypto_rsa_LDADD = \
541 libgnunetutil.la -lgcrypt
542
543test_disk_SOURCES = \
544 test_disk.c
545test_disk_LDADD = \
546 libgnunetutil.la
547
548test_getopt_SOURCES = \
549 test_getopt.c
550test_getopt_LDADD = \
551 libgnunetutil.la
552
553test_mq_SOURCES = \
554 test_mq.c
555test_mq_LDADD = \
556 libgnunetutil.la
557
558test_os_network_SOURCES = \
559 test_os_network.c
560test_os_network_LDADD = \
561 libgnunetutil.la
562
563test_peer_SOURCES = \
564 test_peer.c
565test_peer_LDADD = \
566 libgnunetutil.la -lgcrypt
567
568test_plugin_SOURCES = \
569 test_plugin.c
570test_plugin_LDADD = \
571 libgnunetutil.la
572
573test_program_SOURCES = \
574 test_program.c
575test_program_LDADD = \
576 libgnunetutil.la
577
578test_resolver_api_nc_SOURCES = \
579 test_resolver_api.c
580test_resolver_api_nc_LDADD = \
581 libgnunetutil.la
582
583test_scheduler_SOURCES = \
584 test_scheduler.c
585test_scheduler_LDADD = \
586 libgnunetutil.la
587
588test_scheduler_delay_SOURCES = \
589 test_scheduler_delay.c
590test_scheduler_delay_LDADD = \
591 libgnunetutil.la
592
593test_service_SOURCES = \
594 test_service.c
595test_service_LDADD = \
596 libgnunetutil.la
597
598test_strings_SOURCES = \
599 test_strings.c
600test_strings_LDADD = \
601 libgnunetutil.la
602
603test_strings_to_data_SOURCES = \
604 test_strings_to_data.c
605test_strings_to_data_LDADD = \
606 libgnunetutil.la
607
608
609test_time_SOURCES = \
610 test_time.c
611test_time_LDADD = \
612 libgnunetutil.la
613
614test_speedup_SOURCES = \
615 test_speedup.c
616test_speedup_LDADD = \
617 libgnunetutil.la
618
619test_uri_SOURCES = \
620 test_uri.c
621test_uri_LDADD = \
622 libgnunetutil.la
623
624perf_crypto_cs_SOURCES = \
625 perf_crypto_cs.c
626perf_crypto_cs_LDADD = \
627 libgnunetutil.la
628
629perf_crypto_hash_SOURCES = \
630 perf_crypto_hash.c
631perf_crypto_hash_LDADD = \
632 libgnunetutil.la
633
634perf_crypto_ecc_dlog_SOURCES = \
635 perf_crypto_ecc_dlog.c
636perf_crypto_ecc_dlog_LDADD = \
637 libgnunetutil.la \
638 -lsodium
639
640perf_crypto_rsa_SOURCES = \
641 perf_crypto_rsa.c
642perf_crypto_rsa_LDADD = \
643 libgnunetutil.la
644
645perf_crypto_symmetric_SOURCES = \
646 perf_crypto_symmetric.c
647perf_crypto_symmetric_LDADD = \
648 libgnunetutil.la
649
650perf_crypto_asymmetric_SOURCES = \
651 perf_crypto_asymmetric.c
652perf_crypto_asymmetric_LDADD = \
653 libgnunetutil.la
654
655perf_crypto_paillier_SOURCES = \
656 perf_crypto_paillier.c
657perf_crypto_paillier_LDADD = \
658 libgnunetutil.la \
659 -lgcrypt
660
661perf_malloc_SOURCES = \
662 perf_malloc.c
663perf_malloc_LDADD = \
664 libgnunetutil.la
665
666perf_mq_SOURCES = \
667 perf_mq.c
668perf_mq_LDADD = \
669 libgnunetutil.la
670
671perf_scheduler_SOURCES = \
672 perf_scheduler.c
673perf_scheduler_LDADD = \
674 libgnunetutil.la
675
676
677EXTRA_DIST = \
678 test_client_data.conf \
679 test_client_unix.conf \
680 test_configuration_data.conf \
681 test_program_data.conf \
682 test_resolver_api_data.conf \
683 test_service_data.conf \
684 test_speedup_data.conf \
685 child_management_test.sh \
686 test_crypto_vectors.sh \
687 crypto-test-vectors.json