aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am664
1 files changed, 0 insertions, 664 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
deleted file mode 100644
index a3a77073e..000000000
--- a/src/util/Makefile.am
+++ /dev/null
@@ -1,664 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6libexecdir= $(pkglibdir)/libexec/
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10dist_pkgcfg_DATA = \
11 util.conf
12
13pkgcfg_DATA = \
14 resolver.conf
15
16TEST_CLIENT_UNIX_NC = test_client_unix.nc
17
18if USE_COVERAGE
19 AM_CFLAGS = --coverage -O0
20 XLIB = -lgcov
21endif
22
23if ENABLE_BENCHMARK
24 BENCHMARK = benchmark.c benchmark.h
25 PTHREAD = -lpthread
26endif
27
28DLOG = crypto_ecc_dlog.c
29DLOG_TEST = test_crypto_ecc_dlog
30
31gnunet_config_diff_SOURCES = \
32 gnunet-config-diff.c
33gnunet_config_diff_LDADD = \
34 libgnunetutil.la
35
36test_common_logging_dummy_SOURCES = \
37 test_common_logging_dummy.c
38test_common_logging_dummy_LDADD = \
39 libgnunetutil.la
40
41libgnunetutil_la_SOURCES = \
42 bandwidth.c \
43 $(BENCHMARK) \
44 bio.c \
45 buffer.c \
46 child_management.c \
47 client.c \
48 common_allocation.c \
49 common_endian.c \
50 common_logging.c \
51 configuration.c \
52 configuration_helper.c \
53 consttime_memcmp.c \
54 container_bloomfilter.c \
55 container_heap.c \
56 container_meta_data.c \
57 container_multihashmap.c \
58 container_multishortmap.c \
59 container_multiuuidmap.c \
60 container_multipeermap.c \
61 container_multihashmap32.c \
62 crypto_symmetric.c \
63 crypto_crc.c \
64 crypto_ecc.c \
65 crypto_ecc_gnsrecord.c \
66 $(DLOG) \
67 crypto_ecc_setup.c \
68 crypto_hash.c \
69 crypto_hash_file.c \
70 crypto_hkdf.c \
71 crypto_kdf.c \
72 crypto_mpi.c \
73 crypto_paillier.c \
74 crypto_pow.c \
75 crypto_random.c \
76 crypto_rsa.c \
77 disk.c \
78 disk.h \
79 dnsparser.c \
80 dnsstub.c \
81 getopt.c \
82 getopt_helpers.c \
83 helper.c \
84 load.c \
85 mst.c \
86 mq.c \
87 nc.c \
88 network.c \
89 op.c \
90 os_installation.c \
91 os_network.c \
92 os_priority.c \
93 peer.c \
94 plugin.c \
95 program.c \
96 regex.c \
97 resolver_api.c resolver.h \
98 scheduler.c \
99 service.c \
100 signal.c \
101 strings.c \
102 time.c \
103 tun.c \
104 uri.c \
105 speedup.c speedup.h \
106 proc_compat.c
107
108if HAVE_LIBATOMIC
109if DARWIN
110 LIBATOMIC=
111else
112 LIBATOMIC= -latomic
113endif
114else
115 LIBATOMIC=
116endif
117
118if HAVE_LIBIDN
119 LIBIDN= -lidn
120else
121 LIBIDN=
122endif
123
124if HAVE_LIBIDN2
125 LIBIDN2= -lidn2
126else
127 LIBIDN2=
128endif
129
130libgnunetutil_la_LIBADD = \
131 $(GCLIBADD) $(WINLIB) \
132 $(LIBATOMIC) \
133 $(LIBGCRYPT_LIBS) \
134 $(LTLIBICONV) \
135 $(LTLIBINTL) \
136 -lltdl \
137 $(LIBIDN) $(LIBIDN2) \
138 $(Z_LIBS) \
139 -lunistring \
140 -lsodium \
141 $(XLIB) \
142 $(PTHREAD)
143
144libgnunetutil_la_LDFLAGS = \
145 $(GN_LIB_LDFLAGS) \
146 -version-info 14:0:0
147
148if HAVE_TESTING
149 GNUNET_ECC = gnunet-ecc
150 GNUNET_SCRYPT = gnunet-scrypt
151endif
152
153lib_LTLIBRARIES = libgnunetutil.la
154
155libexec_PROGRAMS = \
156 gnunet-service-resolver \
157 gnunet-timeout
158
159bin_PROGRAMS = \
160 gnunet-base32 \
161 gnunet-config \
162 gnunet-crypto-tvg \
163 gnunet-resolver \
164 $(GNUNET_ECC) \
165 $(GNUNET_SCRYPT) \
166 gnunet-uri
167if HAVE_ZBAR
168bin_PROGRAMS += gnunet-qr
169endif
170
171noinst_PROGRAMS = \
172 gnunet-config-diff \
173 test_common_logging_dummy
174
175
176if ENABLE_TEST_RUN
177AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
178TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
179endif
180
181gnunet_timeout_SOURCES = \
182 gnunet-timeout.c
183
184gnunet_service_resolver_SOURCES = \
185 gnunet-service-resolver.c
186gnunet_service_resolver_LDADD = \
187 libgnunetutil.la \
188 $(GN_LIBINTL)
189if HAVE_GETADDRINFO_A
190gnunet_service_resolver_LDADD += -lanl
191endif
192
193
194gnunet_resolver_SOURCES = \
195 gnunet-resolver.c
196gnunet_resolver_LDADD = \
197 libgnunetutil.la \
198 $(GN_LIBINTL)
199
200gnunet_crypto_tvg_SOURCES = \
201 gnunet-crypto-tvg.c
202gnunet_crypto_tvg_LDADD = \
203 libgnunetutil.la \
204 $(GN_LIBINTL) -lgcrypt -ljansson
205
206gnunet_ecc_SOURCES = \
207 gnunet-ecc.c
208gnunet_ecc_LDADD = \
209 libgnunetutil.la \
210 $(GN_LIBINTL) -lgcrypt
211
212gnunet_base32_SOURCES = \
213 gnunet-base32.c
214gnunet_base32_LDADD = \
215 libgnunetutil.la \
216 $(GN_LIBINTL)
217
218gnunet_scrypt_SOURCES = \
219 gnunet-scrypt.c
220gnunet_scrypt_LDADD = \
221 libgnunetutil.la \
222 $(GN_LIBINTL) -lgcrypt
223
224
225gnunet_config_SOURCES = \
226 gnunet-config.c
227gnunet_config_LDADD = \
228 libgnunetutil.la \
229 $(GN_LIBINTL)
230
231gnunet_uri_SOURCES = \
232 gnunet-uri.c
233gnunet_uri_LDADD = \
234 libgnunetutil.la \
235 $(GN_LIBINTL)
236
237
238gnunet_qr_SOURCES = \
239 gnunet-qr.c
240gnunet_qr_LDADD = \
241 libgnunetutil.la \
242 $(GN_LIBINTL)
243gnunet_qr_LDFLAGS= -lzbar
244
245plugin_LTLIBRARIES = \
246 libgnunet_plugin_utiltest.la
247
248libgnunet_plugin_utiltest_la_SOURCES = \
249 test_plugin_plug.c
250libgnunet_plugin_utiltest_la_LDFLAGS = \
251 $(GN_PLUGIN_LDFLAGS)
252
253if HAVE_BENCHMARKS
254 BENCHMARKS = \
255 perf_crypto_hash \
256 perf_crypto_rsa \
257 perf_crypto_paillier \
258 perf_crypto_symmetric \
259 perf_crypto_asymmetric \
260 perf_malloc \
261 perf_mq \
262 perf_scheduler \
263 perf_crypto_ecc_dlog
264endif
265
266if HAVE_SSH_KEY
267# SSH_USING_TESTS = test_socks.nc
268endif
269
270check_SCRIPTS = \
271 test_crypto_vectors.sh
272
273check_PROGRAMS = \
274 test_bio \
275 test_child_management \
276 test_client.nc \
277 $(TEST_CLIENT_UNIX_NC) \
278 test_common_allocation \
279 test_common_endian \
280 test_common_logging \
281 test_configuration \
282 test_container_bloomfilter \
283 test_container_dll \
284 test_container_meta_data \
285 test_container_multihashmap \
286 test_container_multihashmap32 \
287 test_container_multipeermap \
288 test_container_heap \
289 test_crypto_symmetric \
290 test_crypto_crc \
291 test_crypto_ecdsa \
292 test_crypto_eddsa \
293 test_crypto_ecdhe \
294 test_crypto_ecdh_eddsa \
295 test_crypto_ecdh_ecdsa \
296 $(DLOG_TEST) \
297 test_crypto_hash \
298 test_crypto_hash_context \
299 test_crypto_hkdf \
300 test_crypto_kdf \
301 test_crypto_paillier \
302 test_crypto_random \
303 test_crypto_rsa \
304 test_disk \
305 test_getopt \
306 test_hexcoder \
307 test_mq \
308 test_os_network \
309 test_peer \
310 test_plugin \
311 test_program \
312 test_regex \
313 test_resolver_api.nc \
314 test_scheduler \
315 test_scheduler_delay \
316 test_service \
317 test_strings \
318 test_strings_to_data \
319 test_speedup \
320 test_time \
321 test_tun \
322 test_uri \
323 $(BENCHMARKS) \
324 test_os_start_process \
325 test_common_logging_runtime_loglevels
326
327
328test_child_management_SOURCES = \
329 test_child_management.c
330test_child_management_LDADD = \
331 libgnunetutil.la \
332 $(XLIB)
333
334
335
336# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart
337# sequential execution order for them
338TEST_EXTENSIONS = .nc
339test_test_client_unix.log: test_client.log
340
341test_bio_SOURCES = \
342 test_bio.c
343test_bio_LDADD = \
344 libgnunetutil.la
345
346test_hexcoder_SOURCES = \
347 test_hexcoder.c
348test_hexcoder_LDADD = \
349 libgnunetutil.la
350
351test_tun_SOURCES = \
352 test_tun.c
353test_tun_LDADD = \
354 libgnunetutil.la
355
356test_regex_SOURCES = \
357 test_regex.c
358test_regex_LDADD = \
359 libgnunetutil.la
360
361test_os_start_process_SOURCES = \
362 test_os_start_process.c
363test_os_start_process_LDADD = \
364 libgnunetutil.la
365
366test_client_nc_SOURCES = \
367 test_client.c
368test_client_nc_LDADD = \
369 libgnunetutil.la
370
371test_client_unix_nc_SOURCES = \
372 test_client.c
373test_client_unix_nc_LDADD = \
374 libgnunetutil.la
375
376#test_socks_nc_SOURCES = \
377# test_socks.c
378#test_socks_nc_LDADD = \
379# libgnunetutil.la
380
381test_common_allocation_SOURCES = \
382 test_common_allocation.c
383test_common_allocation_LDADD = \
384 libgnunetutil.la
385
386test_common_endian_SOURCES = \
387 test_common_endian.c
388test_common_endian_LDADD = \
389 libgnunetutil.la
390
391test_common_logging_SOURCES = \
392 test_common_logging.c
393test_common_logging_LDADD = \
394 libgnunetutil.la
395
396test_common_logging_runtime_loglevels_SOURCES = \
397 test_common_logging_runtime_loglevels.c
398test_common_logging_runtime_loglevels_LDADD = \
399 libgnunetutil.la
400
401test_configuration_SOURCES = \
402 test_configuration.c
403test_configuration_LDADD = \
404 libgnunetutil.la
405
406test_container_bloomfilter_SOURCES = \
407 test_container_bloomfilter.c
408test_container_bloomfilter_LDADD = \
409 libgnunetutil.la
410
411test_container_dll_SOURCES = \
412 test_container_dll.c
413test_container_dll_LDADD = \
414 libgnunetutil.la
415
416test_container_meta_data_SOURCES = \
417 test_container_meta_data.c
418test_container_meta_data_LDADD = \
419 libgnunetutil.la
420
421test_container_multihashmap_SOURCES = \
422 test_container_multihashmap.c
423test_container_multihashmap_LDADD = \
424 libgnunetutil.la
425
426test_container_multihashmap32_SOURCES = \
427 test_container_multihashmap32.c
428test_container_multihashmap32_LDADD = \
429 libgnunetutil.la
430
431test_container_multipeermap_SOURCES = \
432 test_container_multipeermap.c
433test_container_multipeermap_LDADD = \
434 libgnunetutil.la
435
436test_container_heap_SOURCES = \
437 test_container_heap.c
438test_container_heap_LDADD = \
439 libgnunetutil.la
440
441test_crypto_symmetric_SOURCES = \
442 test_crypto_symmetric.c
443test_crypto_symmetric_LDADD = \
444 libgnunetutil.la
445
446test_crypto_crc_SOURCES = \
447 test_crypto_crc.c
448test_crypto_crc_LDADD = \
449 libgnunetutil.la
450
451test_crypto_ecdsa_SOURCES = \
452 test_crypto_ecdsa.c
453test_crypto_ecdsa_LDADD = \
454 libgnunetutil.la \
455 $(LIBGCRYPT_LIBS)
456
457test_crypto_eddsa_SOURCES = \
458 test_crypto_eddsa.c
459test_crypto_eddsa_LDADD = \
460 libgnunetutil.la \
461 $(LIBGCRYPT_LIBS)
462
463test_crypto_ecc_dlog_SOURCES = \
464 test_crypto_ecc_dlog.c
465test_crypto_ecc_dlog_LDADD = \
466 -lsodium \
467 libgnunetutil.la \
468 $(LIBGCRYPT_LIBS)
469
470test_crypto_ecdhe_SOURCES = \
471 test_crypto_ecdhe.c
472test_crypto_ecdhe_LDADD = \
473 libgnunetutil.la \
474 $(LIBGCRYPT_LIBS)
475
476test_crypto_ecdh_eddsa_SOURCES = \
477 test_crypto_ecdh_eddsa.c
478test_crypto_ecdh_eddsa_LDADD = \
479 libgnunetutil.la \
480 $(LIBGCRYPT_LIBS)
481
482test_crypto_ecdh_ecdsa_SOURCES = \
483 test_crypto_ecdh_ecdsa.c
484test_crypto_ecdh_ecdsa_LDADD = \
485 libgnunetutil.la \
486 $(LIBGCRYPT_LIBS)
487
488
489test_crypto_hash_SOURCES = \
490 test_crypto_hash.c
491test_crypto_hash_LDADD = \
492 libgnunetutil.la
493
494test_crypto_hash_context_SOURCES = \
495 test_crypto_hash_context.c
496test_crypto_hash_context_LDADD = \
497 libgnunetutil.la
498
499test_crypto_hkdf_SOURCES = \
500 test_crypto_hkdf.c
501test_crypto_hkdf_LDADD = \
502 libgnunetutil.la
503
504test_crypto_kdf_SOURCES = \
505 test_crypto_kdf.c
506test_crypto_kdf_LDADD = \
507 libgnunetutil.la -lgcrypt
508
509test_crypto_paillier_SOURCES = \
510 test_crypto_paillier.c
511test_crypto_paillier_LDADD = \
512 $(LIBGCRYPT_LIBS) \
513 libgnunetutil.la
514
515test_crypto_random_SOURCES = \
516 test_crypto_random.c
517test_crypto_random_LDADD = \
518 libgnunetutil.la
519
520test_crypto_rsa_SOURCES = \
521 test_crypto_rsa.c
522test_crypto_rsa_LDADD = \
523 libgnunetutil.la -lgcrypt
524
525test_disk_SOURCES = \
526 test_disk.c
527test_disk_LDADD = \
528 libgnunetutil.la
529
530test_getopt_SOURCES = \
531 test_getopt.c
532test_getopt_LDADD = \
533 libgnunetutil.la
534
535test_mq_SOURCES = \
536 test_mq.c
537test_mq_LDADD = \
538 libgnunetutil.la
539
540test_os_network_SOURCES = \
541 test_os_network.c
542test_os_network_LDADD = \
543 libgnunetutil.la
544
545test_peer_SOURCES = \
546 test_peer.c
547test_peer_LDADD = \
548 libgnunetutil.la -lgcrypt
549
550test_plugin_SOURCES = \
551 test_plugin.c
552test_plugin_LDADD = \
553 libgnunetutil.la
554
555test_program_SOURCES = \
556 test_program.c
557test_program_LDADD = \
558 libgnunetutil.la
559
560test_resolver_api_nc_SOURCES = \
561 test_resolver_api.c
562test_resolver_api_nc_LDADD = \
563 libgnunetutil.la
564
565test_scheduler_SOURCES = \
566 test_scheduler.c
567test_scheduler_LDADD = \
568 libgnunetutil.la
569
570test_scheduler_delay_SOURCES = \
571 test_scheduler_delay.c
572test_scheduler_delay_LDADD = \
573 libgnunetutil.la
574
575test_service_SOURCES = \
576 test_service.c
577test_service_LDADD = \
578 libgnunetutil.la
579
580test_strings_SOURCES = \
581 test_strings.c
582test_strings_LDADD = \
583 libgnunetutil.la
584
585test_strings_to_data_SOURCES = \
586 test_strings_to_data.c
587test_strings_to_data_LDADD = \
588 libgnunetutil.la
589
590
591test_time_SOURCES = \
592 test_time.c
593test_time_LDADD = \
594 libgnunetutil.la
595
596test_speedup_SOURCES = \
597 test_speedup.c
598test_speedup_LDADD = \
599 libgnunetutil.la
600
601test_uri_SOURCES = \
602 test_uri.c
603test_uri_LDADD = \
604 libgnunetutil.la
605
606perf_crypto_hash_SOURCES = \
607 perf_crypto_hash.c
608perf_crypto_hash_LDADD = \
609 libgnunetutil.la
610
611perf_crypto_ecc_dlog_SOURCES = \
612 perf_crypto_ecc_dlog.c
613perf_crypto_ecc_dlog_LDADD = \
614 libgnunetutil.la \
615 -lsodium
616
617perf_crypto_rsa_SOURCES = \
618 perf_crypto_rsa.c
619perf_crypto_rsa_LDADD = \
620 libgnunetutil.la
621
622perf_crypto_symmetric_SOURCES = \
623 perf_crypto_symmetric.c
624perf_crypto_symmetric_LDADD = \
625 libgnunetutil.la
626
627perf_crypto_asymmetric_SOURCES = \
628 perf_crypto_asymmetric.c
629perf_crypto_asymmetric_LDADD = \
630 libgnunetutil.la
631
632perf_crypto_paillier_SOURCES = \
633 perf_crypto_paillier.c
634perf_crypto_paillier_LDADD = \
635 libgnunetutil.la \
636 -lgcrypt
637
638perf_malloc_SOURCES = \
639 perf_malloc.c
640perf_malloc_LDADD = \
641 libgnunetutil.la
642
643perf_mq_SOURCES = \
644 perf_mq.c
645perf_mq_LDADD = \
646 libgnunetutil.la
647
648perf_scheduler_SOURCES = \
649 perf_scheduler.c
650perf_scheduler_LDADD = \
651 libgnunetutil.la
652
653
654EXTRA_DIST = \
655 test_client_data.conf \
656 test_client_unix.conf \
657 test_configuration_data.conf \
658 test_program_data.conf \
659 test_resolver_api_data.conf \
660 test_service_data.conf \
661 test_speedup_data.conf \
662 child_management_test.sh \
663 test_crypto_vectors.sh \
664 crypto-test-vectors.json