aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am65
1 files changed, 53 insertions, 12 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 685632b49..a2482fc87 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -46,12 +46,6 @@ gnunet_helper_w32_console_SOURCES = \
46gnunet_helper_w32_console_LDADD = \ 46gnunet_helper_w32_console_LDADD = \
47 libgnunetutil.la 47 libgnunetutil.la
48 48
49noinst_PROGRAMS = \
50 gnunet-config-diff \
51 $(W32CAT) \
52 test_common_logging_dummy
53
54
55gnunet_config_diff_SOURCES = \ 49gnunet_config_diff_SOURCES = \
56 gnunet-config-diff.c 50 gnunet-config-diff.c
57gnunet_config_diff_LDADD = \ 51gnunet_config_diff_LDADD = \
@@ -62,8 +56,6 @@ test_common_logging_dummy_SOURCES = \
62test_common_logging_dummy_LDADD = \ 56test_common_logging_dummy_LDADD = \
63 libgnunetutil.la 57 libgnunetutil.la
64 58
65lib_LTLIBRARIES = libgnunetutil.la
66
67libgnunetutil_la_SOURCES = \ 59libgnunetutil_la_SOURCES = \
68 bandwidth.c \ 60 bandwidth.c \
69 bio.c \ 61 bio.c \
@@ -73,6 +65,7 @@ libgnunetutil_la_SOURCES = \
73 common_endian.c \ 65 common_endian.c \
74 common_logging.c \ 66 common_logging.c \
75 configuration.c \ 67 configuration.c \
68 configuration_loader.c \
76 connection.c \ 69 connection.c \
77 container_bloomfilter.c \ 70 container_bloomfilter.c \
78 container_heap.c \ 71 container_heap.c \
@@ -83,7 +76,9 @@ libgnunetutil_la_SOURCES = \
83 crypto_symmetric.c \ 76 crypto_symmetric.c \
84 crypto_crc.c \ 77 crypto_crc.c \
85 crypto_ecc.c \ 78 crypto_ecc.c \
79 crypto_ecc_setup.c \
86 crypto_hash.c \ 80 crypto_hash.c \
81 crypto_hash_file.c \
87 crypto_hkdf.c \ 82 crypto_hkdf.c \
88 crypto_kdf.c \ 83 crypto_kdf.c \
89 crypto_mpi.c \ 84 crypto_mpi.c \
@@ -91,6 +86,7 @@ libgnunetutil_la_SOURCES = \
91 crypto_random.c \ 86 crypto_random.c \
92 crypto_rsa.c \ 87 crypto_rsa.c \
93 disk.c \ 88 disk.c \
89 disk_iterator.c \
94 disk.h \ 90 disk.h \
95 getopt.c \ 91 getopt.c \
96 getopt_helpers.c \ 92 getopt_helpers.c \
@@ -127,11 +123,46 @@ libgnunetutil_la_LDFLAGS = \
127 $(GN_LIB_LDFLAGS) \ 123 $(GN_LIB_LDFLAGS) \
128 -version-info 13:0:0 124 -version-info 13:0:0
129 125
126
127libgnunetutil_taler_wallet_la_SOURCES = \
128 common_allocation.c \
129 common_endian.c \
130 common_logging.c \
131 configuration.c \
132 container_heap.c \
133 container_multihashmap.c \
134 container_multihashmap32.c \
135 crypto_symmetric.c \
136 crypto_crc.c \
137 crypto_ecc.c \
138 crypto_hash.c \
139 crypto_hkdf.c \
140 crypto_kdf.c \
141 crypto_mpi.c \
142 crypto_random.c \
143 crypto_rsa.c \
144 disk.c \
145 disk.h \
146 strings.c \
147 time.c
148
149libgnunetutil_taler_wallet_la_LIBADD = \
150 $(LIBGCRYPT_LIBS) \
151 -lunistring
152
153libgnunetutil_taler_wallet_la_LDFLAGS = \
154 $(GN_LIB_LDFLAGS) \
155 -version-info 0:0:0
156
130if HAVE_TESTING 157if HAVE_TESTING
131 GNUNET_ECC = gnunet-ecc 158 GNUNET_ECC = gnunet-ecc
132 GNUNET_SCRYPT = gnunet-scrypt 159 GNUNET_SCRYPT = gnunet-scrypt
133endif 160endif
134 161
162if TALER_ONLY
163lib_LTLIBRARIES = libgnunetutil_taler_wallet.la
164else
165lib_LTLIBRARIES = libgnunetutil.la
135 166
136libexec_PROGRAMS = \ 167libexec_PROGRAMS = \
137 gnunet-service-resolver \ 168 gnunet-service-resolver \
@@ -147,6 +178,20 @@ bin_PROGRAMS = \
147 $(GNUNET_SCRYPT) \ 178 $(GNUNET_SCRYPT) \
148 gnunet-uri 179 gnunet-uri
149 180
181noinst_PROGRAMS = \
182 gnunet-config-diff \
183 $(W32CAT) \
184 test_common_logging_dummy
185
186
187if ENABLE_TEST_RUN
188AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
189TESTS = $(check_PROGRAMS)
190endif
191
192endif
193
194
150do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g' 195do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
151 196
152gnunet-qr: gnunet-qr.py.in Makefile 197gnunet-qr: gnunet-qr.py.in Makefile
@@ -266,10 +311,6 @@ check_PROGRAMS = \
266 test_os_start_process \ 311 test_os_start_process \
267 test_common_logging_runtime_loglevels 312 test_common_logging_runtime_loglevels
268 313
269if ENABLE_TEST_RUN
270AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
271TESTS = $(check_PROGRAMS)
272endif
273 314
274# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart 315# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart
275# sequential execution order for them 316# sequential execution order for them