aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am83
1 files changed, 1 insertions, 82 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index df319fe77..4418fcfee 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -68,7 +68,6 @@ libgnunetutil_la_SOURCES = \
68 common_logging.c \ 68 common_logging.c \
69 configuration.c \ 69 configuration.c \
70 configuration_loader.c \ 70 configuration_loader.c \
71 connection.c \
72 container_bloomfilter.c \ 71 container_bloomfilter.c \
73 container_heap.c \ 72 container_heap.c \
74 container_meta_data.c \ 73 container_meta_data.c \
@@ -108,16 +107,10 @@ libgnunetutil_la_SOURCES = \
108 program.c \ 107 program.c \
109 resolver_api.c resolver.h \ 108 resolver_api.c resolver.h \
110 scheduler.c \ 109 scheduler.c \
111 server.c \
112 server_mst.c \
113 server_nc.c \
114 server_tc.c \
115 service.c \
116 service_new.c \ 110 service_new.c \
117 signal.c \ 111 signal.c \
118 strings.c \ 112 strings.c \
119 time.c \ 113 time.c \
120 socks.c \
121 speedup.c speedup.h 114 speedup.c speedup.h
122 115
123libgnunetutil_la_LIBADD = \ 116libgnunetutil_la_LIBADD = \
@@ -263,14 +256,13 @@ if HAVE_BENCHMARKS
263endif 256endif
264 257
265if HAVE_SSH_KEY 258if HAVE_SSH_KEY
266 SSH_USING_TESTS = test_socks.nc 259# SSH_USING_TESTS = test_socks.nc
267endif 260endif
268 261
269check_PROGRAMS = \ 262check_PROGRAMS = \
270 test_bio \ 263 test_bio \
271 test_client.nc \ 264 test_client.nc \
272 $(TEST_CLIENT_UNIX_NC) \ 265 $(TEST_CLIENT_UNIX_NC) \
273 $(SSH_USING_TESTS) \
274 test_common_allocation \ 266 test_common_allocation \
275 test_common_endian \ 267 test_common_endian \
276 test_common_logging \ 268 test_common_logging \
@@ -298,12 +290,6 @@ check_PROGRAMS = \
298 test_crypto_rsa \ 290 test_crypto_rsa \
299 test_disk \ 291 test_disk \
300 test_getopt \ 292 test_getopt \
301 test_connection.nc \
302 test_connection_addressing.nc \
303 test_connection_receive_cancel.nc \
304 test_connection_timeout.nc \
305 test_connection_timeout_no_connect.nc \
306 test_connection_transmit_cancel.nc \
307 test_mq \ 293 test_mq \
308 test_os_network \ 294 test_os_network \
309 test_peer \ 295 test_peer \
@@ -312,11 +298,6 @@ check_PROGRAMS = \
312 test_resolver_api.nc \ 298 test_resolver_api.nc \
313 test_scheduler \ 299 test_scheduler \
314 test_scheduler_delay \ 300 test_scheduler_delay \
315 test_server.nc \
316 test_server_disconnect.nc \
317 test_server_with_client.nc \
318 test_server_mst_interrupt.nc \
319 $(SERVER_CLIENT_UNIX) \
320 test_service \ 301 test_service \
321 test_strings \ 302 test_strings \
322 test_strings_to_data \ 303 test_strings_to_data \
@@ -337,11 +318,6 @@ test_connection_transmit_cancel.log: test_connection_timeout_no_connect.log
337test_connection_receive_cancel.log: test_connection_transmit_cancel.log 318test_connection_receive_cancel.log: test_connection_transmit_cancel.log
338test_connection_timeout.log: test_connection_receive_cancel.log 319test_connection_timeout.log: test_connection_receive_cancel.log
339test_resolver_api.log: test_connection_timeout.log 320test_resolver_api.log: test_connection_timeout.log
340test_server.log: test_resolver_api.log
341test_server_disconnect.log: test_server.log
342test_server_with_client.log: test_server_disconnect.log
343test_server_mst_interrupt.log: test_server_with_client.log
344test_client_unix.log: test_server_mst_interrupt.log
345 321
346test_bio_SOURCES = \ 322test_bio_SOURCES = \
347 test_bio.c 323 test_bio.c
@@ -518,36 +494,6 @@ test_getopt_SOURCES = \
518test_getopt_LDADD = \ 494test_getopt_LDADD = \
519 libgnunetutil.la 495 libgnunetutil.la
520 496
521test_connection_nc_SOURCES = \
522 test_connection.c
523test_connection_nc_LDADD = \
524 libgnunetutil.la
525
526test_connection_addressing_nc_SOURCES = \
527 test_connection_addressing.c
528test_connection_addressing_nc_LDADD = \
529 libgnunetutil.la
530
531test_connection_receive_cancel_nc_SOURCES = \
532 test_connection_receive_cancel.c
533test_connection_receive_cancel_nc_LDADD = \
534 libgnunetutil.la
535
536test_connection_timeout_nc_SOURCES = \
537 test_connection_timeout.c
538test_connection_timeout_nc_LDADD = \
539 libgnunetutil.la
540
541test_connection_timeout_no_connect_nc_SOURCES = \
542 test_connection_timeout_no_connect.c
543test_connection_timeout_no_connect_nc_LDADD = \
544 libgnunetutil.la
545
546test_connection_transmit_cancel_nc_SOURCES = \
547 test_connection_transmit_cancel.c
548test_connection_transmit_cancel_nc_LDADD = \
549 libgnunetutil.la
550
551test_mq_SOURCES = \ 497test_mq_SOURCES = \
552 test_mq.c 498 test_mq.c
553test_mq_LDADD = \ 499test_mq_LDADD = \
@@ -588,32 +534,6 @@ test_scheduler_delay_SOURCES = \
588test_scheduler_delay_LDADD = \ 534test_scheduler_delay_LDADD = \
589 libgnunetutil.la 535 libgnunetutil.la
590 536
591test_server_mst_interrupt_nc_SOURCES = \
592 test_server_mst_interrupt.c
593test_server_mst_interrupt_nc_LDADD = \
594 libgnunetutil.la
595
596test_server_nc_SOURCES = \
597 test_server.c
598test_server_nc_LDADD = \
599 libgnunetutil.la
600
601test_server_disconnect_nc_SOURCES = \
602 test_server_disconnect.c
603test_server_disconnect_nc_LDADD = \
604 libgnunetutil.la
605
606test_server_with_client_nc_SOURCES = \
607 test_server_with_client.c
608test_server_with_client_nc_LDADD = \
609 libgnunetutil.la
610
611test_server_with_client_unix_SOURCES = \
612 test_server_with_client_unix.c
613test_server_with_client_unix_LDADD = \
614 libgnunetutil.la
615
616
617test_service_SOURCES = \ 537test_service_SOURCES = \
618 test_service.c 538 test_service.c
619test_service_LDADD = \ 539test_service_LDADD = \
@@ -624,7 +544,6 @@ test_strings_SOURCES = \
624test_strings_LDADD = \ 544test_strings_LDADD = \
625 libgnunetutil.la 545 libgnunetutil.la
626 546
627
628test_strings_to_data_SOURCES = \ 547test_strings_to_data_SOURCES = \
629 test_strings_to_data.c 548 test_strings_to_data.c
630test_strings_to_data_LDADD = \ 549test_strings_to_data_LDADD = \