aboutsummaryrefslogtreecommitdiff
path: root/src/vpn/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/vpn/Makefile.am')
-rw-r--r--src/vpn/Makefile.am20
1 files changed, 2 insertions, 18 deletions
diff --git a/src/vpn/Makefile.am b/src/vpn/Makefile.am
index d1f74d35b..3ad9b1a54 100644
--- a/src/vpn/Makefile.am
+++ b/src/vpn/Makefile.am
@@ -1,11 +1,6 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include 2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
3 3
4if MINGW
5 WINFLAGS = -Wl,--no-undefined,--export-all-symbols
6 VPNBIN = gnunet-helper-vpn
7endif
8
9if USE_COVERAGE 4if USE_COVERAGE
10 AM_CFLAGS = --coverage -O0 5 AM_CFLAGS = --coverage -O0
11endif 6endif
@@ -39,20 +34,9 @@ libexec_PROGRAMS = \
39bin_PROGRAMS = \ 34bin_PROGRAMS = \
40 gnunet-vpn 35 gnunet-vpn
41 36
42if MINGW 37gnunet_helper_vpn_SOURCES = \
43 gnunet_helper_vpn_LDFLAGS = \ 38gnunet-helper-vpn.c
44 -no-undefined -Wl,--export-all-symbols
45
46 gnunet_helper_vpn_LDADD = \
47 -lsetupapi -lnewdev -lshell32 -liconv -lstdc++ \
48 -lcomdlg32 -lgdi32 -liphlpapi
49 39
50 gnunet_helper_vpn_SOURCES = \
51 gnunet-helper-vpn-windows.c
52else
53 gnunet_helper_vpn_SOURCES = \
54 gnunet-helper-vpn.c
55endif
56gnunet_service_vpn_SOURCES = \ 40gnunet_service_vpn_SOURCES = \
57 gnunet-service-vpn.c 41 gnunet-service-vpn.c
58gnunet_service_vpn_LDADD = \ 42gnunet_service_vpn_LDADD = \