aboutsummaryrefslogtreecommitdiff
path: root/src/vpn/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/vpn/Makefile.am')
-rw-r--r--src/vpn/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/vpn/Makefile.am b/src/vpn/Makefile.am
index 2cd798591..973efd0ec 100644
--- a/src/vpn/Makefile.am
+++ b/src/vpn/Makefile.am
@@ -20,6 +20,13 @@ VPNBIN = gnunet-helper-vpn
20install-exec-hook: 20install-exec-hook:
21 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-vpn || true 21 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-vpn || true
22 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-vpn || true 22 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-vpn || true
23if HAVE_MHD
24 VPN_TEST = \
25 test_gnunet_vpn-4_to_6 \
26 test_gnunet_vpn-6_to_4 \
27 test_gnunet_vpn-6_over \
28 test_gnunet_vpn-4_over
29endif
23else 30else
24install-exec-hook: 31install-exec-hook:
25endif 32endif
@@ -33,13 +40,6 @@ bin_PROGRAMS = \
33 $(VPNBIN) gnunet-service-vpn gnunet-vpn 40 $(VPNBIN) gnunet-service-vpn gnunet-vpn
34 41
35 42
36if HAVE_MHD
37 VPN_TEST = \
38 test_gnunet_vpn-4_to_6 \
39 test_gnunet_vpn-6_to_4 \
40 test_gnunet_vpn-6_over \
41 test_gnunet_vpn-4_over
42endif
43 43
44check_PROGRAMS = $(VPN_TEST) 44check_PROGRAMS = $(VPN_TEST)
45 45