aboutsummaryrefslogtreecommitdiff
path: root/src/zklaim/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/zklaim/Makefile.am')
-rw-r--r--src/zklaim/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/zklaim/Makefile.am b/src/zklaim/Makefile.am
new file mode 100644
index 000000000..44f016f2b
--- /dev/null
+++ b/src/zklaim/Makefile.am
@@ -0,0 +1,31 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if MINGW
5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
6endif
7
8if USE_COVERAGE
9 AM_CFLAGS = --coverage -O0
10 XLIB = -lgcov
11endif
12
13bin_PROGRAMS = \
14 gnunet-zklaim
15
16gnunet_zklaim_SOURCES = \
17 main.c
18gnunet_zklaim_LDFLAGS = -rdynamic
19gnunet_zklaim_LDADD = \
20 -lzklaim \
21 -lgcrypt \
22 -lsnark \
23 -lff \
24 -lgmp \
25 -lgmpxx \
26 -lcrypto \
27 -lprocps \
28 -lzm \
29 -lstdc++ \
30 -lm
31