summaryrefslogtreecommitdiff
path: root/doc/outdated-and-old-installation-instructions.txt
blob: f2cbe18472586cb141938d5f7424ad4bef151273 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
438
439
440
441
442
443
444
445
446
447
448
449
450
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
501
502
503
504
505
506
507
508
509
510
511
512
513
514
515
516
517
518
519
520
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540
541
542
543
544
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579
580
581
582
583
584
585
586
587
588
589
590
591
592
593
594
595
596
597
598
599
600
601
602
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
622
623
624
625
626
627
628
629
630
631
632
633
634
635
636
637
638
639
640
641
642
643
644
645
646
647
648
649
650
651
652
653
654
655
656
657
658
659
660
661
662
663
664
665
666
667
668
669
670
671
672
# This file contains pieces from chapter/installation.texi for systems where the LTS or otherwise support
# ended. They can be useful for people trying to write new installation instructions for those systems.
# In particual this covers:
# - FreeBSD 8
# - Mac OS X Tiger
# - Fedora 8
# - Gentoo with GNUnet 0.9
#
# Sources for LTS and support ranges:
# https://www.freebsd.org/security/security.html#sup
# https://support.microsoft.com/en-us/help/17140/lifecycle-faq-general-policy-questions
# Mac products, OS is supposedly similar (no official statements exist): https://web.archive.org/web/20160706101225/https://support.apple.com/en-us/HT201624
# https://wiki.debian.org/LTS
# https://www.ubuntu.com/info/release-end-of-life

@node Build instructions for Gentoo
@subsection Build instructions for Gentoo


This page describes how to install GNUnet 0.9 on Gentoo.

Since the GNUnet 0.9 ebuilds are not in the official portage tree yet, we need
to add them to the local portage overlay. All the commands below should be
executed as root.

Specify your local portage directory in the /etc/make.conf, for example:@
@code{$ echo 'PORTDIR_OVERLAY="/usr/local/portage"' >> /etc/make.conf}

Create directories for the ebuilds:@
@code{$ mkdir -p /usr/local/portage/media-libs/libextractor /usr/local/portage/net-p2p/gnunet/files}

Download the latest ebuilds, init and config files from here and put them into
respective directories:@
@code{$ cp libextractor-0.6.2.ebuild /usr/local/portage/media-libs/libextractor@
 $ cp gnunet-0.9.2.ebuild /usr/local/portage/net-p2p/gnunet@
 $ cp gnunet-0.9.2.conf gnunet-0.9.2.confd gnunet-0.9.2.initd /usr/local/portage/net-p2p/gnunet/files}

Generate Manifest files for the ebuilds:@
@code{$ cd /usr/local/portage/net-p2p/gnunet@
 $ ebuild gnunet-0.9.2.ebuild digest@
 $ cd /usr/local/portage/media-libs/libextractor@
 $ ebuild libextractor-0.6.2.ebuild digest}

Unmask GNUnet and dependencies in the /etc/portage/package.keywords. For
example, if you use x86-64 architecture, add the following lines:@
@code{net-p2p/gnunet ~amd64@
 media-libs/libextractor ~amd64@
 net-libs/libmicrohttpd ~amd64@
 net-misc/curl ~amd64}

Add either sqlite or mysql USE-flag in the /etc/portage/package.use:@
@code{net-p2p/gnunet sqlite}

Now everything is ready to install GNUnet:@
@code{$ emerge -av gnunet}

Use /etc/init.d/gnunet to start/stop GNUnet.




@node Basic Installation for Fedora/PlanetLab nodes running Fedora 8 .
@subsection Basic Installation for Fedora/PlanetLab nodes running Fedora 8 .
@c %**end of header

@strong{This documentation is outdated and not valid for GNUnet 0.10.0!}@
 GNUnet installation on Fedora 8/Planetlab nodes can be done as following:

1. Install the build tools to build GNUnet@
@example
sudo yum -y -t --nogpgcheck install gcc make automake autoconf gettext-devel \
texinfo zlib-devel subversion@
@end example

2. Install the GNUnet dependencies@
@example
sudo yum -y -t --nogpgcheck install gnutls-devel gnutls-devel libgcrypt-devel \
sqlite-devel postgresql-devel mysql-devel libgsf-devel libvorbis-devel \
libidn-devel
@end example

3. Install outdated dependencies from source@
 libtool@
@code{@
 wget http://ftp.gnu.org/gnu/libtool/libtool-2.4.2.tar.gz@
 tar xvfz libtool-2.4.2.tar.gz@
 cd libtool-2.4.2@
 ./configure@
 sudo make install@
}

libtool@
@code{@
 wget http://ftp.gnu.org/gnu/libtool/libtool-2.4.2.tar.gz@
 tar xvfz libtool-2.4.2.tar.gz@
 cd libtool-2.4.2@
 ./configure@
 sudo make install@
}

glpk@
@code{@
 wget http://ftp.gnu.org/gnu/glpk/glpk-4.47.tar.gz@
 tar xvfz glpk-4.47.tar.gz@
 cd glpk-4.47@
 ./configure@
 sudo make install@
}

libgpg-error@
@code{@
 wget ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-1.10.tar.bz2@
 tar xvfj libgpg-error-1.10.tar.bz2@
 cd libgpg-error-1.10@
 ./configure --prefix=/usr@
 sudo make install@
}

libgcrypt@
@code{@
 wget ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-1.5.0.tar.bz2@
 tar xvfj libgcrypt-1.5.0.tar.tar.bz2@
 cd libgcrypt-1.5.0@
 ./configure --prefix=/usr@
 sudo make install@
}

libcurl@
@code{@
 wget http://curl.haxx.se/download/curl-7.26.0.tar.gz@
 tar xvfz curl-7.26.0.tar.gz@
 cd curl-7.26.0@
 ./configure@
 sudo make install@
}

libunistring@
@code{@
 wget http://ftp.gnu.org/gnu/libunistring/libunistring-0.9.3.tar.gz@
 tar xvfz libunistring-0.9.3.tar.gz@
 cd libunistring-0.9.3@
 ./configure@
 sudo make install@
}

4. Remove conflicting packages@
@code{@
 sudo rpm -e --nodeps libgcrypt libgpg-error@
}

4. Install libextractor@
@code{@
 wget ftp://ftp.gnu.org/gnu/libextractor/libextractor-0.6.3.tar.gz@
 tar xvfz libextractor-0.6.3.tar.gz@
 cd libextractor-0.6.3@
 ./configure@
 sudo make install@
}

5. Install libmicrohttpd and dependencies

nettle@
@code{@
 wget http://ftp.gnu.org/gnu/nettle/nettle-2.5.tar.gz@
 tar xvfz nettle-2.5.tar.gz@
 cd nettle-2.5@
 ./configure@
 sudo make install@
}

GnuTLS@
@code{@
 wget http://ftp.gnu.org/gnu/gnutls/gnutls-2.12.20.tar.bz2@
 tar xvfj gnutls-2.12.20.tar.bz2@
 cd gnutls-2.12.20@
 ./configure --without-p11-kit@
 sudo make install@
}

libmicrohttpd@
@code{@
 wget ftp://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-0.9.21.tar.gz@
 tar xvfz libmicrohttpd-0.9.21.tar.gz@
 cd libmicrohttpd-0.9.21@
 ./configure@
 sudo make install@
}

6. Set GNUnet prefix and add to PATH@
@code{@
 export GNUNET_PREFIX=@
 export PATH=$PATH:$GNUNET_PREFIX/bin@
}

7. Install GNUnet from svn@
@example
 export LD_LIBRARY_PATH=/usr/local/lib@
 svn co https://gnunet.org/svn/gnunet@
 cd gnunet@
 libtoolize@
 ./bootstrap@
 ./configure --prefix=$GNUNET_PREFIX --with-extractor=/usr/local \
 --with-curl=/usr/local --with-mysql=/usr/lib/mysql --enable-logging=verbose@
 make install@
@end example

Done!


@node Build instructions for FreeBSD 8
@subsection Build instructions for FreeBSD 8

To get GNUnet 0.9 to compile on FreeBSD (at least FreeBSD 8.0):@ in order to
install the library @code{libiconv}, at first change the directory to your
ports directory, e.g.@
@code{@
 $ cd /usr/ports/@
}@
 following that, go to the install file of @code{libiconv} and install it,@
@code{@
 $ cd converters/libiconv,@
 $ make install@
}

after that, change the directory to where you will check out
@code{libextractor} and GNUnet, and install latest @code{libextractor},@
 first of all, checkout @code{libextractor}, e.g.@
@code{@
 $ svn co https://gnunet.org/svn/Extractor@
}@
 then change the directory into which it was checked out, e.g.@
@code{@
 $ cd Extractor@
}@
 before the installation, you should do following steps,@

@example
$ ./bootstrap@
$ ./configure --with-ltdl-include=/usr/local/include \
  --with-ltdl-lib=/usr/local/lib@
@end example

if these steps complete successfully, you can install the library,@

@example
$ make install@
@end example

to check out the GNUnet, you should do the similar steps as
@code{libextractor}, firstly, change back to starting directory, e.g.@
@code{@
 $ cd ../@
}@
 Set the following environmental variables:@
@code{@
 export CPPFLAGS="-I/usr/local/include"@
 export LDFLAGS="-L/usr/local/lib"@
}@
 next, checkout GNUnet using@
@code{@
 $ svn co https://gnunet.org/svn/gnunet@
}@
 then change directory into newly checked out directory,@
@code{@
 $ cd gnunet@
}@
 at last, start to install GNUnet,@

@example
 $ ./bootstrap@
 $ ./configure --with-ltdl-include=/usr/local/include \
   --with-ltdl-lib=/usr/local/lib --with-extractor=/usr/local

## NOTE: you may not need the --with-extractor option!@

$ make install
@end example



@node Basic installation for Mac OS X
@subsection Basic installation for Mac OS X

This documentation may be outdated!

This page is providing guidelines for users trying to install GNUnet on Mac OS
X.@ Mainly users trying to install GNUnet by building source code are the most
welcome readers.@ The steps below are tested on an Intel Architecture running
Mac OS X Tiger (10.4.11). Ideally they should work on other Mac boxes with
different configurations as all the configuration done for it is dependent on
@uref{http://www.macports.org/, MacPorts}

For having GNUnet installed successfully, some dependencies should be firstly
resolved:

@itemize @bullet

@item
Install/Update your @uref{http://developer.apple.com/tools/xcode/, Xcode}
version 3.2.1 or later for Snow Leopard, 3.1.4 or later for Leopard, or 2.5 for
Tiger. 

@item
Download and install @uref{http://www.macports.org/, MacPorts}.@
Now you are ready for installing GNunet dependencies. 

@item
First, you'd better make sure that: /opt/local/bin and /opt/local/sbin are
available in your PATH. (For doing so, open a terminal and type:@

@example 
$ echo $PATH 
@end example

and examine the output of it). If the paths are not available in your
environment, you have to add them (You can add them by editing your .profile
file in your home directory, append them to the PATH line). Then type:
@example
$ source ~/.profile
@end example

and re-examine the echo command output.

@item
Use MacPorts to download and install the dependencies:@
The libraries are: 

@itemize @bullet

@item
@uref{http://trac.macports.org/browser/trunk/dports/www/libmicrohttpd/Portfile, libmicrohttpd.}

@item
@uref{http://trac.macports.org/browser/trunk/dports/devel/libgcrypt/Portfile, libgcrypt.}

@item
@uref{http://trac.macports.org/browser/trunk/dports/net/curl/Portfile, libcurl.}

@item
@uref{http://trac.macports.org/browser/trunk/dports/devel/libtool/Portfile, libltdl.}

@item
@uref{http://trac.macports.org/browser/trunk/dports/databases/sqlite3/Portfile, SQlite.}

@item
libunistring 

@item
glpk 

@end itemize

The port command is as follows:@
@example
port install libmicrohttpd libgcrypt curl libtool sqlite3 linunistring glpk
@end example
One of the dependencies, the libextractor, should be explicitly installed,
since the version available from macports is outdated to work with GNUnet. To
install the latest libextractor:
@itemize @bullet


@item
Install the Subversion Client:@
For more information about Subversion visit:
@uref{http://subversion.tigris.org/, http://subversion.tigris.org/}

@example
# port install subversion
@end example


@item
Use Subversion to download the latest Extractor: 
@example
$ svn checkout https://gnunet.org/svn/Extractor
@end example


@item
Go to the installation directory of the Extractor, compile and install it: 
@example
$ ./bootstrap
$ export CPPFLAGS="-I/opt/local/include"
$ export  LDFLAGS="-L/opt/local/lib" 
$ ./configure --prefix=/opt/local
$ make
# make install
@end example

@end itemize


@item
Now, your system is ready to install GNunet. If you downloaded GNUnet by
checking it out from svn, you should start by running the bootstrap script.
Open a terminal pointing to the GNUnet directory and type:@

@example
$ ./bootstrap
@end example


@item
Run the configure script: 
@example
$ export CPPFLAGS="-I/opt/local/include" 
$ export LDFLAGS="-L/opt/local/lib" 
$ ./configure --prefix=/tmp/gnunet_build
@end example


GNUnet will be installed in the directory /tmp/gnunet_build (Of course that
installation path can be changed).@ The CPPFLAGS and LDFLAGS are mentioned in
order to inform the compiler and the linker to lookup headers and libraries in
/opt/local/include and /opt/local/lib.

@item
Compile@

@example
$ make
@end example


@item
Install GNUnet 
@example
# make install
@end example

@end itemize


@node Basic Installation for Fedora/PlanetLab nodes running Fedora 12
@subsection Basic Installation for Fedora/PlanetLab nodes running Fedora 12


@strong{This documentation is outdated and not valid for GNUnet 0.10.0!}@

GNUnet installation on Fedora 8/Planetlab nodes can be done as following:

1. Install the build tools to build GNUnet@
@example
sudo yum -y -t --nogpgcheck install gcc make autoconf gettext-devel \
texinfo subversion@
@end example

2. Install the GNUnet dependencies@
@example
sudo yum -y -t --nogpgcheck install libunistring-devel libunistring-devel \
libgcrypt-devel zlib-devel sqlite-devel postgresql-devel mysql-devel \
libgsf-devel libvorbis-devel@
@end example

3. Install outdated dependencies from source@
libtool@
@example
wget http://ftp.gnu.org/gnu/libtool/libtool-2.4.2.tar.gz@
tar xvfz libtool-2.4.2.tar.gz@
cd libtool-2.4.2@
./configure@
sudo make install@
@end example

glpk@
@example
wget http://ftp.gnu.org/gnu/glpk/glpk-4.47.tar.gz@
tar xvfz glpk-4.47.tar.gz@
cd glpk-4.47@
./configure@
sudo make install@
@end example

libcurl@
@example
wget http://curl.haxx.se/download/curl-7.26.0.tar.gz@
tar xvfz curl-7.26.0.tar.gz@
cd curl-7.26.0@
./configure@
sudo make install@
@end example

4. Install libextractor@
@example
svn co https://gnunet.org/svn/libextractor@
cd libextractor@
libtoolize@
./bootstrap@
./configure@
sudo make install@
@end example

5. Install libmicrohttpd@
@example
svn co https://gnunet.org/svn/libmicrohttpd@
cd libmicrohttpd@
libtoolize@
./bootstrap@
./configure@
sudo make install@
@end example

6. Set GNUnet prefix and add to PATH@
@example
export GNUNET_PREFIX=@
export PATH=$PATH:$GNUNET_PREFIX/bin@
@end example

7. Install GNUnet from svn@
@example
export LD_LIBRARY_PATH=/usr/local/lib@
svn co https://gnunet.org/svn/gnunet@
cd gnunet@
libtoolize@
./bootstrap@
./configure --prefix=$GNUNET_PREFIX --with-extractor=/usr \
 --with-mysql=/usr/lib/mysql --enable-logging=verbose@
make install@
@end example

Done!


@node Basic Installation for Fedora/PlanetLab nodes running Fedora 8 .
@subsection Basic Installation for Fedora/PlanetLab nodes running Fedora 8 .
@c %**end of header

@strong{This documentation is outdated and not valid for GNUnet 0.10.0!}@
 GNUnet installation on Fedora 8/Planetlab nodes can be done as following:

1. Install the build tools to build GNUnet@
@example
sudo yum -y -t --nogpgcheck install gcc make automake autoconf gettext-devel \
texinfo zlib-devel subversion@
@end example

2. Install the GNUnet dependencies@
@example
sudo yum -y -t --nogpgcheck install gnutls-devel gnutls-devel libgcrypt-devel \
sqlite-devel postgresql-devel mysql-devel libgsf-devel libvorbis-devel \
libidn-devel
@end example

3. Install outdated dependencies from source@
 libtool@
@code{@
 wget http://ftp.gnu.org/gnu/libtool/libtool-2.4.2.tar.gz@
 tar xvfz libtool-2.4.2.tar.gz@
 cd libtool-2.4.2@
 ./configure@
 sudo make install@
}

libtool@
@code{@
 wget http://ftp.gnu.org/gnu/libtool/libtool-2.4.2.tar.gz@
 tar xvfz libtool-2.4.2.tar.gz@
 cd libtool-2.4.2@
 ./configure@
 sudo make install@
}

glpk@
@code{@
 wget http://ftp.gnu.org/gnu/glpk/glpk-4.47.tar.gz@
 tar xvfz glpk-4.47.tar.gz@
 cd glpk-4.47@
 ./configure@
 sudo make install@
}

libgpg-error@
@code{@
 wget ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-1.10.tar.bz2@
 tar xvfj libgpg-error-1.10.tar.bz2@
 cd libgpg-error-1.10@
 ./configure --prefix=/usr@
 sudo make install@
}

libgcrypt@
@code{@
 wget ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-1.5.0.tar.bz2@
 tar xvfj libgcrypt-1.5.0.tar.tar.bz2@
 cd libgcrypt-1.5.0@
 ./configure --prefix=/usr@
 sudo make install@
}

libcurl@
@code{@
 wget http://curl.haxx.se/download/curl-7.26.0.tar.gz@
 tar xvfz curl-7.26.0.tar.gz@
 cd curl-7.26.0@
 ./configure@
 sudo make install@
}

libunistring@
@code{@
 wget http://ftp.gnu.org/gnu/libunistring/libunistring-0.9.3.tar.gz@
 tar xvfz libunistring-0.9.3.tar.gz@
 cd libunistring-0.9.3@
 ./configure@
 sudo make install@
}

4. Remove conflicting packages@
@code{@
 sudo rpm -e --nodeps libgcrypt libgpg-error@
}

4. Install libextractor@
@code{@
 wget ftp://ftp.gnu.org/gnu/libextractor/libextractor-0.6.3.tar.gz@
 tar xvfz libextractor-0.6.3.tar.gz@
 cd libextractor-0.6.3@
 ./configure@
 sudo make install@
}

5. Install libmicrohttpd and dependencies

nettle@
@code{@
 wget http://ftp.gnu.org/gnu/nettle/nettle-2.5.tar.gz@
 tar xvfz nettle-2.5.tar.gz@
 cd nettle-2.5@
 ./configure@
 sudo make install@
}

GnuTLS@
@code{@
 wget http://ftp.gnu.org/gnu/gnutls/gnutls-2.12.20.tar.bz2@
 tar xvfj gnutls-2.12.20.tar.bz2@
 cd gnutls-2.12.20@
 ./configure --without-p11-kit@
 sudo make install@
}

libmicrohttpd@
@code{@
 wget ftp://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-0.9.21.tar.gz@
 tar xvfz libmicrohttpd-0.9.21.tar.gz@
 cd libmicrohttpd-0.9.21@
 ./configure@
 sudo make install@
}

6. Set GNUnet prefix and add to PATH@
@code{@
 export GNUNET_PREFIX=@
 export PATH=$PATH:$GNUNET_PREFIX/bin@
}

7. Install GNUnet from svn@
@example
 export LD_LIBRARY_PATH=/usr/local/lib@
 svn co https://gnunet.org/svn/gnunet@
 cd gnunet@
 libtoolize@
 ./bootstrap@
 ./configure --prefix=$GNUNET_PREFIX --with-extractor=/usr/local \
 --with-curl=/usr/local --with-mysql=/usr/lib/mysql --enable-logging=verbose@
 make install@
@end example

Done!