aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 3 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 456287a..8005a39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -667,17 +667,11 @@ AS_IF([test x$ffmpeg_enabled = x1],
667 [ffmpeg_enabled=0 667 [ffmpeg_enabled=0
668 new_ffmpeg=0 668 new_ffmpeg=0
669 AC_CHECK_HEADERS([libavutil/avutil.h libavformat/avformat.h libavcodec/avcodec.h libavutil/frame.h], 669 AC_CHECK_HEADERS([libavutil/avutil.h libavformat/avformat.h libavcodec/avcodec.h libavutil/frame.h],
670 AC_CHECK_HEADERS([libavresample/avresample.h], 670 AC_CHECK_HEADERS([libswresample/swresample.h],
671 AC_CHECK_LIB(avutil, av_audio_fifo_alloc, 671 AC_CHECK_LIB(avutil, av_audio_fifo_alloc,
672 new_ffmpeg=1))) 672 ffmpeg_enabled=1)))
673
674 AC_CHECK_LIB(swscale, sws_getContext,
675 AC_CHECK_LIB(avcodec, avcodec_alloc_context3,
676 ffmpeg_enabled=1))
677 AC_CHECK_HEADERS([libavutil/avutil.h ffmpeg/avutil.h libavformat/avformat.h ffmpeg/avformat.h libavcodec/avcodec.h ffmpeg/avcodec.h libswscale/swscale.h ffmpeg/swscale.h])
678 ]) 673 ])
679AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0) 674AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0)
680AM_CONDITIONAL(HAVE_FFMPEG_NEW, test x$new_ffmpeg != x0)
681 675
682 676
683LE_INTLINCL="" 677LE_INTLINCL=""
@@ -776,10 +770,7 @@ AS_IF([test "x$have_gsf" != "xtrue"],
776 [AC_MSG_NOTICE([NOTICE: libgsf not found, no OLE2 (MS Office) support])]) 770 [AC_MSG_NOTICE([NOTICE: libgsf not found, no OLE2 (MS Office) support])])
777 771
778AS_IF([test "x$ffmpeg_enabled" = "x0"], 772AS_IF([test "x$ffmpeg_enabled" = "x0"],
779 [AC_MSG_NOTICE([NOTICE: FFmpeg thumbnailer plugin disabled])]) 773 [AC_MSG_NOTICE([NOTICE: FFmpeg/opus audito thumbnailer plugin disabled])])
780
781AS_IF([test "x$new_ffmpeg" = "x0"],
782 [AC_MSG_NOTICE([NOTICE: FFmpeg/opus audio preview plugin disabled, It needs libav >= 10, or a FFmpeg with --enable-libavresample])])
783 774
784AS_IF([test "x$have_gdk_pixbuf" = "x0"], 775AS_IF([test "x$have_gdk_pixbuf" = "x0"],
785 [AC_MSG_NOTICE([NOTICE: libgdk-pixbuf not found, gtk thumbnail support disabled])]) 776 [AC_MSG_NOTICE([NOTICE: libgdk-pixbuf not found, gtk thumbnail support disabled])])