summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 3 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 456287a..8005a39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -667,17 +667,11 @@ AS_IF([test x$ffmpeg_enabled = x1],
[ffmpeg_enabled=0
new_ffmpeg=0
AC_CHECK_HEADERS([libavutil/avutil.h libavformat/avformat.h libavcodec/avcodec.h libavutil/frame.h],
- AC_CHECK_HEADERS([libavresample/avresample.h],
+ AC_CHECK_HEADERS([libswresample/swresample.h],
AC_CHECK_LIB(avutil, av_audio_fifo_alloc,
- new_ffmpeg=1)))
-
- AC_CHECK_LIB(swscale, sws_getContext,
- AC_CHECK_LIB(avcodec, avcodec_alloc_context3,
- ffmpeg_enabled=1))
- AC_CHECK_HEADERS([libavutil/avutil.h ffmpeg/avutil.h libavformat/avformat.h ffmpeg/avformat.h libavcodec/avcodec.h ffmpeg/avcodec.h libswscale/swscale.h ffmpeg/swscale.h])
+ ffmpeg_enabled=1)))
])
AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0)
-AM_CONDITIONAL(HAVE_FFMPEG_NEW, test x$new_ffmpeg != x0)
LE_INTLINCL=""
@@ -776,10 +770,7 @@ AS_IF([test "x$have_gsf" != "xtrue"],
[AC_MSG_NOTICE([NOTICE: libgsf not found, no OLE2 (MS Office) support])])
AS_IF([test "x$ffmpeg_enabled" = "x0"],
- [AC_MSG_NOTICE([NOTICE: FFmpeg thumbnailer plugin disabled])])
-
-AS_IF([test "x$new_ffmpeg" = "x0"],
- [AC_MSG_NOTICE([NOTICE: FFmpeg/opus audio preview plugin disabled, It needs libav >= 10, or a FFmpeg with --enable-libavresample])])
+ [AC_MSG_NOTICE([NOTICE: FFmpeg/opus audito thumbnailer plugin disabled])])
AS_IF([test "x$have_gdk_pixbuf" = "x0"],
[AC_MSG_NOTICE([NOTICE: libgdk-pixbuf not found, gtk thumbnail support disabled])])